AwoCoupon no guarda el cupón [Solucionado]  

 
Claudio
 Claudio
Usuario eminente

Buenas noches, he instalado Awocupon para cupones descuentos, el componente parece muy intuitivo y se instala correctamente pero, aparte de tener el backend en inglés (eso no sería un problema), en el momento en que introduzco un cupón antes de comprar y le doy a GUARDAR, no se aplica el cupón al precio final. Ni siquiera me da un mensaje, como si el botón no funcionara. La versión de Virtuemart es la 2.6.6 y la de awocupon la 2.0.17. ¿A alguien le había pasado antes o me puede ayudar? Muchas gracias!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 24/05/2015 10:56 pm
Julen
 Julen
Miembro Admin

Hola,

Haciendo pruebas en tu web da la sensación de que el problema está en que el botón de procesar el cupón no funciona, por lo que lo más probable es que el error esté en la plantilla del carro de compra.

Vete al directorio templates/anthe/html/com_virtuemart/cart de tu web y renombra el archivo default.php como default_BAK.php.

Una vez hecho esto, realiza una nueva prueba y comprueba si ahora funciona el cupón.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/05/2015 10:09 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Claudio
 Claudio
Usuario eminente

Hola, gracias por la rápida respuesta. He renombrado el archivo y he realizado la prueba, pero no ha cambiado nada. Sigue sin funcionar.

ResponderCitar
Respondido : 25/05/2015 8:51 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba renombrar temporalmente la carpeta padre

templates/anthe/html/com_virtuemart

POr ejemplo por :

templates/anthe/html/bac_com_virtuemart

Esto con la finalidad de descarta un problema con el overrides de la plantilla.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/05/2015 12:46 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Claudio
 Claudio
Usuario eminente

Gracias por la respuesta. He renombrado la carpeta como indicas y sigue sin funcionar. Un saludo.

ResponderCitar
Respondido : 26/05/2015 1:19 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Prueba a desactivar el componente esto con la finalidad de verificar si funciona el cupón que tiene el propio Virtuemart.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/05/2015 6:40 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Claudio
 Claudio
Usuario eminente

Gracias por el mensaje. Me he ido a plugins y he desactivado todo, tampoco funciona en Virtuemart. Escribí en inglés al fabricante del componente Awocupon y me contestaron que el problema parece ser de Virtuemart. Me aconsejaron realizar este cambio, aquí está el hilo: https://awodev.com/forum/awocoupon/help-section/save-button-doesnt-work-when-i-introduce-coupon#comment-8290
...pero tampoco ha funcionado.

ResponderCitar
Respondido : 26/05/2015 9:29 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Para realizar una prueba y comprobar si el problema es de Virtuemart te recomiendo instalar un Pack básico de Joomla en otro directorio, luego descarga la ultima versión de Virtuemart y procede a instalarlo en ese Pack.

Comprueba primero si funciona el cupón que trae por defecto Virtuemart, luego procede a instalar el componente AwoCoupon y verifica si funciona sin problemas.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/05/2015 1:27 am

Cursos Gratuitos WordPress

Claudio
 Claudio
Usuario eminente

Gracias por tu respuesta, Johnny. La respuesta que me han dado es la siguiente:

"The problem you are having is a virtuemart problem and regardless of if you have AwoCoupon installed or any other coupon plugins you would still receive it. There is a submit button to submit a coupon, but the problem is there is no form around this button."

Supongo que se refieren a la versión de virtuemart instalada en la plantilla que tengo actualmente. Si instalo un Joomla nuevo, con la última versión de Virtuemart me imagino que funcionaría.

"the problem is there is no form around this button." Alguna idea sobre como solucionarlo?

Gracias de antemano.

ResponderCitar
Respondido : 27/05/2015 6:56 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Descativando el plugin la funcionalidad de cupones que tiene por defect o virtuemart igualmente no te funciona?

Tendrías que probar lo que te comentó Johnny de otra instalación y verificar si te sucede lo mismo, prueba instalar otro pack en una carpeta y verifica

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/05/2015 8:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Claudio
 Claudio
Usuario eminente

Correcto, desactivando el plugin igualmente no me funciona. Haré la instalación en otra carpeta, aunque me imagino que no pasará lo mismo. Gracias!!

ResponderCitar
Respondido : 27/05/2015 8:44 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En la nueva instalación primero prueba sin instalar awcopon

Asegurate que esa el mismo pack que estas usando y luego ve comprobando una a una las configuraciones que tengas en el que no te funciona si tienes alguna extensión también podrías instalarla, la idea es aislar el problema y ver por que no te funciona.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/05/2015 10:12 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Claudio
 Claudio
Usuario eminente

Buenos días y gracias por la ayuda. Fue un error mío a la hora de verificar la solución del problema (las prisas no son buenas)

La solución fue: renombrar temporalmente la carpeta padre

templates/anthe/html/com_virtuemart por :

templates/anthe/html/bac_com_virtuemart

Muchas gracias, un saludo.

ResponderCitar
Respondido : 01/06/2015 12:19 pm
Rafael
 Rafael
Miembro Moderator

¡Hola Claudio!

Gracias por tu confianza y aportación al foro :).

Nos alegra que te guste nuestro servicio. 🙂

Nos sería de mucha utilidad que nos dejases tu testimonio, solicitamos testimonios para colocar en nuestra página y ayudar a otros posibles clientes a decidirse por nuestros servicios:

Puedes crear el testimonio aquí: https://www.webempresa.com/testimonios.html?view=form&layout=edit

Si nos quieres enviar tu experiencia con nuestro servicio, la publicaremos en nuestra página con un link hacia tu Web que siempre te ayudará a posicionarse, nuestra página tiene un Page Rank de Google alto.

Si ya lo solicitamos anteriormente y nos lo facilitaste, puedes dejar otro testimonio si tienes otra página que quieras posicionar mejor al tener un link en la nuestra con tu testimonio.

Gracias por publicar tu testimonio y por tus palabras de agradecimiento.

Procedemos a cerrar hilo.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/06/2015 12:28 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro