Cambio de Idioma en detalles de Producto  

Página 1 / 2
 
Carlos
 Carlos
Reputable Member

Hola:

Estoy tratando de cambiar el idioma del Ingles al Español en los detalles del Producto, cuando pinchas sobre un producto para ver en detalle las caracteristicas sale en Ingles y no logro encontrar desde donde se puede cambiar estas cabeceras. ver imagen:

Espero su ayuda, gracias.
Un saludo
Carlos

URL del sitio: http://presume1-cp56.webjoomla.es/index.php/online-shop/recien-nacido/ofertas-julio/prueba-fechas-detail

Citar
Respondido : 01/08/2012 10:46 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Carlos,

Entiendo que has instalado VirtueMart desde los archivos "oficiales" del componente que por defecto están en Inglés ¿correcto?.

Veo que tu plantilla no es de ningún Pack de Webempresa por lo que deduzco que inicialmente la tienes en inglés.

Estas publicando en la categoría del Foro "Noticias Webempresa" y es complicado saber que versión de VirtueMart estás utilizando a menos que nos lo digas.

Agradecemos que cuando publiques consultas en el Foro lo hagas en la categoría adecuada.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/08/2012 10:56 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Carlos
 Carlos
Reputable Member

Hola Luis:

No se que ha pasado, crei que estaba publicando en la categoria de Virtuemar 2.0, fue un despiste, pero bueno abro un nuevo tema, diculpa el error.

Los archivos son Oficiales

Un saludo
Carlos

ResponderCitar
Respondido : 01/08/2012 11:26 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Carlos,

Movimos el tema a la categoría adecuada. Sobre la consulta verifica que tengas en tu gestor de idiomas seleccionado el idioma español por defecto, te adjunto una captura para mejor visualización:

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/08/2012 12:22 am

Cursos Gratuitos WordPress

Carlos
 Carlos
Reputable Member

Hola Jonhy,

Gracias por su respuesta, antes de nada, como Luis me comento lo de la categoría del foro, he creado un nuevo tema con la categoría correspondiente, por lo que estará duplicada la consulta...

Dicho esto te comento al respecto, que he cambiado el idioma predeterminado a Español y lo curioso en que desaparece la columna izquierda de Categorías, y el slide no se abre en la pagina de inicio, y el resto de la web no aparece tampoco categorias ni productos. ver imagenes....

Entonces vuelvo a poner el ingles como idioma predeterminado y todo vuelve a funcionar correctamente, pero claro, los encabezados de los productos vuelven al Ingles.

Que puedo hacer, si ya instale la version en Español, gracias.
Un saludo
Carlos

ResponderCitar
Respondido : 02/08/2012 12:37 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Carlos,

Te recomiendo la siguiente "obligada" lectura si quieres entender como funcionan los Multiidiomas en Joomla! 2.5:

- Idiomas en Joomla 1.7 (multi-idioma): https://www.webempresa.com/blog/item/515-idiomas-en-joomla-17-multi-idioma.html - (válido para Joomla! 2.5)

Aunque el artículo haga referencia a Joomla! 1.7 se aplica de igual forma para Joomla! 2.5.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/08/2012 12:42 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Carlos
 Carlos
Reputable Member

Hola de nuevo:

Estoy siguiendo los pasos descritos en el video y cuando verifico en el apartaod de idioma la pestaña de contenido para ver que tambien esta en Español, me da el siguiente error:

500 - Se ha producido un error.

Unknown column 'a.access' in 'on clause' SQL=SELECT a.*,ag.title AS access_level,l.home AS home FROM `web1_languages` AS a LEFT JOIN web1_viewlevels AS ag ON ag.id = a.access LEFT JOIN `web1_menu` AS l ON l.language = a.lang_code AND l.home=1 AND l.language '*' WHERE (a.published IN (0, 1)) ORDER BY a.title asc Unknown column 'a.access' in 'on clause' SQL=SELECT a.*,ag.title AS access_level,l.home AS home FROM `web1_languages` AS a LEFT JOIN web1_viewlevels AS ag ON ag.id = a.access LEFT JOIN `web1_menu` AS l ON l.language = a.lang_code AND l.home=1 AND l.language '*' WHERE (a.published IN (0, 1)) ORDER BY a.title asc LIMIT 0, 20 Unknown column 'a.access' in 'on clause' SQL=SELECT a.*,ag.title AS access_level,l.home AS home FROM `web1_languages` AS a LEFT JOIN web1_viewlevels AS ag ON ag.id = a.access LEFT JOIN `web1_menu` AS l ON l.language = a.lang_code AND l.home=1 AND l.language '*' WHERE (a.published IN (0, 1)) ORDER BY a.title asc

Volver al panel de control

ResponderCitar
Respondido : 02/08/2012 12:57 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Carlos,

Y si no es mucho pedir ¿podrías adjuntar ese mismo error en una captura? así vemos el contexto en el que se produce.

Gracias y saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/08/2012 1:14 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Carlos
 Carlos
Reputable Member

Hola Luis;
Paso esquema de la captura por pasos, he seguido las instrucciones del video, y siguiendo los pasos indicados el resultado es que en el tercer paso cuando pincho en "contenido" me da el error.
Adjunto imagen:

ResponderCitar
Respondido : 02/08/2012 1:25 am
Carlos
 Carlos
Reputable Member

Adjunto imagen mas grande del detalle del error para que se vea mejor.

ResponderCitar
Respondido : 02/08/2012 1:27 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Carlos,

Veo que utilizas una instalación de Joomla que no procede de un pack de Webempresa ¿correcto?.

Te propongo una tarea, a ver que te parece:

1. Copia de seguridad de tu sitio con Akeeba Backup.
2. Descargar el archivo de la copia a tu PC y eliminarlo del servidor.
3. Ir al gestor de Idiomas y establecer para el frontend y backend el idioma Ingles (en-GB).
4. I al Gestor de Extensiones, Gestionar, filtrar por Idiomas:

5. Seleccionar el idioma Español del front y back y desinstalarlos.
6. Descargar de JoomlaSpanish el archivo de idioma para tu versión de Joomla (entiendo que usas Joomla! 2.5.6)

- http://joomlacode.org/gf/download/frsrelease/17183/74771/es-ES_joomla2.5.6_front_admin.zip

7. Gestor de Extensiones, Instalar, seleccionar el archivo de idioma descargado y lo instalas.
8. Gestor de Idiomas, habilitas Español para el frontend y backend nuevamente y verificas que todo funciona correctamente.

Vuelves a probar lo que hiciste antes a ver si te da nuevamente el error de sql.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/08/2012 1:39 am
Carlos
 Carlos
Reputable Member

Tomo nota;

Pero como hago la copia de seguridad, donde encuentro Akeeba Backup. en el Cpanel?

ResponderCitar
Respondido : 02/08/2012 1:44 am

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Carlos,

Te recomiendo visitar con frecuencia el Blog de Webempresa, publicamos regularmente artículos de interés como el siguiente:

- https://www.webempresa.com/blog/item/906-liberado-akeeba-backup-360-para-joomla-25-con-interfaz-mejorada-basada-en-bootstrap.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/08/2012 1:53 am
Carlos
 Carlos
Reputable Member

Perdona, busque despues de la consulta,.... ya lo tengo instalado
Gracias y disculpa la molestia

ResponderCitar
Respondido : 02/08/2012 1:56 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Carlos
 Carlos
Reputable Member

Hola Luis:

He seguido los pasos indicados, he realizado el Backup y en el punto 4. Ir al Gestor de Extensiones, Gestionar, filtrar por Idiomas, no me sale nada, solo esta imagen:

por lo que no puedo seguir con las instrucciones indicadas....

ResponderCitar
Respondido : 02/08/2012 2:39 am
Página 1 / 2

Por favor Iniciar Sesión o Registro