Avisos
Vaciar todo

Como no mostrar campos personalizados en producto Virtuemart en visualización tipo lista  

 
Marco
 Marco
Reputable Member

Hola,

Como puedo no mostar los campos personalizados de un productos en la visualización tipo lista y mostrarslos solo en el detalle del producto?

Gracias.

Marco

http://www.grabadosguerrero.com/index.php?option=com_virtuemart&view=category&virtuemart_category_id=53&Itemid=1396

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 24/05/2016 11:51 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica en el siguiente fichero: /components/com_virtuemart/assets/css/vm-ltr-site.css verifica el cambio en la linea 210:

.product-fields .product-field, .product-related-categories .product-field {
  display: none;
  float: left;
  margin-bottom: 0.4em;
  width: 100%;
}

Verifica si este cambio no afecta al detalle del producto.

ResponderCitar
Respondido : 25/05/2016 1:35 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Marco
 Marco
Reputable Member

Hola Johnny,
Perdona pero no entiendo muy bien lo que tengo que hacer.

Actualmente en la linea 210 hay este código:

.product-fields .product-field,.product-related-categories .product-field {width:100%;float:left;display:inline-block;margin-bottom: 0.4em;}

Tengo que sustituir este código por lo que me indicas tu?

Gracias.

Marco

ResponderCitar
Respondido : 25/05/2016 10:10 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Marco.
si te das cuenta lo único que cambia es la linea ' display:inline-block ' que se cambia por 'display: none', esto hace que no se represente.

Modifícalo como te comenta Johnny

Nota: Recuerda realizar una copia del archivo antes de cualquier modificación, solo con un copia y pega en el block de notas tendrás suficiente para dejarlo como estaba anteriormente.

Un saludo

ResponderCitar
Respondido : 25/05/2016 10:26 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Marco
 Marco
Reputable Member

Hola, he realizado el cambio pero sigue mostrando los campos personalizados en la visualización de lista productos:

http://www.grabadosguerrero.com/index.php?option=com_virtuemart&view=category&virtuemart_category_id=53&limitstart=24

Marco

ResponderCitar
Respondido : 25/05/2016 11:27 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Marco.
Esto es lo que yo veo y no se muestra el campo personalizado:

Prueba a eliminar la cache del navegador con (F5)

Un saludo

ResponderCitar
Respondido : 25/05/2016 11:56 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Marco
 Marco
Reputable Member

Hola,

Si efectivamente ahora lo veo yo tambien asi. Pero ahora no me muestra los campos personalizados en el detalle del producto:

http://www.grabadosguerrero.com/index.php?option=com_virtuemart&view=productdetails&virtuemart_product_id=14&virtuemart_category_id=53&Itemid=1396

Marco

ResponderCitar
Respondido : 25/05/2016 12:24 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Marco.
Vuélvelo a dejar como estaba y añade las combinaciones para que podamos verlo otra vez.
Piensa que estamos trabajando en una web que no sabemos como esta echa y pueden haber cosas que nos confundan un poco.

Un saludo

ResponderCitar
Respondido : 25/05/2016 2:28 pm

Cursos Gratuitos WordPress

Marco
 Marco
Reputable Member

Hola pepe,

Ya está.

Gracias.

Marco

ResponderCitar
Respondido : 25/05/2016 5:47 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba agregar el siguiente código al final del archivo :

/templates/it_orchidshop/assets/css/custom.css

.browse-view .product-fields{
	display:none;
}

Si adicionalmente no quieres que se muestre el espacio en donde debería aparecer el botón de añadir al carrito, agrega también este código :

.browse-view .addtocart-area{
	display:none;
}

Saludos.

ResponderCitar
Respondido : 25/05/2016 8:26 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Marco
 Marco
Reputable Member

Perfecto.

Ahora funciona.

Muchas gracias a toso.

Marco

ResponderCitar
Respondido : 25/05/2016 11:06 pm