¿Debemos actualizar a VirtueMart 2.0.24c ??  

 
Fernando
 Fernando
Estimable Member

Hola a todos

He visto en vuestro blog que ha salido una nueva version de VirtueMart que corrige algunos problemas de la version anterior.
En el articulo se especifica que es para PHP 5.3 o superior y me pregunto

¿Que tenemos que hacer los que tenemos un php anterior?.
¿Debemos actualizar?
¿Es recomendable hacerlo?.

Saludos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 25/11/2013 8:00 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Fernando

Al final siempre vas a tener que actualizar tus extensiones ya que las vulnerabilidades se hacen conocidas y podrías exporter tu sitio web, sin embargo las actualizaciones no necesariamente deben ser inmediatas, te sugiero probar la actualización en un sitio web paralelo en donde puedas probar si todo funciona correctamente.

Con respecto a la versión de PHP, esto lo puedes solicitar por tickets de soporte, usualmente las extensiones que trabajan con PHP 5.2 seguiran trabajando normalmente con PHP 5.3

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/11/2013 10:59 pm

Cursos Gratuitos WordPress

Fernando
 Fernando
Estimable Member

Parece que con el tiempo todos acabaremos con el php 5.3 o superior, de hecho ya algunas aplicaciones que venian en el paquete webempresa de joomla no se pueden actualizar porque exigen el php 5.3.

Ademas, si queremos hacer uso de joomla 3 pues tendremos que hacerlo.

Habria que saber si alguien ha experimentado algún problema con el cambio. Segun pude comprobar en otros hosting el Extplorer deja de funcionar.

Sinceramente, no estaria mal que los tecnicos de webempresa escribieran un articulo en el blog que hablase de este cambio, sus ventajas e inconvenientes, incluso que los pack ya viniesen con las aplicaciones compatibles para ese servidor.

Seguro que muchos nos estamos haciendo estas mismas preguntas.

Un saludo

ResponderCitar
Respondido : 26/11/2013 8:01 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Fernando,

Si necesitas PHP 5.3 tienes que enviar un ticket al departamento de hosting y solicitar el cambio a un servidor con PHP 5.3, el traslado se realiza sin ningún coste para ti.

Estás utilizando un Joomla! 2.5, por lo que es muy extraño que no funcionará con PHP 5.3. Respecto a extensiones de la administración como eXtplorer no tengo constancia de que no funcione con PHP 5.3, puede ser que la extensión no estuviera actualizada en el caso que conoces. Lo que menos me preocupa cuando se hace un traslado es que deje de funcionar una extensión de la administración que no tiene incidencia en el frontal del sitio web, porque con una actualización a la última versión se resuelve el problema.

Los packs de 2.5 las extensiones son compatibles con PHP 5.3. De todas formas después del traslado es importante revisar todo el correcto funcionamiento del sitio web, y más cuando es una tienda virtual.

Los problemas de utilizar PHP 5.3 se pueden encontrar en Joomla! de la serie 1.0, y en las 1.5 creo que desde las 1.5.15 ya funciona bien, otro tema serían las extensiones de terceros instaladas.

Pero incluso en un Joomla! de la serie 1.0 hay soluciones para que funcione con PHP 5.3, http://www.kpsystems.com.au/fixing-joomla-10-for-php-53x.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 26/11/2013 9:00 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Fernando
 Fernando
Estimable Member

La verdad Jordi es que tu respuesta me tranquiliza.

Una vez realizado el cambio, en el supuesto caso de encontrar incompatibilidades graves (que no lo creo por lo que comentas) habria marcha atras?.

Gracias

ResponderCitar
Respondido : 26/11/2013 9:11 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Fernando,

En rara ocasión por un tema de incompatibilidades con alguna extensión antigua instalada que no tiene actualización, el cliente ha solicitado volver a PHP 5.2, y se le ha realizado nuevamente el traslado a un servidor con esa versión de PHP sin ningún coste. Dudo mucho en tu caso que pueda suceder, porque tienes una versión de Joomla! reciente.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 26/11/2013 10:41 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Fernando
 Fernando
Estimable Member

Gracias Jordi,

iniciare los tramites para el traslado.

Un saludo

ResponderCitar
Respondido : 26/11/2013 10:44 am

Por favor Iniciar Sesión o Registro