Avisos
Vaciar todo

El mismo error PHP y las páginas de producto no cargan  

 
Internautis
 Internautis
Usuario experto

Este es el error:

5] PHP Fatal error: Call to undefined method shopFunctionsF::PrintIcon() in /home/eurodete/public_html/templates/gk_boutique/html/com_virtuemart/productdetails/default.php on line 68
[18-May-2012 18:32:13] PHP Fatal error: Call to undefined method shopFunctionsF::PrintIcon() in /home/eurodete/public_html/templates/gk_boutique/html/com_virtuemart/productdetails/default.php on line 68

Y el efecto es que las páginas de producto se quedan en blanco.

Esto mismo exactamente igual me sucedió hace unos días; me recomendasteis desinstalar e instalar y así lo hice, pero ya tengo que tirar palante, tengo unos plazos que cumplir. Por favor indicadme cómo se soluciona y sobre todo a qué se debe ya que no he hecho nada extraño ni he tocado nada salvo introducir algún artículo y fabricantes.

Gracias!

URL del sitio: http://eurodete-cp50.webjoomla.es

Citar
Respondido : 18/05/2012 6:27 pm
Internautis
 Internautis
Usuario experto

SOLUCIONADO. Es en la configuración inicial de la tienda al marcar la casilla de "marcar enlace para recomendar producto". Si se desmarca esta casilla, vuelve a funcionar.

Por favor pasadme un enlace a un manual de virtuemart imprimible ya que los videos están muy bien... para las personas sin discapacidad auditiva, gracias.

ResponderCitar
Respondido : 18/05/2012 6:57 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Internautis,

¿Que versión "exacta" de VirtueMart 2 tienes? y como llegaste a ella ¿actualización, instalación limpia?.

Este tipo de problemas suceden cuando se viene de actualizaciones con plantilla como por ejemplo la JA Boutique y otras similares que ya incorporan versiones anteriores de VirtueMart.

Saludos

ResponderCitar
Respondido : 18/05/2012 6:59 pm
Internautis
 Internautis
Usuario experto

Pues no, Luis... Es un pack tienda nuevito del trinque, ni una semana hace que lo he cogido y ya me estaba tirando de los pelos, porque de php voy... pero justa justa.

Pienso que es "algo" de vuestra plantilla Boutique, al desmarcar esa casillla, hop, todo se ha arreglado. No ha habido ni instalación previa ni nada, es vuestro preinstalado, no he tocado gran cosa. La vez anterior cuando ví lo que sucedía cambié la plantilla y ahí sí funcionaba; cuando volvía a la boutique no funcionaba.

No me puedo permitir estos lujos Luis ya que la tienda la estoy montando para un cliente! Es que esto te pasa con tres mil artículos metidos y.... ....

ResponderCitar
Respondido : 18/05/2012 9:46 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Internautis,

Bien por tus aclaraciones 🙂 es importante saber que todo parte de nosotros, lo que significa que puede ser solventable de forma relativamente sencilla y no es fruto de una mezcla de versiones. 🙂

Escalo el post a un técnico para que lo revise y te pueda dar más detalles.

Se agradece mucho tu paciencia.

ResponderCitar
Respondido : 19/05/2012 1:40 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Internautis

Hemos realizado una actualización de los packs hace unas semanas.

Prueba instalar un pack de prueba en una carpeta de tu cuenta de hosting y verifica que al habilitar esta opción no te produce errores.

Saludos.

ResponderCitar
Respondido : 19/05/2012 5:09 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Internautis
 Internautis
Usuario experto

Hola John, veo que alguien ha instalado este mismo pack tieda boutique en un subdirectorio:

This is an automated email from Installatron.

Pack Tienda Boutique v2.5.4 has been installed to:

http://eurodetection.com/tmp_
http://eurodetection.com/tmp_
(en realidad la ruta es eurodete-cp50.webjoomla.es/tmp_)

pero suceden 2 cosas raras:

1) No me deja entrar como administrator
2) En mi cpanel no aparece este pack, no podré desinstalarlo después de hecha la prueba.

Lo que he hecho para verificar ha sido seguir tus instrucciones:
-->He instalado un pack de prueba, puedes verlo en http://eurodete-cp50.webjoomla.es/prueba
-->He marcado la dichosa casilla que me daba problemas, y has acertado: sigue funcionando todo.

La versión del pack con la que estoy trabajando es la 2.5.2, la que he instalado recién es la 2.5.4

¿Qué hago ahora? Realmente esa casilla no me importa, no es relevante; lo que no quiero es tener problemas "serios" cuando la tienda esté funcionando.

Gracias Jhon por la rápida respuesta.

ResponderCitar
Respondido : 19/05/2012 5:51 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Internautis

El dominio : http://eurodete-cp50.webjoomla.es/tmp_ ,fue una prueba realizada por nuestros administradores y ha sido eliminado.

El problema detectado por la habilitación de la impresión al parecer es un bug que se ha corregido en la versión 2.5.4 de Joomla.

Si no has avanzado mucho en tu sitio web, puedes empezar desde la nueva versión de Joomla.
Otra opción es instalar la actualización, te sugiero realizar un backup de tu sitio web antes de realizar esto.

Saludos.

ResponderCitar
Respondido : 19/05/2012 6:19 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Internautis
 Internautis
Usuario experto

Tema solucionadísimo, gracias. He reinstalado y todo va como la seda.

ResponderCitar
Respondido : 09/06/2012 10:57 pm