"Haga una pregunta del producto" no integrado en la web  

 
Daniel
 Daniel
Usuario eminente

Hola

Podriais ayudarme a solucionar el problema de que al clickar en "Haga una pregunta del producto" accedo a una pagina con solo el formulario para hacer una pregunta. No la carga en el cuerpo de la web o en un pop up como es mi intención.

Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 12/02/2013 4:07 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a cambiar el archivo que genera la plantilla de la ficha de producto en tu web. Te adjunto comprimido en un zip el archivo default.php. Tienes que descomprimir el zip y colocar el archivo en la ruta templates/gk_black_and_white/html/com_virtuemart/productdetails sustituyendo al archivo que allí se encuentra con el mismo nombre.

Antes de hacer esto realiza una copia de seguridad del archivo original para poder volver atrás en caso de problemas.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/02/2013 4:42 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Daniel
 Daniel
Usuario eminente

Perfecto Pablo. Muchas gracias

ResponderCitar
Respondido : 12/02/2013 4:47 pm
Daniel
 Daniel
Usuario eminente

Pablo, siento volver a abrir el tema pero no ha quedado solucionado del todo.

Ahora se integra perfectamente, pero al realizar la consulta en la respuesta del formulario (enviado correctamente) vuelve a hacerlo en pagina en blanco. Igualmente, hay un boton "cerrar" que no funciona. No permite volver a la web....

Sorry..

ResponderCitar
Respondido : 12/02/2013 5:04 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Te adjunto comprimido en un zip una nueva versión del archivo default.php. Tienes que descomprimir el zip y colocar el archivo en la ruta templates/gk_black_and_white/html/com_virtuemart/productdetails.

Ahora, la pregunta se abrirá en una ventana emergente.

Para que el botón mantenga el mismo aspecto que antes deberás editar el archivo templates/gk_black_and_white/css/template.css y agregar el siguiente código al final del archivo:

a.ask-a-question {
	font-size: 10px;
	border: 1px solid #9b9886;
	color: #fff;
	background: #a8a592;
	padding: 0 8px;
	border-radius: 0px;
	-webkit-border-radius: 0px;
}

a.ask-a-question:hover {
	background: #373636;
	border-color: #222;
	color: #fff;
}

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/02/2013 5:58 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Se me ha olvidado adjuntar el archivo. Aquí va.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/02/2013 5:58 pm

Cursos Gratuitos WordPress

Daniel
 Daniel
Usuario eminente

Solucionado, gracias.

ResponderCitar
Respondido : 12/02/2013 6:50 pm

Por favor Iniciar Sesión o Registro