Jooma 2.5.6 + Xmap 2.2.1  

Página 1 / 2
 
Javier
 Javier
Usuario eminente

Hola, estoy intentando crear un sitemap con Xmap 2.2.1.

Tengo un menu (llamado catalogo) de tipo Layout por defecto de Virtuemart
No consigo que añada ni los productos ni las categorias de Virtuemart.

Lo máximo que he conseguido es que añada productos y categorias si cambio el tipo de menú a Layout de categorias de Virtuemart, pero entonces añade las lineas de la siguiente manera:

/component/virtuemart/categoria/producto, lo que no me interesa, ya que quiero que las url sean /catalogop/familiar/producto

¿alguna idea? Por el foro de Xmap no he visto ninguna solución.

Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 30/08/2012 3:59 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que los enlaces a las categorías de Virtuemart no te estén saliendo por el tipo de elemento de menú que has asociado con la tienda online.

Prueba a editar el elemento de menú de la tienda y cámbialo del tipo VirtueMart » Layout por defecto de Virtuemart que tienes a uno del tipo VirtueMart » Layout de categorías Virtuemart (si te sale 2 veces la misma opción al elegir, elije la primera).

De esta forma sí que debería de mostrar correctamente el mapa con la estructura de la tienda.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/08/2012 4:21 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Javier
 Javier
Usuario eminente

Gracias de nuevo, si hago lo que comentas, en el fichero xml se generan las url del tipo /component/virtuemart/familia/producto, que es lo que quiero evitar, necesitaria que no aparecieran asi las url, si es posible, claro.l

(segun el hilo que me has solucionado antes):
https://www.webempresa.com/foro/30-VirtueMart-20/71061-SOLUCIONADO-Cambiar-urls-paginas-Virtue-Mart.html

Saludos.

ResponderCitar
Respondido : 30/08/2012 4:47 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

He estado realizando pruebas y parece que la solución pasaría porque editaras el elemento de menú que te carga la tienda, y en el tipo selecciones la opción Layout de categorías Virtuemart pero, eso sí, del listado que se muestra cuando hay que elegir una opción escoge la segunda (hay dos con el mismo nombre).

De esta forma parece que se arreglan las 2 cosas.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/08/2012 5:03 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Javier
 Javier
Usuario eminente

Genial, muchísimas gracias, funciona perfectamente.

Saludos

ResponderCitar
Respondido : 30/08/2012 5:08 pm
Javier
 Javier
Usuario eminente

Una cosa más, al indicar en el menu que es un layout de categorias virtuemart (la segunda opcion), cuando abro este menu y aparecen las categorias principales, debajo de las categorias se muestran todos los productos de la tienda... no veo como evitar que aparezcan los productos, solo querria las categorias, y no veo en virtuemart ningun sitio donde configurar eso.
Si pongo el menu como layout de categorias virtuemart (primera opcion), no aparecen los productos debajo de las categorias, pero entonces el xmap genera las url /component/virtuemart/etc. que quiero evitar.

ResponderCitar
Respondido : 30/08/2012 5:49 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Javier,

Si solo quieres mostrar las categorías y no los productos en el mapa que se muestra en el sitio web, pero no impedir que el sitemap que se le pueda mostrar a Google no rastree esos productos. Accede al administración --> extensiones --> gestor de plugins --> editar Xmap - Virtuemart Plugin --> en el parámetros Mostrar Productos, seleccionar mostrar solo el XML sitemap.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 31/08/2012 9:46 am
Javier
 Javier
Usuario eminente

no es ese el problema que tengo. Voy a intentar subir la web a un entorno de pruebas y asi lo veremos más facilmente.

¡¡Gracias !!

ResponderCitar
Respondido : 31/08/2012 11:55 am

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Envíanos un enlace para que podamos ver la página de inicio de la tienda. También será conveniente que el SEO esté desactivado.

Es posible que para que no se muestren los productos haya que realizar cambios en el diseño de las plantillas de Virtuemart.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/08/2012 12:06 pm
Javier
 Javier
Usuario eminente

Bueno, pues acabo de subir la web a traves de Akeeba Backup a un directorio provisional, y el administrador funciona, pero el frontend no. Se queda la pagina en blanco o da error http: 500... lo malo es que en un ordenador portatil con Linux y Lampp me hace exactamente lo mismo. Quizá tenga que poner una versión anterior de Akeeba Backup. Cuando lo tenga solucionado os avisaré.

Saludos.

ResponderCitar
Respondido : 31/08/2012 3:00 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Revisa la siguiente entrada de nuestro blog:

https://www.webempresa.com/blog/que-es-un-error-500-y-como-localizarlo-en-nuestra-web.html

Te puede resultar útil para tratar de localizar información sobre el error.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/08/2012 3:18 pm
Javier
 Javier
Usuario eminente

Ok, he buscado ficheros error_log según el tutorial y no me encuentra ninguno (me encuentra alguno pero en la carpeta donde tengo alojado otra web con otro dominio, no en la que me genera el error.
No obstante os pongo la dirección donde esta la que me da error, a ver si veis algo.

www.ams-accesorios.com/pruebas

(la plantilla es la JA_travel, de Joomlart, legal. Si cambio a otra plantilla estandar de joola me funciona bien)

ResponderCitar
Respondido : 31/08/2012 3:34 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Cargando la página se puede sacar poca información, solo que se trata de un error 500, pero sin más información. Esto es normal, porque dar a un visitante más información sobre el error sería contraproducente para la seguridad de la web.

Si comentas que tras cambiar la plantilla el error desaparece, esto nos indica que el error tiene que estar necesariamente en la plantilla.

Lo que podrías probar es a desinstalar la plantilla y volver a instalarla para ver si el problema se soluciona. Y, sobre todo, asegúrate de que la plantilla que estás instalando es compatible con la versión de Joomla que estás utilizando. Una misma plantilla puede tener una versión para Joomla 1.5 y otra para Joomla 2.5, y si se instala la versión que no es pueden aparecer este tipo de errores, ya que se llamarían a funciones del núcleo de Joomla que no existen.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/08/2012 4:06 pm
Javier
 Javier
Usuario eminente

Bueno pues desinstalada la plantilla y vuelta a instalar hace lo mismo.

He probado a restaurar con akeeba backup la copia que tengo, y en local con windows y xampp, funciona. NO funciona en vuestro servidor, ni funciona en linux con lampp...

Creo que va a ser un problema del akeeba backup, esta noche subire los archivos por ftp, restaurare la bbdd manualmente y a ver que pasa.

Saludos.

ResponderCitar
Respondido : 31/08/2012 5:07 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Javier,

¿Puedes indicar la versión "exacta" de Akeeba Backup que tratas de usar?.

Entiendo que la versión de Joomla! sobre la que te da el error 500 es la 2.5.6 ¿correcto?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/08/2012 5:10 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro