Avisos
Vaciar todo

No me aparece algunas subcategorias de producto  

 
Juan
 Juan
Noble Member

Hola muy buenas!

Tengo un problema con algunas subcategorias de producto, si accedemos a Contenido solo visible a usuarios registrados

Citar
Respondido : 22/04/2014 6:07 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Accediendo desde Contenido solo visible a usuarios registrados a la categoría CNC sí que me carga correctamente el listado de subcategorías de esta categoría, y lo mismo ocurre si accedo desde el módulo de categorías del lateral. No veo ningún problema aquí.

Eso sí, para conseguir unas mejores urls amigables en las que se quite el index.php vete a Sitio->Configuración Global y activa el parámetro Usar la reescritura URL. Comprueba que tras este cambio los enlaces funcionen. En caso contrario el archivo .htaccess que tienes en la raíz de tu web no sería correcto.

ResponderCitar
Respondido : 22/04/2014 6:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan
 Juan
Noble Member

Activando el campo Usar la reescritura URL. solo e carga la página de incio, el resto de la web aparece así

quizás el problema sea el archivo .htaccess, pero como lo arrego?

Saludos!

ResponderCitar
Respondido : 22/04/2014 7:00 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Comprueba si en la raíz de tu sitio web tienes un archivo con el nombre htaccess.txt. De ser así renómbralo como .htaccess y vuelve a probar.

ResponderCitar
Respondido : 22/04/2014 7:12 pm

Cursos Gratuitos WordPress

Juan
 Juan
Noble Member

Ok, lo he renombrado y sí, ya no sale el index... pero el problema sigue ahí, esta url http://solstone-cp47.webjoomla.es/productos-solstone/accesorios/fijacion/cnc es de una navefacion que he hecho, desde el modulo de categorias de VM accesorios (que carga bien) despues una subcategoria de accesorios, Fijacion (que tambien carga bien), pero si de ahí nos vamos a CNC o cualquier otra ya no carga y lo que hace es sumar la categoria a la URL en lugar de sustituirla.

Desde aqui:
http://solstone-cp47.webjoomla.es/productos-solstone/accesorios/fijacion/cnc quiero ir a CNC y genera esta url http://solstone-cp47.webjoomla.es/productos-solstone/accesorios/fijacion/cnc que está mal, debería generar esta http://solstone-cp47.webjoomla.es/productos-solstone/cnc

Vaya cacao...

Saludos!

ResponderCitar
Respondido : 22/04/2014 7:51 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Juan

Verifica si tienes un ítem de menú de tipo Layout por defecto de virtuemart

Desactiva temporalmente las urls amigables para ver que tipo de urls se generan

Saludos.

ResponderCitar
Respondido : 22/04/2014 11:01 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan
 Juan
Noble Member

Ya he probado varias veces a desactivar las urls amigables, pero con ellas desactivadas si pasando lo mismo.

Un Saludo!

ResponderCitar
Respondido : 23/04/2014 5:16 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Deja las urls amigables desactivadas por ahora para que podamos revisar las urls que se generan y ver si todo es correcto.

ResponderCitar
Respondido : 23/04/2014 6:24 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan
 Juan
Noble Member

Ok, ya estan desactivadas.

Muchas gracias.

ResponderCitar
Respondido : 23/04/2014 6:28 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Al acceder al menú de herramientas , veo que aparece el módulo de categorías, al acceder a los links de categorías del modulo se ven correctamente.

Contenido solo visible a usuarios registrados

Tienes algún plugin de urls amigables adicional a lo que tiene Joomla por defecto?

Saludos.

ResponderCitar
Respondido : 23/04/2014 7:32 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan
 Juan
Noble Member

No, no tengo ningun plugin de URL amigales adicional. de hecho ahora mismo las url amigables estan desactivadas.

Hablo ahora exclusivamente del menú de categorias de VM del lateral derecho. Este menú lo he utilozamo en multiples ocasiones en otros sitios web y es simple... jamas me ha dando ningun problema. Pero lo extraño de éste es que por ejemplo en las categorias padre, no publica las subcategorias y si navegais por él las subcategorias hasta productos quimicos aparecen correctamente. A partir de Productos químicos, si vas pasando de una subcategoria a otra, estás extrañamente se van añadiendo a la url y por lo tanto no cargan. Si realizais la prueba, mirar la Url y etendereis lo que os comento.

A ver si encontramos una solucion por que me estoy volviendo majara con el tema... :dry: :dry: :dry:

Saludos! y gracias!

ResponderCitar
Respondido : 28/04/2014 2:31 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Haciendo pruebas no veo que se produzca ningún problema con las subcategorías, al menos ahora que están las urls amigables desactivada. No se si el problema lo tienes solo cuando activas las urls amigables.

Así, por ejemplo, cuando accedo a la categoría "Corte y desgaste" la url que se carga es Contenido solo visible a usuarios registrados

Es decir, se cargan con una estructura similar.

ResponderCitar
Respondido : 28/04/2014 5:45 pm

Cursos Gratuitos WordPress