Plantilla de terceros  

 
Carlos
 Carlos
Reputable Member

Hola:

Tengo una consulta técnica, compre hace unos mese una plantilla en Templatemonster, la cual tiene la versiones Joomla 2.5 y virtuemart 2.0.6 pues bien, después de varias modificaciones para adaptar la plantilla a mi gusto, resulta que me da un problema, no muestra el carro, me pongo en contacto con el soporte técnico de templatemonster y me dicen que esto es debido a que he actualizado la versión de virtuemart de 2.0.6 que es la original de la plantilla a la versión 2.0.12.

Bueno hasta aquí puedo entender algunas cosas, pero la cuestión que quiero plantear, puedo retroceder a la versión 2.0.6 de la actual que tengo instalada 2.0.12 sin problemas?

La versión 2.0.6 es segura? que cambias significativos hay entre una versión y otra?

Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 16/11/2012 8:28 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Carlos,

Si hay cambios, siempre los hay y suelen ser importantes, de hecho desde la versión 2.0.6 hasta la actual 2.0.14 hay bastantes cambios y muchos de ellos importantes y bastantes de funcionalidades importantes y otros tantos de correcciones de funcionalidades básicas de VirtueMart que causaban errores o conflictos.

No tenemos publicado un 2.0.6 vs 2.0.14, pero si lees el siguiente artículo, de la 2.0.8, ya verás que se hablan de cambios y de cuales, así que eso amplialo a la nueva versión y te darás cuenta de la importancia de mantener esta extensión siempre actualizada dentro de lo normal

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/11/2012 10:08 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Carlos
 Carlos
Reputable Member

Hola:

Por lo que entiendo y según lo comentado por vosotros y por el proveedor de la plantilla, una vez instalada una versión, si hay actualizaciones no siempre serán compatibles con el diseño de la plantilla original, por lo que o te quedas como estas sin actualizar o tendrías que comprar otra plantilla con la actualización.,.... Es asi, verdad?

ResponderCitar
Respondido : 19/11/2012 11:11 am
David Noguera
 David Noguera
Miembro Admin

Si así és... deberías de comentarlo con los proveedores de tu plantilla para que te den una solución... y si no, quedarte en la versión de VirtueMart que tienes... También podrías usar esa plantilla y deshabilitar los overrides que haya en esa plantilla para los módulos y componente de virtuemart, simplemente renombrando los directorios que estén haciendo override en /templates/nombreplantilla/html/com_virtuemart por /templates/nombreplantilla/html/com_virtuemart_old

Prueba así a ver si te funciona..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/11/2012 1:47 pm

Cursos Gratuitos WordPress

Carlos
 Carlos
Reputable Member

Hola David:

Gracias por tu respuesta, te puedo pedir un favor, podrías ser algo mas conciso, no alcanzo a entender que es lo que tengo que cambiar. gracias y disculpa mi ignorancia.

ResponderCitar
Respondido : 19/11/2012 2:15 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Carlos,

Creo que es un error tener una plantilla que solo funcione con una determinada versión de Virtuemart de una misma serie, ello indica que está mal realizada, o que tienes que tener actualizaciones de la misma, que te permitan actualizar la versión de Virtuemart.

Para entender el concepto de Override,

Prueba a renombrar las carpetas que realizan ese Override tal como te indica David, y comprobar el correcto funcionamiento de Virtuemart después de la actualización.

Desconozco si la plantilla que tienes instalada realiza realmente Overrides del componente Virtuemart, es fácil comprobar si en la carpeta html tienes alguna con el nombre de virtuemart.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 19/11/2012 2:34 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Carlos
 Carlos
Reputable Member

Hola Jordi:

Esto es lo que tiene la plantilla:

Como puedes ver hay dentro del HTML de la plantilla hay una carpeta "MOD_VIRTUEMART_CURRENCIES" es esta la carpeta que tengo que renombrar?

Un saludo
Carlos

ResponderCitar
Respondido : 19/11/2012 5:33 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Carlos

Por lo que veo en tu captura de pantalla sólo se esta haciendo overrides de un módulo, el mulo de monedas

Si, prueba realizar el renombre de este y verifica si te funciona.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/11/2012 9:49 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Carlos
 Carlos
Reputable Member

Hola:

he renombrado la carpeta y nada....

Voy a optar por empezar de cero, con la versión de virtuemart 2.0.6

Gracias

ResponderCitar
Respondido : 20/11/2012 12:15 pm

Por favor Iniciar Sesión o Registro