avisos tras instalar virtuemart 3  

 
Alceste
 Alceste
Noble Member

Hola,
Tras instalar la última versión de VirtueMar 3 en un Joomla 3.4.1 me muestra los avisos que os adjunto en el pantallazo. (Es en una wb que no está en producción sinó la que preparo para migrar contenidos de la que tengo en Joomla 1.5.26 y VM 1.1.9)

Me preocupa especialmente este aviso:

Advertencia
JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración de Joomla!
JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración.

Saludos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 31/03/2015 3:06 pm
Lorena
 Lorena
Miembro Moderator

Hola Alceste,

los avisos de:

JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración de Joomla!
JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración.

se suelen dar cuando no se tienen correctas las rutas en el configuration.php de las carpetas de logs y tmp (sobre todo si has hecho un clonado o movido la instalación entre carpetas) Comprueba que la ruta sea correcta. Si la web la tienes en la ruta /home/micuenta/public_html/miweb/ entonces serían

/home/micuenta/public_html/miweb/logs y /home/micuenta/public_html/miweb/tmp

Si las rutas no son correctas, al realizar una revisión con nuestro asistente Stephan, de saldrá el aviso con la info de la instalación Joomla y te dirá la ruta a indicar en el configuration.php.

Otro motivo suele ser que debas descomprimir previamente el fichero de instalación. Normalmente este tipo de instaladores que viene en varias parte suele tener en el nombre del archivo que te descargas el texto unzip_first o algo similar.

Pero si en tu caso es un clon o similar, me decanto por afirmar que será el tema de las rutas.

Un saludo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/03/2015 4:03 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola,
Estoy algo desorientado porqué veo que tengo dos carpetas con el nombre jom315 y que desde la administración puedo acceder a ambas por dos rutas distintas ya que está con el mismo nombr en dos sitios:
En el Cpanel lo veo en ambas rutas:
/home/public_html/midomnino1/clon/jom315/administrator
/home/public_html/midominio1/jom315/administrator

Sin embargo, en la parte pública solamente puedo acceder a través de:

/home/public_html/midominio1/jom315

He utilizado Jupgrade para migrar Joomla y todo fue bien. Yo diría que solamente cree la carpeta jom315 en la ruta: /home/public_html/midominio1/jom315

¿Hay alguna explicación para esto? Ahora en ambas carpetas hay un Joomla y un virtuemart...
¿Qué debo hacer?
Antes de instalar VM he hecho una copia de seguridad con Akeeba Backup

Muchas gracias Lorena

ResponderCitar
Respondido : 31/03/2015 6:58 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Entiendo que el sitio web real es :

Contenido solo visible a usuarios registrados
No muestra nada

Por lo tanto renombra temporalmente la carpeta clon por "back_clon", trabaja sólo con jom315

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/03/2015 7:27 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola,
Si por sitio resal entendemos que es la del destino de la migración, sí.
Si por web real te refieres a la web que tengo en producción, no.

Para ponerlo más claro, te indico aquí las webs y directorios:

Web real en producción con joomla 1.5.26 y VM 1.1.9 y plantilla zeolite (no disponoble para migrar a joomla 3 y vm 3)

Spoiler
Contenido solo visible a usuarios registrados

En esta última es en la que me parece que hay dos carptas llamadas igual y con la nueva instalación en ambas, al menos desdel CPanel eso parece.

Mil gracias por tu ayuda
Saludos

ResponderCitar
Respondido : 31/03/2015 10:35 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Lo que pasa es que estas dos web q estan en estas rutas:
Contenido solo visible a usuarios registrados

Según lo que comentas usan la misma BD, al final debes quedarte sólo con jom315, renombra la carpeta de clon como backup_clon y no vuelvas a entrar desde aca, todo haslo desde jom315

Luego también deberás depurar las tablas de Joomla 1.5 de tu BD

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/03/2015 10:58 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola,
De acuerdo la he renombrado como Backup_clon_jom315 para identificar que es un duplicado de la nueva instalación en Joomla 3 a la que migro y no confundirla con el clon de la web en producción, que está en el directorio Clon y en Joomla 1.5.26.

Pero tengo varías dudas:
1ª- Cuando dices "deberás depurar las tablas de Joomla 1.5 de tu BD" te refieres a la web en producción en o al clon?
2ª ¿Cómo se depuran las tablas y qué riesgos entraña?
3ª No recuerdo haber creado dos directorios con el mismo nombre dentro del directorio Clon, pero ahí está. Entoncs ¿Puede ser que la haya creado Akeeba Backup o Jupgrade? ¿Hay alguna explicación?
4ª Ahora la carpeta renombrada como "Backup_clon_jom315" debe de ocupar espacio en el servidor. ¿Debo borrarla? Si entiendo bien tengo lo mismo en la ruta correcta en el directorio Jom315
5ª En lo concerniente al error que me ha dado la instalación de VirtueMart

JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración de Joomla!
JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración.

¿Qué hago? Instalo de nuevo VirtueMart sin desinstalarlo o previamente debo desinstalar el componente de VM y VM AIO antes de intentar instalarlo de nuevo?

Perdonad por tantas dudas y mil gracias por vuestra ayuda

Saludos

ResponderCitar
Respondido : 01/04/2015 9:28 am
Julen
 Julen
Miembro Admin

Hola,

Si al crear el clon no creaste una nueva base de datos entonces se creo de manera incorrecta.

Mi recomendación es que con esa misma copia, clones el sitio web en otra carpeta distinta y utilizando otra base de datos, y de esta forma primero hacer una actualización en ese clon, y si hay problemas, entonces resolver en ese clon si afectar a la web en producción. Cuando esté todo resuelto los mismos pasos se realizan en el sitio web en producción. Debes tener un sitio totalmente independiente con su propia Base de Datos.

Te sugiero revises:
https://www.webempresa.com/blog/clonar-joomla-desde-el-panel-de-administracion-del-hosting.html

Una vez creado el clon correctamente, puedes preceder a instalar VirtueMart, ambas opciones que has comentado son correctas, puedes actualizar directamente VirtueMart sin necesidad de desinstalarlo.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/04/2015 11:21 am

Cursos Gratuitos WordPress

Alceste
 Alceste
Noble Member

Hola Julen,
El caso es que sí creé una nueva base de datos. Todavía no entiendo cómo es que tenia el directorio jom315 en dos rutas distintas, salvo que tenga que ver con la copia que hice con akeeba_backup, que no creo...

En culaquier caso, no es porque no creara una nueva base de datos...

Saludos y gracias!

ResponderCitar
Respondido : 01/04/2015 1:26 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

ES muy importante primero que te asesgures que ambos sitios web estan funcionando con diferentes bases de datos, desde la configuración global => servidor ,puedes ver el nombre de la BD al que hacen referencia, verifica que nombre tiene cada uno, puedes enviar capturas

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/04/2015 6:40 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola,
Sobre las bases de datos son estas y son distintas:
Sitio en producción: nombre_de_cuenta_deco2 (Joomla 1.5.26 / VM 1.1.9)
Clon del sitio en producción: nombre_de_cuenta_clon (Joomla 1.5.26 / VM 1.1.9)
Clon del sitio para migrar: nombre_de_cuenta_j31 (Joomla 3.4.1 / VM 3.0.6.2)

Tras actualizar el Joomla 3.1.5 de la web de destino de la migración a Joomla 3.4.1 y voler a instalar VirtueMart me ha desaparecido el error.

Sin embargo ahora me salió este aviso:

Aviso
Taking config from file
The configuration setting 'Enable database Update tools' is enabled. Please disable this for security measures here in the Configuration panel.

La versión de VM que tengo es la 3.0.6.4 ¿Qué debo hacer según este aviso

A parte de eso quedan algunas dudas pendientes de respuesta de un post anterior de este mismo hilo:

- Cuando dices "deberás depurar las tablas de Joomla 1.5 de tu BD" te refieres a la web en producción en o al clon?
-¿Cómo se depuran las tablas y qué riesgos entraña?
- Ahora la carpeta renombrada como "Backup_clon_jom315" debe de ocupar espacio en el servidor. ¿Debo borrarla? Si entiendo bien tengo lo mismo en la ruta correcta en el directorio Jom315

Saludos y gracias!

ResponderCitar
Respondido : 02/04/2015 9:20 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Primero, con respecto al mensaje, puedes buscar desde la configuraicón de virtuemart, en la sección de herramientas veriifica si tienes opcion de desactivar esto

Luego con respecto a tus otras consultas, si son BD de datos diferentes para cada instalaicón entonces no tienes nada que depurar a nivel de BD

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/04/2015 6:57 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro