Avisos
Vaciar todo

EL modulo virtuemart desaparece si no es aplicado a todas las páginas  

 
jelego
 jelego
Usuario eminente

Hola, quiero quitar el menú de virtumart de la pagina de inicio y asignar al menu seleccionando varias secciones(los que corresponden con el menu principal horizontal) pero no me deja, si desaparace del Inicio y lo asigno a paginas interiores que está en Menu Principal, el modulo no aparece.Es decir, para que aparezca en paginas interiores el moludo virtuemart, tiene que estar asignado en todos lo menus, no me permite seleccionar...

POdeis verlo en www.padelenlared.com

Gracias

Citar
Respondido : 14/12/2011 11:49 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Entiendo que te refieres al módulo con nombre "TIENDA" que se muestra en la columna izquierda de la web.

Sí que tendría que funciona la opción de que se cargue solo en las página que necesites, teniendo en cuenta que Virtuemart contaría como una sola página, es decir, si se muestra en un listado de productos de una categoría, también se mostrará para otras categorías o la ficha de los productos.

El problema puede venir derivado de que en el menú superior estás enlazando de forma directa con algunas categorías de Virtuemart. Cuando se va navegando por la categorías (entrando en una ficha de producto, por ejemplo), se tiende a que el elemento de menú asociado sea el principal de Virtuemart, que suele ser el primero que se creó asociado a Virtuemart.

Por tanto, cuando vayas asociar el módulo asegúrate de que seleccionas todos los elementos de menú asociados con Virtuemart, aunque estos se encuentren en menús que no se muestren en la web.

ResponderCitar
Respondido : 14/12/2011 12:09 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

jelego
 jelego
Usuario eminente

Nada o he asignado a todos los menu relacionado con virtuemart, pero no me aparece si lo quito de la pagina principal... 🙁

ResponderCitar
Respondido : 14/12/2011 12:51 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola jelego

Envíanos una captura de pantalla para ver como tienes configurado el módulo y los items de menú al cual esta asignado

Saludos.

ResponderCitar
Respondido : 14/12/2011 3:29 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

jelego
 jelego
Usuario eminente

Este es el modulo, que para que aparezca en otras secciones del menún, tiene que estar señalado como "todo" en la asignación de menú...

ResponderCitar
Respondido : 14/12/2011 5:51 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba, una vez que has seleccionado la opción Todo en Mostrar, a cambiar a la opción de seleccionar los items de menú y desmarca solo el item "INICIO" para ver si así se muestra en el resto de las páginas.

ResponderCitar
Respondido : 14/12/2011 8:56 pm

Cursos Gratuitos WordPress

jelego
 jelego
Usuario eminente

Nada, ya lo he probado y al desmarcar "todo" y dejar sin marcar "INICIO", no aparece el modulo en el resto de paginas....

ResponderCitar
Respondido : 14/12/2011 9:12 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola jelego,

¿Puedes volver a mandar una captura de como tienes "ahora" configurado dicho módulo tras los cambios?

Saludos

ResponderCitar
Respondido : 14/12/2011 9:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

jelego
 jelego
Usuario eminente

Así es como se queda, pero tengo que desactivarlo porque no aparece el modulo en ninguna pagina...

ResponderCitar
Respondido : 14/12/2011 9:39 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola jelego,

No se ven todos los ítems de asignación de menú pero entiendo que solo tienes un ítem "Inicio" en "mainmenu" que más abajo no hay más y que tampoco tienes duplicado/clonado dicho módulo ¿correcto?.

Saludos

ResponderCitar
Respondido : 14/12/2011 10:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

jelego
 jelego
Usuario eminente

He "limpiado" los menús y he comprobado que no esta el modulo clonado...voy a ver si así arreglo algo...

ResponderCitar
Respondido : 15/12/2011 6:41 am
jelego
 jelego
Usuario eminente

Nada, siguen sin aparecer el modulo en las otras secciones cuando lo desactivo en INICIO...Para que funciones tiene que estar asignado a TODO los apartados del menú...

ResponderCitar
Respondido : 15/12/2011 1:08 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

¿Este problema te ocurre solo con este módulo o también te pasa si utilizas otro módulo de Virtuemart, como el mod_product_categories (menú de categorías de Virtuemart)?

De esta forma podremos determinar si el problema está en el módulo o en la configuración de los menús.

ResponderCitar
Respondido : 15/12/2011 5:34 pm
jelego
 jelego
Usuario eminente

Lo he comprobado también con el modulo mod_product_categories, y ocurre lo mismo, ahora mismo lo tengo activado en dos secciones, pero no aparece si no se asigna "todo" al menu...

ResponderCitar
Respondido : 19/12/2011 6:23 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a desactivar las urls amigables en tu web para ver si entonces funciona la publicación de menús. Necesitaría ver la página sin las urls amigables para ver cómo asigna el valor Itemid a los distintos apartados de la web.

ResponderCitar
Respondido : 20/12/2011 12:44 pm