ERROR VIRTUEMART  

 
daniel
 daniel
Estimable Member

Hola.
Sigo teniendo el mismo problema de antes el mensaje de las cookies no se quita.Me borraron la cache de google para que la pagina se volviera a indexar y nada de nada.
Probe el desmarcar la casilla de las cookies en virtuemart configuración y borrar mi cache ytodas las cookies y nada de nada.
Que otra cosa puedo hacer.Este tema ya me tiene un poco jodido.
Si dejo la casilla de las cookies sin marcar en configuracion virtuemart que podria pasar.
Gracias de antemano.
Un saludo.

Citar
Respondido : 24/11/2010 4:40 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola danny,

Solo veo este primer post al respecto de tu "error en VirtueMart" y ayudaría un poco recapitular y contar brevemente de que se trata porque yo no se exactamente que te sucede con la "cookies" 🙂

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/11/2010 1:56 am

Cursos Gratuitos WordPress

daniel
 daniel
Estimable Member

Buenas.Cuando accedo en mi web por la palabra comprar proteinas me redirecciona a una categoría de la página (proteinas).
Y sale la siguiente información:
Info: Su navegador no acepta cookies. Para introducir productos en su carrito y proceder a la compra, necesita habilitar las cookies.
De mi navegador no es y entrando escribiendo por el nombre del dominio no me muestra esa información.
He hecho lo que tu me comentaste En el backend de Joomla, Componentes, VirtueMart, Administración, Configuración, Configuración principal, ¿Habilitar comprobación de Cookies? [ ] desmarca esa funcionalidad y limpia la caché de tu navegador, (Control+F5 en Firefox, Shift+F5 en Chrome) y prueba nuevamente a acceder a la url:
Parece que ya se ha arreglado por lo menos a mi no me aparece,no se como ira en los navegadores de mis clientes.Si dejo la casilla de las cookies desmarcada siempre,no pasaría nada verdad.
Un saludo.

ResponderCitar
Respondido : 25/11/2010 12:55 pm
daniel
 daniel
Estimable Member

Si dejo la casilla de las cookies desmarcada,cuando accedo con firefox buscando en google comprar proteinas accedo a mi web y no me deja ni rejistrarme ni iniciar sesion.INVALID TOKEN.En cambio con internet explore va bien.

ResponderCitar
Respondido : 25/11/2010 5:44 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola danny,

En principio si desmarcas la casilla de "cookies" tal como comenté no deberías tener mayores problemas ni tu ni los usuarios, no obstante ¿hay posibilidad de ver la url para verficar el funcionamiento?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/11/2010 6:00 pm
daniel
 daniel
Estimable Member

Este es el enlace que esta indexado con google.
http://sherrysport.es/index.php?page=shop.product_details&flypage=flypage.tpl&product_id=194&category_id=39&option=com_virtuemart&Itemid=1
He dejado la casilla de las cookies desmarcada como me has comentado.El problema lo tengo cuando accedo mediante esta página indexada con google,si accedo desde mi direccion www.sherrysport.es no tengo el problema con las cookies,no me muestra el mensaje aunque tenga la casilla marcada.
Ya me dices algo.
Un saludo

ResponderCitar
Respondido : 26/11/2010 12:14 am

wpdoctor-revisa-la-salud-de-tu-wordpress

daniel
 daniel
Estimable Member

Con firefox no me deja ni registrarme y con internet explorer si,pero desde ahi no me deja comprar.Y si dejo la casilla marcada si me deja.

ResponderCitar
Respondido : 26/11/2010 12:29 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola danny,

El tema es que seguramente en componentes --> Virtuemart --> configuración --> seguridad.
Site URL
SECUREURL - URL segura
Tienes con 3 www el dominio.

Hay 2 opciones:

- https://www.webempresa.com/blog/codigos-utiles-htaccess-para-wordpress.html de manera que sin www redireccione a www.

- Cambiar el código en el archivo administrator/components/com_virtuemart/virtuemart.cfg.php
define( 'URL', 'http://www.sherrysport.es/' );
define( 'SECUREURL', 'http://www.sherrysport.es/' );
por
define( 'URL', $mosConfig_live_site.$app );
define( 'SECUREURL', $mosConfig_live_site.$app);

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 04/05/2011 11:10 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose
 Jose
Usuario experto

Hola danny,

El tema es que seguramente en componentes --> Virtuemart --> configuración --> seguridad.
Site URL
SECUREURL - URL segura
Tienes con 3 www el dominio.

Hay 2 opciones:

- https://www.webempresa.com/blog/codigos-utiles-htaccess-para-wordpress.html de manera que sin www redireccione a www.

- Cambiar el código en el archivo administrator/components/com_virtuemart/virtuemart.cfg.php
define( 'URL', 'http://www.sherrysport.es/' );
define( 'SECUREURL', 'http://www.sherrysport.es/' );
por
define( 'URL', $mosConfig_live_site.$app );
define( 'SECUREURL', $mosConfig_live_site.$app);

Saludos,

Rescato este post para darle las gracias tanto a gnumax como a Jordi Sala por los consejos.

Una de mis webs me estaba dando algunos problemas como el famoso "Invalid Token". Todo se ha solucionado redireccionando la web sin www a www. Después en Virtuemart>Administración>Configuración>Seguridad he puesto en Site URL y SECUREURL - URL el dominio con www y problema solucionado (espero que para siempre).

Gracias!!

ResponderCitar
Respondido : 18/01/2012 12:29 pm

Por favor Iniciar Sesión o Registro