Haga una pregunta del producto (no veo email del que pregunta)  

 
Sergio
 Sergio
Usuario eminente

Hola,
tengo problemas para identificar el Email de quien pregunta.
Estando en el detalle de un producto, al hacer clic en "Haga una pregunta del producto", todo ok, ingreso nombre e Email + la pregunta..

Luego al recibir el correo (al administradro / vendedor), este dice:
Hola Vendedor
Pregunta acer de producto XXXXX
La consulta fue hecha por ()
xxxx texto de la pregunta xxxxx

El tema es que no visualizo quien pregunto (Email), solo aparece ().
Donde podre ver esto para identificar wquien escribio?
Otra cosa, recio correo al vndedor, pero no recibo correo de confirmación si pregunto, es posible hacer esto (que si escribo, me llegue un email, confirmando la pregunta que he realizado)??

utilizo, pack tienda, plantilla your shop..

muchas gracias,
salu2,

Citar
Respondido : 11/09/2012 7:28 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Sergio

Puedes enviar la url de tu sitio web?

Envía también una captura de pantalla del correo que te llega.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/09/2012 8:11 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Sergio
 Sergio
Usuario eminente

Hola Jhon,
lo solicitado,
gracias.

http://perfetto.cl/tkm2/catalogo-de-productos/para-la-mujer?start=6

ResponderCitar
Respondido : 11/09/2012 9:51 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

Tal como te han indicado anteriormente, seria interesante ver un correo tal como lo recibes, ya sea una captura o el texto "íntegro" del email que recibes (puedes ofuscar el email y datos sensibles si procede).

De otra forma es difícil ver lo que tu ves cuando recibes el correo.

También te recomiendo la siguiente IMPORTANTE lectura:

- https://www.webempresa.com/blog/anadir-captcha-al-formulario-de-consulta-de-producto-de-virtuemart.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/09/2012 10:20 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Sergio
 Sergio
Usuario eminente

Jhon, Luis,
adjunto captura de como recibo el email.. (es lo mismo que les escribi)

el texto que sale " () " es donde, imagino debiese estar referenciando una variable o algo así.

pd: el tema no va por instalar un captcha (interesante pero no por el momento)

salu2 y gracias...

ResponderCitar
Respondido : 12/09/2012 12:32 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

Es obvio que el no dispone de captcha no es vinculante al problema que planteas, esta claro, pero si es una recomendación IMPORTANTE al considerarse este tipo de formularios un vector de ataque para bots de spam que en estos últimos meses están proliferando de manera considerable.

¿Recuerdas haber realizado cambios en el formulario de consulta de productos de VirtueMart recientemente?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/09/2012 12:58 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Sergio
 Sergio
Usuario eminente

NO,
la verdad Luis ni siquiera conozco donde esta esto (formulario de consulta de productos de VirtueMart).

salu2,

ResponderCitar
Respondido : 12/09/2012 1:05 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

Si afán de alargar este post innecesariamente te diré que el formulario al que me refiero es el mismo sobre el que tu estás consultando el problema de los campos vacíos ().

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/09/2012 1:21 am

Cursos Gratuitos WordPress

Sergio
 Sergio
Usuario eminente

Luis,
no me queda claro tus consultas. Haber si entiendo,

si se a que formulario te refieres, sin embargo si me consultas si he realizado cambios en el formulario de consulta de productos de VirtueMart.
resp, no, nunca.

Lo que hago es yo mismo hacer una pregunta, ingreso el monbre, email (xxx@xxx.com) y pregunta..y envío.
luego cuando me llega el email informandome (al sitio) que alguien realizo una pregunta a un producto, es hay donde no se como se muestran los datos del usuario que generó la pregunta (nombe y email xxxxxx.com).

salu2,

ResponderCitar
Respondido : 12/09/2012 1:32 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

Dices que no has realizado cambios en archivos de VirtueMart que afecten al formulario de consultas de productos, no obstante un técnico que harevisado tu sitio web me comenta que tienen innumerables errores en tus logs relativos al sitio web que comentas:

Contenido solo visible a usuarios registrados

Revisa los archivos /public_html/error_log y /public_html/administrator/error_log donde podrás ver estas entradas que comentan.

Es importante realizar copias de seguridad antes de proceder con cambios que puedan modificar o deteriorar el comportamiento de tu sitio web con el fin de poder volver a un estado anterior estable.

¿Tienes copia de seguridad con Akeeba Backup de un momento anterior al problema donde el formulario funcionase correctamente?, ¿que versión "exacta" de VirtueMart 2.0.x tienes?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/09/2012 1:52 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Sergio
 Sergio
Usuario eminente

Luis,
los cambios que he realizado, son a nivel de lenguage, referencia a imagenes y otras cosas..
por lo que yo "entiendo"nada que pudiese afector esto.. al parecer estoy equivocado.

al buscar los archivos que mencionas, veo lo siguiente:
primero, el sitio, actualmente esta en /public_html/tkm2

buscando en us interior no veo esta ruta:
para la ruta, /public_html/administrator/error_log , si veo el archivo pero veo esto:

la version de VM,

Luis, tengo otro joomla intalado en /public_html/tkm y en el si recibo el correo (nombre, email y pregunta)

Es posible solucionar esto ( no tengo respaldo de lo avanzado... mi error)

salu2,

ResponderCitar
Respondido : 12/09/2012 2:44 am
Sergio
 Sergio
Usuario eminente

adjunto version VM,

ResponderCitar
Respondido : 12/09/2012 3:15 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Sergio,

¿Desde cuando tienes el inconveniente?. Puedes bajarte la última copia de seguridad desde tu panel de control cPanel, accediendo a la opción backup y pulsando en el botón de la copia que estimes se aproxima a la fecha que desees:

- daily: Copia de Seguridad Diaria
- weekly: Copia de Seguridad Semanal
- monthly: Copia de Seguridad Mensual

Aquí tienes un vídeo que te muestra como puedes fácilmente recuperar una copia de tu web desde el panel de control: https://www.webempresa.com/videos/backup_cpanel/backup_cpanel.html

Una vez se haya descargado el backup lo tienes que descomprimir, verás que hay un fichero llamado "homedir.tar" que si lo descomprimes en otro directorio tendrás todos los ficheros de la carpeta /public_html referente a tu Joomla!.

En el caso que además quieras restaurar la base de datos también tienes una copia de seguridad dentro del fichero que hayas bajado en el directorio /mysql, desde el phpMyAdmin podrás eliminar las tablas de tu base de datos y realizar una importación del fichero SQL de la copia.

Si alguno de estos pasos no te queda claro, antes de ejecutarlo es mejor preguntar.

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/09/2012 3:39 am
Sergio
 Sergio
Usuario eminente

Estimados todos,
primero que todo gracias por su ayuda siempre..

para cerrar este tema les comento,
inicalmente quede con la duda del por que ocurría esto, considerando además que la solución de bajar una copia de seguridad no me convenció dado que los cambios que he realizado a la pantilla, no debiesen cambiar o generar el problema...

bueno, como buen curioso, encontré la solución y esta es muy simple.
la dejo para compartir a quienes les pueda ocurrir lo mismo.

Solución: en VirtueMart, ir a configuración/configuración/ lengueta Tienda. acá ir a "Formato de Mail de pedido" y seleccionar "Mail HTML" (no Mail de Texto. este es el que produce el error)

salu2 a todos,

ResponderCitar
Respondido : 14/09/2012 3:38 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Sergio,

Gracias por compartir la solución, seguramente será útil a otros usuarios de Joomla!.

Cerramos el tema

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 14/09/2012 3:52 pm

Por favor Iniciar Sesión o Registro