No puedo añadir categorias ni productos relacionados  

Página 1 / 2
 
María
 María
Estimable Member

Hola, estoy tratando de añadir productos relacionados o categorías relacionadas en productos desde la pestaña campos personalizados pero al darle a guardar estos desaparecen, además cuando escribo el nombre de algún producto que quiero relacionar, este no me aparece como miniatura del mismo con un aspa en la parte superior derecha sino como una simple línea de texto-vinculo.
¿Como puedo solucionarlo?
Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 27/08/2015 1:28 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que se deba a algún bug en la versión de Virtuemart que estás utilizando. Indícanos la versión de Joomla y Virtuemart que estás utilizando en tu tienda para indicarte si es necesario que te actualices.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/08/2015 3:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

María
 María
Estimable Member

Hola Pablo, la versión de Virtuemart es: 3.0.9
y la de Joomla: 3.4.1

ResponderCitar
Respondido : 27/08/2015 6:19 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Veo que son versiones recientes las que tienes

Has instalado recientemente algúna extensión?

Es posible que sea algún problema con javascript, verifica primero si te sucede lo mismo con otro navegador, podrías verificar también instalando el componente firebug para tu navegador y cuando ejecutas esta página verifica si te reporta errores en la consola de firebug

Para aprender sobre firebug, aunque en tu caso sería solo para ver si hay errores javascript
https://www.webempresa.com/blog/usando-firebug-para-modificar-la-apariencia-de-una-plantilla-joomla.html

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/08/2015 7:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

María
 María
Estimable Member

Hola Jhon, he probado con Firefox y el resultado es el mismo, después he instalado Firebug, pero no veo ningún error en la pestaña consola.
Gracias.

ResponderCitar
Respondido : 27/08/2015 8:24 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Tienes que actualizar la web para verificar si se muestran errores en consola. Puedes revisar el siguiente articulo de blog:

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/08/2015 2:37 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

María
 María
Estimable Member

Hola Johnny, una vez revisado el video tutorial de Firebug, he procedido a recargar la web en la consola de firebug y me detectaba el siguiente error:
Error in file:components/com_k2/js/k2.js; Error:jQuery is not defined
El cual he visto que deja de aparecer al desactivar el Plugin System - K2, pero claro dejan de aparecer los artículos creados en el blog de K2. Aún así he procedido a intentar relacionar un producto y sigue sin funcionar (cuando le doy a guardar este desaparece), una vez recargada la página desde el backend he detectado un error jquery.min.js pero no tengo claro que debo despublicar para solucionarlo, adjunto captura de pantalla.
Gracias.

ResponderCitar
Respondido : 28/08/2015 11:14 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Al parecer es un bug: http://forum.virtuemart.net/index.php?topic=130303.0 según se comenta en este hilo se solucionaría con la ultima versión de Virtuemart 3.0.9.4

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/08/2015 12:13 am

Cursos Gratuitos WordPress

María
 María
Estimable Member

Ok, Johnny voy a proceder con la actualización a ver que tal va.
Muchas gracias.

ResponderCitar
Respondido : 29/08/2015 9:45 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola María,

Si precisamos, la versión que te indica Johnny es 'incorrecta', la versión "estable" es la 3.0.9.6

Haz copia de seguridad antes de proceder.

- Copias de Seguridad en Joomla 2.5.x y 3.1.x con Akeeba Backup: www.webempresa.com/blog/item/1109-copias-de-seguridad-en-joomla-25-y-3x-con-akeeba-backup.html

Saludos

This post was modified hace 9 meses por antonio

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/08/2015 10:39 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

María
 María
Estimable Member

Hola Luis, acabo de actualizar Joomla a la última versión (Joomla! 3.4.3) y Virtuemart a la versión 3.0.9.6, pero lamentablemente siguen sin funcionarme los productos relacionados.
¿Alguna idea?
Gracias.

ResponderCitar
Respondido : 30/08/2015 12:27 pm
María
 María
Estimable Member

Acabo de detectar un nuevo problema bastante grave surgido tras la actualización:
Ahora no puedo eliminar ni añadir ninguna imagen desde la pestaña "Imágenes de Producto".
Gracias.

ResponderCitar
Respondido : 30/08/2015 9:55 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola María,

Me comenta un Técnico de Soporte que no ve ningún error a nivel servidor ni Hosting tras la actualización de Joomla y de VirtueMart y que los parámetros de ejecución están correctos.

¿Puedes documentarnos a que errores de funcionamiento te refieres?

- Los formatos de capturas admitidos son .jpg y .png (no .bmp)
- No la incruste en archivos .doc de Word o similares, ni en PDFs.
- No las unifique en una sola captura.

Gracias

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/08/2015 3:26 am
María
 María
Estimable Member

Hola Luis, por favor discúlpame error mío, ahora tras la actualización la pestaña "Imágenes de Producto" se queda como acción de subir imagen en "Ninguna" por lo que evidentemente no sube ni guarda las imágenes.

El problema que sigo teniendo es que sigo sin poder relacionar productos ni categorías, cuando selecciono algún producto o categoría y pulso en guardar, estos desaparecen. Adjunto captura de pantalla de una categoría y un producto seleccionados y el resultado cuando pulso guardar.

Gracias.

ResponderCitar
Respondido : 31/08/2015 8:41 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Julen
 Julen
Miembro Admin

Hola,

El fallo podría estar relacionado con alguna incompatibilidad de la plantilla.

Para comprobar si es un tema de la plantilla puedes renombrar el directorio /templates/tuplantilla/html/com_virtuemart a com_virtuemart_old y realiza nuevamente las pruebas.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/08/2015 10:29 am
Página 1 / 2

Por favor Iniciar Sesión o Registro