Ocultar bloque contenido en plantilla JA Zeolite si no se publican artículos en portada  

 
Joxean
 Joxean
Usuario eminente

Muy buenas,

La parte superior de algun módulo se me queda enganchado, debajo de productos destacados.
Mejor ver la imagen adjunta

Saludos,

Citar
Respondido : 09/11/2011 12:09 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Joxean,

Desde el Gestor de Módulos filtra por posiciones la posición "ja-slider" y mira a ver que tienes publicado que aparezca en portada que o bien esté incompleto, o que no funcione.

Podría incluso tratarse de un "mod_custom" al que le eliminaste contenido y no deshabilitaste el módulo.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/11/2011 12:33 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Joxean
 Joxean
Usuario eminente

Buenas,

No me aparece ninguna posición ja-slider.
Y de los módulos habilitados no hay ninguno que lo relacione.

Ja-slider es la posición concreta del módulo que está enganchado???

Saludos,

ResponderCitar
Respondido : 09/11/2011 10:27 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por lo que veo es posible que el problema no esté en un módulo, sino que en la página de inicio no estás cargando ningún contenido (artículo) y eso hace que salga la parte superior de la caja de contenidos. Es posible que haya que hacer cambios en el diseño de la plantilla para que no salga esa caja en la página de inicio.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/11/2011 1:19 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Joxean
 Joxean
Usuario eminente

Buenas Pablo,

Y qué cambios habría que hacer??? Los puedo hacer yo???

Saludos,

ResponderCitar
Respondido : 10/11/2011 9:28 am
David Noguera
 David Noguera
Miembro Admin

Hola Joxean,

si nos pasas la URL de la web que te da problemas, a poder ser una URL donde se aprecie el problema, podríamos indicarte alguna modificación que podrías hacer para solucionar esto..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/11/2011 10:26 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Joxean
 Joxean
Usuario eminente

Hola David,

Esta es la url: http://www.euskal-produktuak.com/index.php

ResponderCitar
Respondido : 10/11/2011 10:33 am
David Noguera
 David Noguera
Miembro Admin

El fallo está en lo que indica pablo,

como solución rápida puedes aplicar el siguiente código en el fichero index.php de tu plantilla:

getActive() == $menu->getDefault()) {
$doc = JFactory::getDocument();
$style = "#ja-current-content {display:none;}";
$doc->addStyleDeclaration( $style );
}
?>

El problema es que si aplicas este código después no podrás introducir artículos en la página principal, cuando quieras introducir un artículo en la página principal tendrás que quitar el código.

Prueba y nos cuentas.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/11/2011 11:06 am

Cursos Gratuitos WordPress

Joxean
 Joxean
Usuario eminente

Gracias David,
no sé qué decisión tomaré, porque después seguro que no me acuerdo de éste cambio!!!

Gracias por vuestra ayuda

ResponderCitar
Respondido : 10/11/2011 3:24 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Otra solución que podrías aplicar sería la siguiente: editar el archivo templates/ja_zeolite/index.php y busca el siguiente código:


Sustitúyelo por lo siguiente:


countModules('inicio')) { ?>

Después tendrías que crear un nuevo módulo de tipo html y situarlo en la posición inicio. Da igual el texto que lleve el módulo porque no se va cargar. En los lugares donde publiques el módulo no se cargará la parte de artículos. Es decir, si solo lo publicas en la página de inicio no se cargará la parte de contenidos en la home. Luego, si un día sí que necesitas colocar contenidos, tan solo tendrás que desactivar el módulo que has creado.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/11/2011 4:23 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Joxean
 Joxean
Usuario eminente

SOLUCIONADO

No he optado por las soluciones que me habeís dado, pues he puesto una categoría de vm de página de inicio, pero se agradecen las soluciones propuestas.

Gracias y saludos

ResponderCitar
Respondido : 12/11/2011 1:52 am

Por favor Iniciar Sesión o Registro