Problema con campo personalizado en Virtuemart  

Página 1 / 2
 
Marco
 Marco
Reputable Member

Hola,

tenemos Joomla 3.7.5
Virtuemart 3.2.2.

El problema es que si a un producto le ponemos en los campos personalizados la opcion para enviar una imagen no se puede añadir al carro.

Aquí os dejo un producto de prueba para que podais ver lo que pasa:

http://www.grabadosguerrero.com/index.php/articulos-publicitarios/encendedores/individuales/prueba-2-detail.html

Si le quito este campo personalizado si funciona.

No entiendo lo que pasa.

Muchas gracias.
Marco

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 25/10/2017 1:32 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola marco.

Estoy probando añadirlo y no tengo problemas:

No puedo finalizar la compra por el tema del usuario y que tienes que validar la cuenta pero añadirlo al carro lo añade

Si el problema viene después, adjunta un usuario demo para que podamos realizar un pedido ( Usuario para el front no para la administración )

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 25/10/2017 4:01 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Marco
 Marco
Reputable Member

Hola Pepe,

Gracias por tu respuesta.

No añade el producto al carrito ya que deberia aparecer en la "ventanita" que me indicas.

Si te fija en este producto http://www.grabadosguerrero.com/index.php/articulos-publicitarios/encendedores/individuales/prueba-detail.html que no tiene el campo personalizado en cuestion si lo muestra (adjunto imagen).

De toda forma he habilitado un usuario para que puedas probar hasta el final.

Usuario: webempresa
Contraseña: empresaweb

Gracias

ResponderCitar
Respondido : 25/10/2017 5:10 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Efectivamente, aparece como si lo añadiera pero al ver los ítems en el carrito no aparece ninguno.
Es muy extraño porque no sale ningún error javascript.

Para descartar problemas con tu template podrías probar si te sucede lo mismo cambiando temporalmente de plantilla, usa alguna que trae por defecto Joomla

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/10/2017 8:13 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Marco
 Marco
Reputable Member

Hola Jhon,

He cambiado de plantilla y sigue pasando lo mismo.

Marco

ResponderCitar
Respondido : 26/10/2017 12:17 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Marco.

Accede a la configuración de Virtuemar y revisa la URl que tienes añadida para la subida de los archivos.
En principio a nivel servidor no existen problemas por lo que deduzco que puede ser problema de la URL.

Si puedes adjunta una captura de la configuración.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 26/10/2017 3:31 pm

Cursos Gratuitos WordPress

Marco
 Marco
Reputable Member

Hola Pepe,

adjunto captura.

Las carpetas estan creadas en el servidor.

Marco

ResponderCitar
Respondido : 26/10/2017 4:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba poner algún valor en el input size, también habilita el modo debug, la última opción de tu captura de pantalla.

En tu captura de pantalla no se ven las rutas completas, indícanos que rutas has usado, puedes enviarnos también una captura de pantalla de las rutas vistas con el Administrador de Archivos de tu Cpanel.

Pasa una revisión de tu cuenta con la herramienta Stephan, disponible al hacer un ticket, esto para verificar si hay algún problema con los permisos de carpetas, verifica también si se generan errores recientes relacionados con esto.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/10/2017 7:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Marco
 Marco
Reputable Member

Hola,

he añadido un valor al campo imput size y habilitado la opción modo debug.

He pasado revision con Stephan y parece estar todo ok.

Estas son las rutas:

images/imagenes_sellos_tmp

images/imagenes_sellos

Adjunto captura rutas en administrador de archivos.

Sigue igual sin cargar en el carrito.

Marco

ResponderCitar
Respondido : 27/10/2017 10:36 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En la ruta de las imágenes veo que estas usando la ruta de url, prueba usar una ruta física

Es decir por ejemplo: home/TUCUENTA/public_html/images/imagenes_sellos_tmp

Verifica la ruta que debes usar desde el Administrador de Archivos de tu Cpanel

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/10/2017 7:53 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Marco
 Marco
Reputable Member

Hola John,

He probado a cambiar la ruta tal y como me has dicho pero sigue igual.

Marco

ResponderCitar
Respondido : 30/10/2017 12:05 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Marco.

Tienes la web en mantenimiento y no podemos realizar prueba, por favor activa la web para que lo revisemos.
.- Comprueba las versiones de PHP que tienes instalada en tu cuenta, revia que tengas como minimo la 5.6, si no es así la modificas -> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Tienes plugins para realizar lo que buscas -> https://extensions.joomla.org/extensions/extension/extension-specific/virtuemart-extensions/order-files-upload-for-virtuemart/

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 30/10/2017 2:53 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Marco
 Marco
Reputable Member

Hola Pepe,

Ya he puesto otra vez online la Web.

He actualizado la version PHP a la 5.6 (pero sigue igual)

Gracias.

Marco

ResponderCitar
Respondido : 30/10/2017 6:16 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Verifica si te sucede lo mismo con otro plugin para virtuemart por ejemplo uno que coloque una caja de texto
Revisa: https://www.ostraining.com/blog/joomla/custom-field-virtuemart/

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/10/2017 9:19 pm

Cursos Gratuitos WordPress

Marco
 Marco
Reputable Member

Hola John,

Ya tenia un plugin para enviar texto libre junto con el producto. (adjunto captura configuracion campo personalizado).

He quitado campo pers. enviar imagen y he puesto campo pers. enviar texto y funciona, cuando vuelvo a poner enviar imagen no.

Marco

ResponderCitar
Respondido : 30/10/2017 10:14 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro