Problema con cesta de compra  

 
Juan
 Juan
Noble Member

Hola,

Tengo un pequeño problema que no se exactamente cual es. Vereis a mi no me pasa pero ya son varios los clientes que me comentan que les pasa he incluso me han tenido que hacer un pedido por telf por que no erna capaces a subir productos a la cesta de la compra.

La cosas es esa, que cuando el cliente quiere añadir artículos a la cesta de la compra no se los sube, insito en que a mi eso no me pasa, pero parece ser que a algunos clientes tienen ese problema.

He probado con todos los navegadores que conozco y solo me he topado con un problema que no se si tendrá que ver con lo que os comento, en explorer pongo el usuario y contraseña y no responde, es como si no huviese hecho nada... no sé si tendrá que ver.

La url es www.tiempozamora.es

Un saludo y gracias.

Citar
Respondido : 23/11/2011 11:51 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El problema de que no funcione el botón de añadir al carro en Virtuemart puede venir determinado por los datos que has puesto en la Configuración de Virtuemart. En la pestaña Seguridad hay dos parámetrosSite URL y SECUREURL donde supongo que has puesto http://www.tiempozamora.es, lo que ya es correcto.

El problema estaría en que si un usuario entra en la web con la url tiempozamora.es (sin las www) no le funcionará el botón de añadir al carro.

La mejor solución pasaría porque hicieras un cambio en el archivo .htaccess que se encuentra en la raíz de tu web para que cuando un usuario pone la dirección de tu página sin las www, se coloquen automáticamente las www.

Para ello, en el archivo .htaccess añade el siguiente código:

RewriteCond %{HTTP_HOST} !^www.tiempozamora.es$ [NC]
RewriteRule (.*)  http://www.tiempozamora.es/$1  [R=301,L]

Esto, además de arreglar el problema con el botón de añadir al carro, mejoraría el posicionamiento de la web en los buscadores.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/11/2011 12:05 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan
 Juan
Noble Member

Hola,

Donde tengo que añadir el código, osea en que parte del .htacees tengo que poner el código?

Muchas gracias!

ResponderCitar
Respondido : 23/11/2011 12:27 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Juan,

Has una copia de seguridad del archivo .htaccess antes de modificar, y añade las lineas que te indica Pablo al inicio del mismo.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 23/11/2011 12:58 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan
 Juan
Noble Member

Ostras... en un principo funcionaba bien, hice la prueba y todo ok, pero ahora me veo que han desparecido los productos en la web, osea que no se ven, puedes navegar por las categorias pero al llegar a los productos no se ve nada, no creo que se por el codigo que he puesto ya que he hecho una copia como indicaba jordi, y al poner la copia sigue igual.

He puesto tambien el archivo este de shop_browse para el virtuemart 119 pero sigue igual.

Hoy al medio dia al ver que he trabajado mucho en esta web y está practicamente lista he hecho una cipia de seguriada, la he insertado a traves del administrador de archivos pero tampoco, la cosa es que otra vez estoy a cuadros con lo que habrá podido pasar...

ResponderCitar
Respondido : 23/11/2011 5:27 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Asegúrate que tras los cambios el archivo .htaccess no hay cambiado de nombre y sigue teniendo el punto antes del htaccess.

Prueba también a desactivar el SEO para ver si esa es la causa del problema.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/11/2011 5:30 pm

Cursos Gratuitos WordPress

Juan
 Juan
Noble Member

Si deshabilito SEO sigo teniendo el problema y no entoendo muy bien donde tiene que estar el "." es delante de htaccess, no?

ResponderCitar
Respondido : 23/11/2011 5:33 pm
Juan
 Juan
Noble Member

Ahora mismo y hasta que se resuelva a ver que ha pasado esta como estaba antes de hacer ningun cambio, pero joer... que mobida...

ResponderCitar
Respondido : 23/11/2011 5:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan
 Juan
Noble Member

Ok, ya está resuelto el tema, por lo visto un usuario de la web se pueso a indagar para hacer tipos de descuentos, creó un grupo de compradores cual puso por defecto. Lo he cambiado por el que estaba y listo.

Que por cierto no estaría mal saber como poder hacer descuentos a ciertos usuarios, en este caso el cliente quiere hacer un 15% de descuento a clientes asociados. Pero bueno quizas cada cosa a su tiempo, ya sabeis cual será mi proxima tocadura de narices.

Muchas gracias por vuestra paciencia, y Saludos!

ResponderCitar
Respondido : 23/11/2011 6:25 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Juan,

Te será de utilidad http://virtuemart.webempresa.eu/index.php?title=Grupo_de_Compradores

Interesante revisen los artículos de nuestro blog:
Configuración de precios con Virtuemart -->
Mostrar productos por grupo de compradores en Virtuemart -->

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 24/11/2011 9:14 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro