Problema con IE 9 y pago con tarjeta  

 
Sergio
 Sergio
Reputable Member

Estoy probando la compra a traves de tpv (sermepa) y me encuentro con un caso atípico. Todo funciona bien en Crome y firfox.

En IE 9 cuando voy a finalizar la compra y elijo tarjeta (configurado segun video de webempresa), magicamente me redirecciona a la pagina de paypa. Tengo tambien configurado paypal como metodo de pago. Pero com he indicado en el primer parrafo esto solo ocurre con IE 9. Con otros navegadores me redirecciona a la pagina de sermepa para el pago con tarjeta.

Saludos

URL del sitio: http://www.pienso24horas.com/comida-para-perros

Citar
Respondido : 21/03/2012 9:47 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

Lo que comentas cuando menos es curioso porque es la primera vez que oigo eso 🙂

No obstante para esclarecer que puede estar pasando seria útil que facilites una captura del momento anterior y posterior al proceso de checkout que comentas para ver si hay algún indicio del problema.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/03/2012 10:44 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Sergio
 Sergio
Reputable Member

Hola anexo la captura, pero el momento anterior es seleccionar el metodo de pago y el posterior la redicreccion a paypal. Con Chrome por ejemplo no pasa esto cuando seleccionas la tarjeta la redireccion es hacia el terminal de sermepa.

Entien que debe haber algo de codigo que provoque esto en IE

ResponderCitar
Respondido : 24/03/2012 10:23 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

¿Puedes facilitar un usuario de "prueba" para simular el proceso y poder sacar mejores conclusiones? La captura deja claro que seleccionar el método de "pago mediante Tarjeta de Credito" por lo que no tiene porque redireccionarte a Paypal.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/03/2012 10:33 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Sergio
 Sergio
Reputable Member

Si claro,

Test5
Pwd Contenido solo visible a usuarios registrados

Te habilito solo para ti este metodo de pago

ResponderCitar
Respondido : 24/03/2012 10:35 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

Es posible que tenga sun problema de caché pues he realizado un proceso de compra de un producto y en el ckeckout, forma de pago, elijo Tarjeta de Credito y me lleva correctamente al TPV virtual del banco.
Contenido solo visible a usuarios registrados
Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/03/2012 2:06 am

Cursos Gratuitos WordPress

Sergio
 Sergio
Reputable Member

He borrado la cache completa del navegador.......y nada me sigue dirigiendo a paypal. Voy a probar desde otro equipo.

Os cuento los resultados.......

ResponderCitar
Respondido : 25/03/2012 1:04 pm
Sergio
 Sergio
Reputable Member

Hola acabo de probar desde otro equipo y el resultado es el mismo.....me redirecciona a paypal.

Luis puedes volver a probar, me pasa con IE 8 y IE 9.

Si desactivo el metodo de pago Paypal_api todo funciona bien.

ResponderCitar
Respondido : 25/03/2012 1:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Sergio
 Sergio
Reputable Member

Luis solucionado, el problema estaba en esta linea de código....por algún motivo en value yo tenía prefijado un 2, lo he dejado como estaba el orignal y todo OK

Realmente a ti con IE 8 y IE 9 te ha funcionado????

El problema es que si quito ese 2 de este sitio, cuando elijo paypal me sale el famoso error de invlaid credit card number, verification code, bla,bal.....

ResponderCitar
Respondido : 25/03/2012 1:50 pm
Sergio
 Sergio
Reputable Member

Hola he encontrado esto en el foro oficial de VM, con el archivo anexo se soluciona el problema. Me gustaría conocer vuestra opinión al respecto.

El Link de articulo es :

http://forum.virtuemart.net/index.php?topic=84650.0

En el mismo post podéis ver el fichero que he reemplazado...que os parece?? Algun caso similar??

ResponderCitar
Respondido : 25/03/2012 3:13 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por lo que veo el problema se debe a los diferentes sistemas de interpretar el código javascript que tiene el Intenet Explorer y otros navegadores, de forma que haga que su comportamiento no sea el correcto.

Si has aplicado los cambios que viene en el enlace que has pegado y funciona bien te recomiendo que ya no lo cambies.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/03/2012 1:27 pm
Sergio
 Sergio
Reputable Member

Gracias, Pablo. Lo que me resulta extraño es que ha nadie se le de la misma situacion que a mi.....

ResponderCitar
Respondido : 27/03/2012 10:42 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Cabe la posibilidad de que esto se deba a que estás usando un tema de Virtuemart que no es el que viene por defecto, y que en este tema existan ligeros cambios que puedan afectar a esto, aunque lo veo poco probable.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/03/2012 1:14 pm

Por favor Iniciar Sesión o Registro