Avisos
Vaciar todo

Problemas al cambiar de plantilla crystalline a Camber  

Página 1 / 3
 
Juan
 Juan
Noble Member

Hola,

Pues eso, estoy intentando cambiar de plantilla, en este caso de Crystalline a Camber. El motivo por el cual quiero cambiar, es por que tengo una serie de problemas con los menus y navegadores que no he conseguido arreglar.

Uno es que en IE lo menús desplegables quedan por detras de los módulos. Y los menús desplegables solo despliegan una vez, osea en www.pk-0.info si das a conocenos, hay tres sub menus, de los cuales uno es delegaciones, y éste tiene 5 o 6 subnenus, pues esno no encuentro la formar y he buscado mucho de que se habran.

Por lo que he visto desde aquí parece ser problema del templete y lo he consultado en Rocktheme pero sigo igual. Por lo cual quiero instalar el template Camber que he utilizado en otras webs con óptimo resultado, tanto en navegadores como en los problemas que acabo de contar, pero una vez instalado el templete y las extensiones y al poner de predeterminada la plantilla, al actualizar el sitio me aparece el siguiente mensaje.

"Warning: require_once(/home/pkinfo/public_htmlgantry-splitmenu/formatter.php) [function.require-once]: failed to open stream: No such file or directory in /home/pkinfo/public_html/modules/mod_roknavmenu/helper.php on line 129

Fatal error: require_once() [function.require]: Failed opening required '/home/pkinfo/public_htmlgantry-splitmenu/formatter.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/pkinfo/public_html/modules/mod_roknavmenu/helper.php on line 129"

Si entro al template para editar la plantilla parece estar bien instalada, os adjunto la captura.

Muchas gracias de nuevo!

URL del sitio:

URL del sitio:

URL del sitio:

Citar
Respondido : 30/01/2012 7:46 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

¿Puedes indicarnos si te aparece algún error al respecto en /administrator/error_log o en /public_html/error_log?

Saludos

ResponderCitar
Respondido : 30/01/2012 9:12 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan
 Juan
Noble Member

No creo que tenga mucho que ver con el tema, pero pongo los errores que me aparecen

[13-Nov-2011 11:07:48] PHP Notice: Only variable references should be returned by reference in /home/pkinfo/public_html/administrator/components/com_ninjaxplorer/libraries/Archive.php on line 576
[13-Nov-2011 11:07:48] PHP Notice: Only variable references should be returned by reference in /home/pkinfo/public_html/administrator/components/com_ninjaxplorer/libraries/Archive.php on line 595
[30-Jan-2012 22:24:08] PHP Notice: Undefined index: extension in /home/pkinfo/public_html/administrator/components/com_ninjaxplorer/include/fun_edit.php on line 96
[30-Jan-2012 22:26:26] PHP Notice: Undefined index: extension in /home/pkinfo/public_html/administrator/components/com_ninjaxplorer/include/fun_edit.php on line 96
[31-Jan-2012 11:15:06] PHP Notice: Undefined index: extension in /home/pkinfo/public_html/administrator/components/com_ninjaxplorer/include/fun_edit.php on line 96

Saludos.

ResponderCitar
Respondido : 31/01/2012 10:16 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

sobre la plantilla Crystalline he revisado la demo en la url http://demo.rockettheme.com/mar10/ y veo que en ella abre submenús de segundo nivel e incluso superiores. Tendrías que revisar la configuración de la plantilla para determinar si hay un parámetro que indique el nivel máximo de profundidad del submenú.

Sobre los problemas que tienes después de instalar la nueva plantilla, parece que estos están en la ruta en la que va a buscar los archivos. Como verás, nos indicas que te salen errores como el siguiente:

require_once(/home/pkinfo/public_htmlgantry-splitmenu/formatter.php)

Si se fijas, faltaría una barra entre public_html y gantry-splitmenu. Tendrías que revisar si has hecho algún cambio en la configuración de tu Joomla que esté afectando a la ruta.
Prueba también a limpiar la caché por si puediera ser ese el problema.

ResponderCitar
Respondido : 31/01/2012 11:24 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan
 Juan
Noble Member

Si se fijas, faltaría una barra entre public_html y gantry-splitmenu. Tendrías que revisar si has hecho algún cambio en la configuración de tu Joomla que esté afectando a la ruta.
Prueba también a limpiar la caché por si puediera ser ese el problema.

Donde puedo mirar los cambios que que haya podido hacer en el Joomla sin poner mucho en riesgo el contenido de la web?

Gracias

ResponderCitar
Respondido : 05/02/2012 10:34 am
Juan
 Juan
Noble Member

Hola,

Con respecto al problema del desplegable del menú, acabo de hacer una prueba, poniendo otra plantilla, en este caso Zeolite y el problema persiste, por lo que me da a entender que no es cosa del template. He estado mirando y comparando con otras webs con el mismo template (crystalline) que no tienen este problema, por ejemplo webservi.es y he parejado todos los datos posibles y sigo igual.

Tambien he probado en configurar en Gestor de Modulos, y entro del módulo menú, pero sigo igual...

dejo la captura del template zeolite.

ResponderCitar
Respondido : 05/02/2012 11:09 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Juan,

He querido revisar el sitio web Contenido solo visible a usuarios registrados, pero veo que lo tienes en mantenimiento.

No veo en la captura de pantalla en la que se muestra la plantilla Zeolite, que los elementos del menú principal cuando se desplegan, que queden por debajo del módulo, sino que no se muestran.

¿Que opción de menú has escogido en la plantilla zeolite? No parece tema del módulo, ya que con el módulo despublicado de menu principal, sigue trabajando el mismo en la plantilla.

Saludos

ResponderCitar
Respondido : 06/02/2012 9:13 am
Juan
 Juan
Noble Member

Se despiega una vez, un nivel. en este caso en el menu principal existen varios subniveles, " conócenos/delegaciones/sevilla,cadiz... pues se despiega hsata delegaciones.

Lo mismo pasa en maquinaria/plataformas elevadotas/Tijeras y plaragoras elevadoras/ pues llega hasta el segundo subnivel el tercero no se desopliega.

Lo he provado en distintos templates y pasa en todos por lo que creo que es algo de configuración. Pero he dado mil vueltas y he provado de todo, pero no encuentro donde está la pifia.

Saludos, desbloque unas horas la web para que le echesi un vistazo si lo creeis oportuno.

ResponderCitar
Respondido : 06/02/2012 11:40 am

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Envía una captura de pantalla de los elementos de menú del menú principal que estás cargando en la cabecera para que podamos ver la estructura que tiene, ya que es muy raro que no te cargue bien con distintas plantillas.

ResponderCitar
Respondido : 06/02/2012 5:25 pm
Juan
 Juan
Noble Member

Ahí van 4 capturas.

a ver si nos acercamos un poco a la solución...

Gracias!

ResponderCitar
Respondido : 06/02/2012 5:34 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Excepto la primera captura que has enviado (con esta era suficiente) el resto veo que pertenecen a un módulo para cargar el menú, pero que no tiene nada que ver con el menú de la cabecera que entiendo que se genera solo desde la propia plantilla.

Revisando un poco el código fuente de la página veo que realmente los enlaces a los elementos de menú de tercer nivel sí que se están cargando pero por alguna razón no se están cargando.

Tendría que revisar si has realizado cambios en el código de la plantilla o has instalado algún plugin que pueda estar interfiriendo en el correcto funcionamiento del menú superior.

Puedes probar a cambiar a la plantilla Zeolite de nuevo y dejarlo así para que lo podamos revisar.

ResponderCitar
Respondido : 06/02/2012 5:44 pm
Juan
 Juan
Noble Member

Ok Pablo, ya esta Zeolite como template predeterminado.

Muchas gracias por tu dedicación!

Saludos!

ResponderCitar
Respondido : 06/02/2012 5:50 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por lo que veo, el menú superior que se está cargando para tu plantilla Zeolite no se corresponde en aspecto al que viene por defecto con la plantilla, por lo que no se si has aplicado cambios para esta plantilla.

Es posible que exista un conflicto con el código javascript. Vete a Extensiones->Gestor de plantillas y edita la plantilla Zeolite. En el parámetro Menu Module elige la opción "CSS Menu" y comprueba si así sí te funciona.

ResponderCitar
Respondido : 06/02/2012 5:57 pm
Juan
 Juan
Noble Member

Funciona... Lo que seria fabuloso si funcionase con el templeate crystalline...

ResponderCitar
Respondido : 06/02/2012 6:52 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Con tu sitio en mantenimiento no podemos revisar.
Te sugiero si esta en producción realizar un clon de tu sitio para poder ver lo que comentas.

Saludos

ResponderCitar
Respondido : 07/02/2012 12:28 am
Página 1 / 3