Avisos
Vaciar todo

Error 500 al ver pedidos  

 
Gustavo
 Gustavo
Usuario activo

Recién cambié la versión final de mi tienda de un subdominio en el que la estaba trabajando al dominio principal, ahora no puedo acceder a los pedidos pues encuentro el siguiente error (ver imagen adjunta por favor), ya intenté con algunas soluciones que encontré en foros como activar y desactivar la moneda, cambiar la precisión de la tabla a 2 (no fue necesario pues este ya era el valor), instalar la moneda USD,

error

nada me ha funcionado hasta el momento

Contenido solo visible a usuarios registrados

Citar
Respondido : 19/01/2021 7:27 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Has probado activar y desactivar la moneda que tengas por defecto?, supongo que es dolar, has probado instalando otra moneda con el paquete de localizacion?

Tienes una multititenda? o es sólo un sitio web?

Al parecer igual podría ser un bug de la versión de tu PrestaShop, qué versión exacta tienes?

Aqui se discute el tema: https://github.com/PrestaShop/PrestaShop/issues/14595

Anteriormente en el subdominio entiendo que todo funcionaba bien, podrías evaluar recuperar una copia de tu cuenta antes de que hayas movido el sitio y verificar, puedes hacerlo con Superbackup: https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-de-seguridad-con-superbackup-en-cpanel/

Saludos.

ResponderCitar
Respondido : 19/01/2021 7:38 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Gustavo
 Gustavo
Usuario activo

@jmarreros

Hola! mi moneda por defecto es el peso mexicano, ya intenté activarla y desactivarla, también desinstalarla e instalarla nuevamente desde el paquete de localización, e instalé también otras monedas (EUR y USD), no tengo multitienda, pero importé clientes, pedidos y productos desde la versión anterior de mi tienda
Estaba usando 1.7.7.0 cuando comenzó el problema, actualicé a 1.7.7.1 para ver si se solucionaba el problema pero no fue así

Así es esta misma tienda cuando se accedía a ella desde el subdominio funcionaba bien

Restauré primero el directorio de la tienda y el error persistía, después restauré la base de datos y sucedió lo siguiente: Ahora sí puedo acceder a la página de pedidos, pero al intentar ver el detalle de algunos pedidos (a otros se puede acceder sin problema) o al dar clic en la flechita para cambiar el orden de los pedidos por ID, nuevamente arroja el mismo error

error2

 

ResponderCitar
Respondido : 19/01/2021 8:13 pm
Gustavo
 Gustavo
Usuario activo
Respondido por: @cloudealeroutlook-com

@jmarreros

Hola! mi moneda por defecto es el peso mexicano, ya intenté activarla y desactivarla, también desinstalarla e instalarla nuevamente desde el paquete de localización, e instalé también otras monedas (EUR y USD), no tengo multitienda, pero importé clientes, pedidos y productos desde la versión anterior de mi tienda
Estaba usando 1.7.7.0 cuando comenzó el problema, actualicé a 1.7.7.1 para ver si se solucionaba el problema pero no fue así

Así es esta misma tienda cuando se accedía a ella desde el subdominio funcionaba bien

Restauré primero el directorio de la tienda y el error persistía, después restauré la base de datos y sucedió lo siguiente: Ahora sí puedo acceder a la página de pedidos, pero al intentar ver el detalle de algunos pedidos (a otros se puede acceder sin problema) o al dar clic en la flechita para cambiar el orden de los pedidos por ID, nuevamente arroja el mismo error

error2

 

Al realizar el backup se había puesto nuevamente el subdominio como url de la tienda en SEO & URL, al cambiarlo nuevamente al dominio principal, el error aparece nuevamente desde que doy clic en Pedidos

ResponderCitar
Respondido : 19/01/2021 8:19 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Esto que comentas:

"al cambiarlo nuevamente al dominio principal, el error aparece nuevamente desde que doy clic en Pedidos"

No es suficiente cambiar esto, tienes que igualmente mover los archivos físicos para que funcione cuando cambias un sitio de un subdominio al dominio principal.

Sin embargo en tu comentario anterior según comentas igualmente no funcionaba bien en el subdominio. Tendrías que asegurarte primero de que funcione bien en el subdomino. Recupera un backp de tu cuenta completa, archivos y BD y verifica esto antes de mover el sitio de ubicación.

Saludos.

ResponderCitar
Respondido : 19/01/2021 8:23 pm
Gustavo
 Gustavo
Usuario activo

@jmarreros 

Lo que hice fue cambiar el directorio al que apuntaba el dominio principal, del directorio de la tienda anterior a la nueva, no es esta la manera correcta?

ResponderCitar
Respondido : 19/01/2021 8:30 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Teóricamente si apuntantes a otra ubicación, si debería funcionar.

Lo otro que podrías haber realizado es mover tus archivos hacia la nueva ubicación, hacia donde apunta el dominio principal.

De todas formas recuperar nuevamente y asegúrate de que funcione bien en el subdominio.

Saludos.

 

ResponderCitar
Respondido : 19/01/2021 8:38 pm
Gustavo
 Gustavo
Usuario activo

Hola, he estado haciendo pruebas y parece ser que el error está incluso en la tienda anterior, pero sólo ocurre cuando trato de ver pedidos viejos (puedo ver las primeras 2 páginas de mis pedidos más recientes, pero al intentar avanzar a la tercera, o al cambiar el orden para que muestre primero los pedidos más antiguos, se muestra el mismo error)

ResponderCitar
Respondido : 19/01/2021 10:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@cloudealeroutlook-com

Hola Gustavo, 

El problema que describes al ver los pedidos mas antiguos, ¿Se genera en el sitio web cuyo dominio es Contenido solo visible a usuarios registrados, ¿Tiene configurada la versión 5.6 de PHP? ¿Podrías verificarlo? -> cambiar-la-version-php

Además veo el siguiente error en tu cuenta de hosting:

[19-Jan-2021 15:35:37 America/Mexico_City] PHP Fatal error:  Uncaught PDOException: SQLSTATE[42000] [1203] User clouddea_FcYHWAFO already has more than 'max_user_connections' active connections in /home2/clouddea/public_html/prueba2/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:27
El cual explicaría, probablemente, el por qué de los problemas que están presentando tus sitios webs, como puedes ver se ha rebazado el limite de recursos desde el Prestashop cuyo Document root se encuentra en la carpeta prueba2, esto entonces afectará al resto de tus Prestashops pues se encuentran en el mismo servidor o cuenta de hosting. Lo que debes hacer es reducir el consumo de recursos en conexiones a la base de datos en el prestashop ubicado en prueba2, ¿Cómo? Desactivando el modulo de estadísticas por ejemplo y tambien los últimos modulos que hallas instalado. 

Saludos 

Esta publicación ha sido modificada el hace 1 mes por Bulmaro
ResponderCitar
Respondido : 19/01/2021 11:10 pm
Gustavo
 Gustavo
Usuario activo

@bulmaro-webempresa

Hola, éste error sucede en los sitios clean.clouddealer.com.mx y clouddealer.com.mx

Nunca había intentado ver pedidos antiguos así que probablemente el problema esté presente desde la instalación

ResponderCitar
Respondido : 19/01/2021 11:26 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@cloudealeroutlook-com

Hola Gustavo, 

Una disculpa, he ampliado y modificado mí anterior respuesta, por favor, revisadla y nos comentas. 

Saludos 

ResponderCitar
Respondido : 19/01/2021 11:31 pm
Gustavo
 Gustavo
Usuario activo

Sí, hoy un par de veces me arrojó ese error de "max users conection" ya que estaba trabajando en dos o en las tres tiendas que tengo en el hosting para tratar de arreglar el problema, pero cómo podría esto relacionarse con el error por el cuál abrí el tema? 

ResponderCitar
Respondido : 20/01/2021 12:09 am

Cursos Gratuitos WordPress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@cloudealeroutlook-com

Hola Gustavo, 

Precisamente por ello te pedí una captura de pantalla del error que te aparece al intentar acceder a los pedidos viejos, ya que puedo suponer que:

1.- Dado que se han rebasado en momentos muy precisos algunos recursos del revisor es posible que al intentar acceder y extraer información de la base de datos en particulares situaciones el sitio web colapse.

2, Otro supuesto es que entonces la base de datos tenga inconsistencias y por ello el sitio colapse.

3.- Que nada tenga que ver con los recursos del servidor ni la base de datos y el problema vaya por otro lado.

Esté relacionado o no, finalmente es un tema que tendrás pendiente a resolver en el futuro cercano o lejano, una cuenta de hosting con los recursos suficientes teniendo los sitios web apropiadamente configurados no tiene razón para rebasar los recursos asignados, si lo hace es por que algún componente o varios de ellos están haciendo algo mal.

Saludos 🙂 

ResponderCitar
Respondido : 20/01/2021 1:43 am
Gustavo
 Gustavo
Usuario activo
Respondido por: @cloudealeroutlook-com

Recién cambié la versión final de mi tienda de un subdominio en el que la estaba trabajando al dominio principal, ahora no puedo acceder a los pedidos pues encuentro el siguiente error (ver imagen adjunta por favor), ya intenté con algunas soluciones que encontré en foros como activar y desactivar la moneda, cambiar la precisión de la tabla a 2 (no fue necesario pues este ya era el valor), instalar la moneda USD,

error

nada me ha funcionado hasta el momento

Contenido solo visible a usuarios registrados

Es exactamente este mismo error el que se muestra 

ResponderCitar
Respondido : 20/01/2021 3:52 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Gustavo, 

Tenemos al menos una pista con esa captura que me proporcionas puedo corroborar la relación que hay entre el problema que nos planteaste y el que veo en el los registros de tu cuenta de hosting, ¿Cómo lo relaciono? Por la hora:

[19-Jan-2021 20:52:15 America/Mexico_City] PHP Fatal error:  Uncaught PDOException: SQLSTATE[42000] [1203] User clouddea_FcYHWAFO already has more than 'max_user_connections' active connections in /home2/clouddea/public_html/prueba2/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:27

A las 20:52 fue tu publicación de la ultima respuesta y tambien la hora en que se registró el error en los Logs del servidor. Pero investigando un poco mas acerca del problema veo que el origen del mismo no viene del consumo de recursos conexiones a la base de datos, si no de otro lado.

En este caso, tal como mi compañero @jhon lo sugirió, así mismo te sugiero yo revisar los siguientes casos de otros usuarios y sus diversas soluciones:

997469-admin-cart-gives-error-500-when-trying-to-use-it

1021915-presta-currency-problems-after-moving

22733

Saludos 🙂

 

 

 

ResponderCitar
Respondido : 20/01/2021 6:35 am