Etiqueta !DOCTYPE html en la descripción de las categorias  

 
Francisco Javier
 Francisco Javier
Usuario eminente

Buenos días, me aparece al principio de la descripción de las categorías la etiqueta !DOCTYPE html y el texto de la categoría me sale recortado.

Hace unos meses siguiendo uno de los temas del foro conseguí que la descripción de las categorías se mostrase con mucha más extensión (le puse un límite bastante alto). sin embargo, desde hace unos días como se ve en la foto aparece "!DOCTYPE html " al principio y me recorta la descripción de las categorías como se ve en el siguiente enlace:

https://grupoeditorial.edicionesjavisa23.com/63-preventa

PD. Hace un par de días actualice prestashop de 1.6.1.12 a 1.6.1.18 no sé si ello puede influir.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 08/04/2018 6:20 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Francisco Javier,

¿Que límite tienes establecido? muestra una captura donde podamos ver como lo has configurado por favor.

Veo que algunas con texto mayor si se ven si cortarse: 17-proximas-publicaciones-javisa23

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/04/2018 9:55 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Francisco Javier
 Francisco Javier
Usuario eminente

Hola Luis, al acceder a /controllers/front/CategoryController.php para realizar la captura que me has pedido, he visto que en 'description_short' => Tools::truncateString($this->category->description, el valor había vuelto a 350 en lugar de 1000 que le había puesto yo, lo he vuelto a aumentar y ya está solucionado. No sé si puede ser que al realizar la actualización se hubiese cambiado la configuración a la que por defecto viene con prestashop, pero ya está solucionado.

ResponderCitar
Respondido : 09/04/2018 11:46 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Ten en cuenta que si aplicas los cambios de forma directa en archivos que se encuentren dentro del directorio controllers, cada vez que actualices tu PrestaShop a una nueva versión perderás los cambios aplicados.

Para que esto no ocurra tendrías que aplicar los cambios como override, es decir en un archivo override/controllers/front/CategoryController.php.

En el siguiente enlace se explica cómo hacerlo:

http://doc.prestashop.com/display/PS16/Overriding+default+behaviors

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/04/2018 3:18 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro