Avisos
Vaciar todo

Mi tienda va muy lenta al navegar por el idioma en Inglés. En español navega bien  

 
ALBERTO
 ALBERTO
Usuario activo

Hola, tengo una tienda en Prestashop 1.7.4.3 y al activar la tienda en inglés, y empezar a traducir páginas. Cuando me voy a la parte del cliente, y empiezo a navegar por las páginas en inglés, me tarda mucho tiempo al cargar las mismas. Mientras que si elijo el idioma Español (que es el idioma principal de la tienda) las páginas me cargan rápido.
No entiendo cual es el problema.
¿Me podéis ayudar?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 27/03/2019 12:51 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alberto.

Activa el debug de prestashop:
.- accede a tu cuenta de cPanel -> Administrador de archivos
.- Accede a la carpeta config de la instalación y edita el archivo defines.inc.php
.- Busca el siguiente código:

define(‘_PS_DEBUG_PROFILING_’, false);

.- sustituye false por true

define(‘_PS_DEBUG_PROFILING_’, true);

Una vez guardado vuelve acceder a la web podrás ver los tiempos de carga de la pagina, tiempos que tardan las consultas SQL, módulos que se ejecutan, tiempos de carga, etc...

Revisa los tiempos de carga de los módulos y podras identificar que modulo es que te esta provocando ese consumo.

Un saludo

ResponderCitar
Respondido : 27/03/2019 3:07 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

ALBERTO
 ALBERTO
Usuario activo

Hola Pepe.
Primero, gracias por tu ayuda.

He activado el debug en Prestashop, pero no logro interpretar el fallo o fallos de los módulos o que ocasiona que vaya lenta la página en inglés.
¿Puedes ayudarme? Te adjunto un enlace de un apartado de la web en inglés, he dejado activado el modo debug para que puedas mirarlo.

Enlace: http://mercanau-cp508.webprestashop.com/mercanautic_online/index.php?id_cms=15&controller=cms&id_lang=5

Igualmente, he desactivado los módulos que hacen referencia a temas de estadísticas, ya que he leído que son módulos que principalmente ralentizan la web, pero igualmente me sigue con el problema.

Espero respuesta, gracias.

ResponderCitar
Respondido : 28/03/2019 1:01 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alberto.

Los tiempos de carga mas altos los tienes en el menu de tu plantilla :

24 iqitmegamenu_tabs_lang
24 iqitmegamenu_tabs_shop
24 iqitmegamenu_tabs

Prueba lo siguiente:
.- Desactiva el modulo " Productos destacados "
.- Actualiza la versión de PHP e instala la versión 7.3
-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Revisa si mejora después de esos pasos.

Un saludo

ResponderCitar
Respondido : 28/03/2019 1:30 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

ALBERTO
 ALBERTO
Usuario activo

Hola Pepe,

He realizado lo que me comentabas:

- El módulo "Productos destacados" ya estaba desactivado
- He actualizado a la versión PHP: 7.3.3

Después de estos cambios, he probado a navegar por la página en el idioma Español y me va muy rápido la carga de páginas, pero al navegar por la página en el idioma Inglés me sigue cargando las páginas muy lento.
He vuelto a activar el modo debug para si puedes mirarlo de nuevo.
Te paso un enlace en Español de una pagina y un enlace en Inglés de la misma para que compruebes la velocidad de carga.

Enlace Español: http://mercanau-cp508.webprestashop.com/mercanautic_online/index.php?id_cms=14&controller=cms&id_lang=1

Enlace Inglés: http://mercanau-cp508.webprestashop.com/mercanautic_online/index.php?id_cms=14&controller=cms&id_lang=5

Espero respuesta, gracias por tu ayuda.

ResponderCitar
Respondido : 28/03/2019 4:41 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alberto.

ok, desactiva el modo debug.
Manda un ticket a soporte explicado el caso, en el departamento de optimización revisaran las cargas y podrán darte algunas indicaciones para mejorarlo.

Un saludo

ResponderCitar
Respondido : 28/03/2019 4:55 pm

Cursos Gratuitos WordPress

ALBERTO
 ALBERTO
Usuario activo

Ok Pepe.
Una cosa, el tema es que primero de todo escribí un ticket con este problema, y me acabaron enviando aquí, al foro. Tengo que poner algo en concreto para que ese ticket vaya al departamento de optimización (más que nada, para que no vuelvan a mandarme aquí, y esté en bucle)

Muchas gracias por tu ayuda.

ResponderCitar
Respondido : 28/03/2019 5:02 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alberto.

pon el enlace del foro para que vean de que estamos tratando
ahora paso aviso 😉

Un saludo

ResponderCitar
Respondido : 28/03/2019 5:12 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

ALBERTO
 ALBERTO
Usuario activo

Perfecto. Muchas Gracias por tu ayuda y atención.

ResponderCitar
Respondido : 28/03/2019 5:17 pm