Acceso a través de Wp-admin en blanco  

 
David UdV
 David UdV
Estimable Member

Buenos días,

Hace unos días que no entro a mi ADMIN de wordpress, y al ir a entrar hoy no puedo. La página de wp-admin me aparece en blanco. No puedo poner ni el usuario ni el password. La web parece que funciona bien. De hecho la tengo "en construcción".

La semana pasada o la anterior me paso lo mismo, pero restauré una copia de seguridad y listo! Pero si me ha vuelto a suceder es que algo esta pasando.

¿Alguna sugerencia para no tener que volver a restaurar la copia de seguridad?

Saludos,

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 24/10/2014 12:35 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a acceder a la administración de la web a través de la siguiente dirección:

Contenido solo visible a usuarios registrados

Tendrías que verificar que no hayas cambiado el directorio de la administración (wp-admin). En caso se que se siga usando este directorio tendrías que revisar si dentro de él hay un archivo error_log. De ser así, tendrías que editarlo para ver si se muestran mensajes sobre el error que se está produciendo.

ResponderCitar
Respondido : 24/10/2014 12:52 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David UdV
 David UdV
Estimable Member

Hola Pablo,

En este caso si me aparece la opción de indicar el nombre de usuario y password, pero no me reconoce los datos. Me dice que no existen. Al querer restaurar la contraseña, recibo el email, pero al pinchar sobre el enlace se me abre una página en blanco.

Sobre el archivo que me comentas de "error_log", el último error que me aparece data del 10SEP y dice así:
[10-Sep-2014 13:59:38 UTC] Error a la base de dades del WordPress Duplicate entry 'Widgets-widget title - b902cbab52e2b7f1659fa40bfde5510b' for key 'context_name' a la consulta UPDATE `wp_icl_strings` SET `name` = 'widget title - b902cbab52e2b7f1659fa40bfde5510b' WHERE `context` = 'Widgets' AND `name` = 'widget title - 6ab25d7cf59049250e5b7b0315e0a9e1' feta per do_action('wp_ajax_save-widget'), call_user_func_array, wp_ajax_save_widget, call_user_func_array, WP_Widget->update_callback, WP_Widget->save_settings, update_option, do_action('update_option_widget_text'), call_user_func_array, icl_st_update_widget_title_actions, icl_st_update_string_actions, icl_rename_string

Así pues sigo con el problema.

Saludos,

ResponderCitar
Respondido : 24/10/2014 1:11 pm
Lorena
 Lorena
Miembro Moderator

Hola David,

Al acceder a Contenido solo visible a usuarios registrados veo que sale el aviso de error de cookies.

Revisa el siguiente artículo de nuestro blog que trata este mismo error.

https://www.webempresa.com/blog/item/1565-solucionando-el-error-de-cookies-bloqueadas-al-acceder-al-dashboard-de-wordpress.html

Un saludo.

ResponderCitar
Respondido : 24/10/2014 1:32 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David UdV
 David UdV
Estimable Member

Hola Lorena,

Estoy intentando hacer esto que me dices pero no hay manera.

Desde Firefox: He podido guardar la opción a "Indicar a los sitios que quiero ser rastreado", pero en cambio no me deja guardar la opción de "Usar una confirguración personalizada para el historial".

Desde Internet Explorer: Me he ido a cambiar las cookies y no he tenido problemas. Las he cambiado sin problemas. Pero el error continua. Así pues entiendo que el problema real no son por la configuración de las cookies, ¿no?. Te adjunto imagen.

Sigo con el problema.

Saludos,

ResponderCitar
Respondido : 24/10/2014 2:29 pm
David UdV
 David UdV
Estimable Member

Hola,

Iba a preguntar si pudiera ser que corro bajo Windows 7 a 64 bits, pero me he dado cuenta de que no. He probado de acceder mediante mi iPhone y me pasa exactamente lo mismo.

Por lo tanto creo que hay que descartar el tema de las cookies. Me sale el mismo aviso, pero no he modificado nada en mi teléfono, así que creo que deberíamos descartarlo aunque aparezca el mensaje.

De hecho... Lorena, si tu tienes el tema de las cookies bien configuradas en tu navegador, y aún así te salió el error de cookies... hay algo que no cuadra.

Saludos,

ResponderCitar
Respondido : 24/10/2014 2:45 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que el problema pueda estar causado por algún plugin que hayas podido añadir a tu web. Previa copia de seguridad de la web y de la base de datos prueba a ir al directorio wp-content/plugins y renombra los directorios de los plugins que hayas añadido últimamente en tu WordPress, recordando el nombre que tenían estos directorios para volver a dejarlo como estaba tras las pruebas.

De esta forma podrás verificar si es algún plugin de los que tienes el que te causa el problema. Si tienes instalado el WPML empieza renombrando ese directorio.

ResponderCitar
Respondido : 24/10/2014 4:14 pm
David UdV
 David UdV
Estimable Member

Hola Pablo,

Pues va a ser eso!!! He modificado el directoria de KNEWS y voila! Ahora si que me funciona.

Y ahora me he fijado que en los plugins de Wordpress me aparecen 2 Knews... ¿puede estar por ahí el error? ¿Cómo puede eliminar uno de ellos? Os adjunto imagen.

Saludos,

ResponderCitar
Respondido : 24/10/2014 7:24 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Una vez que has identificado el plugin puedes desde el backend de tu wordpress desinstalarlo ya que actualmente no esta activo.

Saludos.

ResponderCitar
Respondido : 24/10/2014 10:13 pm