Acceso al panel imposible  

 
Xulián
 Xulián
Usuario eminente

Hola, no sé que me puede estar pasando, desde hoy se me ponen las páginas en blanco cada vez que publico una página (aunque sí se actualizaban) ahora solo la web se ve, no puedo acceder a mi panel ya que las paginas cargan en blanco, nisiquiera entrar en mi panel (los intentos de entrar con usuario fallan). Ya he borrado todo plugin que he instalado hoy, los cambios en wp-config.php, etc y esto cada vez está peor.

He escrito un ticket y me han respondido que puede ser por varios intentos de entrar con contraseña incorrecta. Me han dicho que han desbloqueado mi IP y debería poder entrar pero no lo he conseguido

Muchas gracias,

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 24/10/2014 12:02 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Xulian,

Me comenta un Técnico de Soporte que en el archivo /home/xironet6/public_html/wp-config.php tienes estos defines:

Contenido solo visible a usuarios registrados

Si el dominio xiroeco.com es el dominio principal y la web está en /public_html ¿para que declaras esos defines?, no son necesarios, elimínalos.

Si la web está en /public_html el define siguiente del archivo /home/xironet6/public_html/wp-config.php es incorrecto:

define('ABSPATH', dirname(__FILE__) . '/public_html/wordpress');

Debería ser:

define('ABSPATH', dirname(__FILE__) . '/public_html/');

Un define "ABSPATH" mal declarado provoca errores del tipo:

PHP Fatal error: require_once(): Failed opening required wordpress/wp-settings.php

Saludos

ResponderCitar
Respondido : 24/10/2014 1:01 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Xulián
 Xulián
Usuario eminente

Hola, muchas gracias por la respuesta.
Tengo un nivel poco más que básico en esto, ni siquiera sé que es un define.
Cuando los he borrado y modificado el ABSPATH que me indicabas, la propia web, que funcionaba bien, hasta que intentabas identificarte o registrarte, ha quedado mal. A cada página que pulso se dirige a esta direccion http://p.pw/404

Además, he comprobado que estos defines tiene una dirección temporal, no sé si es correcto:
//define('WP_HOME', 'http://xironet6-cp94.wordpresstemporal.com');
//define('WP_SITEURL','http://xironet6-cp94.wordpresstemporal.com');

Gracias otra vez de antemano

ResponderCitar
Respondido : 24/10/2014 12:00 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Haciendo pruebas en tu web veo que los enlaces cargan correctamente. Entiendo que ya has arreglado el problema.

ResponderCitar
Respondido : 24/10/2014 12:49 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Xulián
 Xulián
Usuario eminente

Hola, esque he dejado wp-config.php como estaba antes para que los usuarios puedan visitar la web por lo menos.
Prueba a registrarte, no deja. Y al indentificarte con un usuario válido va a página en blanco. Si es un usuario inválido funciona bien porque me aparece el mensaje de error por nombre de usuario inválido.

Gracias, un saludo

ResponderCitar
Respondido : 24/10/2014 1:04 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Da la sensación de que tienes algo mal en el archivo wp-config.php que tienes en la raíz de la web. Prueba a reemplazar ese archivo por el que te adjunto comprimido en un zip.

Antes tendrás que editar el archivo wp-config.php que yo te adjunto y poner los datos correctos en las siguientes líneas para el nombre de la base de datos, el usuario que accede a la base de datos y la contraseña):

/** El nombre de tu base de datos de WordPress */
define('DB_NAME', 'nombre base de datos');

/** Tu nombre de usuario de MySQL */
define('DB_USER', 'usuarios base de datos');

/** Tu contraseña de MySQL */
define('DB_PASSWORD', 'contraseña base de datos');

Los datos los puedes obtener de tu archivo wp-config.php. Una vez que tengas listo el archivo realiza una copia de seguridad del archivo wp-config.php que tienes actualmente y, una vez hecha, reemplaza el archivo por el que has preparado.

Comprueba si así se solucionan los problemas. De no ser así, deja de nuevo el archivo wp-config.php que tenías.

ResponderCitar
Respondido : 24/10/2014 1:25 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Xulián
 Xulián
Usuario eminente

Hola de nuevo, gracias por responder rápido.
He hecho simplemente esos cambios y en idioma cambiar es_ES por gl_ES que era el que tenía.
Ahora no se ve nada y aparece este mensaje:
Erro ao establecer unha conexión coa base de datos

ResponderCitar
Respondido : 24/10/2014 1:39 pm
Lorena
 Lorena
Miembro Moderator

Hola,

Revisa los datos que estás poniendo en nombre de base de datos, usuario de la base de datos y la contraseña en el fichero.

En principio son los mismos que en el wp-config.php original. Probablemente el error esté en la contraseña, comprueba que estás poniendo la misma que en el wp-config.php original.

Si no la recuerdas la puedes cambiar por la que quieras desde tu cPanel -> Bases de Datos -> MySQL Bases de Datos

Un saludo.

ResponderCitar
Respondido : 24/10/2014 2:23 pm

Cursos Gratuitos WordPress

Xulián
 Xulián
Usuario eminente

Si...una tontería por mi parte, la habia puesto mal.
De todas formas ahora solo entra en la pagina de inicio. El resto nada, iconos que aparecen por ahi, fuentes de letras cambiados, un cristo vamos...
Qué puedo hacer? subir un backup anterior?
Tengo bastante información actualizada desde mi ultima backup por eso preferiría arreglarlo de otra forma

Mil gracias

ResponderCitar
Respondido : 24/10/2014 2:36 pm
Xulián
 Xulián
Usuario eminente

He puesto el wp-config de esa última backup y parece que todo ha vuelto a la normalidad.
Podría pasaroslo por privado para ver qué puede estar mal?
No he modificado nada en el, podría ser por instalación de plugins

ResponderCitar
Respondido : 24/10/2014 2:40 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Tendrías que enviar el archivo mediante un ticket, nunca por foro, ya que contiene datos de acceso a la base de datos. En el ticket que envíes pon un enlace a este post del foro.

ResponderCitar
Respondido : 24/10/2014 4:00 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Nos han pasado el archivo y vemos sólo el tema del ABSPATH

Asegurate de tener correctamente las variables de la ruta absoluta, debería ser algo como, tal como te paso el archivo de Pablo :

if ( !defined('ABSPATH') )
define('ABSPATH', dirname(__FILE__) . '/');

Luego las líneas de WP_HOME , WP_SITEURL y RELOCATE no serían necesarias pero tampoco causan ningún efecto el tenerlas

Saludos.

ResponderCitar
Respondido : 24/10/2014 7:26 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Xulián
 Xulián
Usuario eminente

Lo tendré en cuenta,
muchas gracias por toda la ayuda.

Un saludo

ResponderCitar
Respondido : 27/10/2014 4:13 pm