Avisos
Vaciar todo

[Resuelto] Cabecera X-XSS-Protection desaparece  

 
Alberto
 Alberto
Usuario experto

Hola,

después de seguir todas vuestras indicaciones, añadiendo el código a las cabeceras, resulta que al rato se reescribe el archivo .htaccess y me borra todo lo que añado, y no se porque puede ser, ¿alguna idea?

Gracias!

Contenido solo visible a usuarios registrados

Respondido : 16/04/2021 9:44 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Alberto.

Le pedí a un compañero de hosting que añadiera las cabeceras en el archivo htaccess de tu instalación.

Revisa que todo este bien.

En principio no tiene por que sobre escribirse, sí se sobre escribe puede ser por algún plugin de cache, si ves que vuelve a pasar desactiva el plugin W3 total cache.

 

Un saludo

 

Respondido : 16/04/2021 10:06 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alberto
 Alberto
Usuario experto

@pepesoler

Bien, parece ser que el plugin w3 lo reescribe y lo borra, aun así el Cabecera Content-Security-Policy sigue sin aparecer, a pesar de estar añadido, y claro, tambien ala citar el plugin de cache mi web ahora es mas lenta, ¿que puedo hacer para resolverlo?

 

gracias.

Respondido : 16/04/2021 10:55 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Alberto,

En este caso envíanos los códigos que tienes añadidos para la cabecera que mencionas, de esta forma podemos verificar con mayor detalle. Sobre el plugin de cache si este te genera problemas puedes probar con otro por ejemplo WP Super Cache

Un Saludo

 

Respondido : 16/04/2021 12:36 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alberto
 Alberto
Usuario experto

@karen

Hola Karen,

tengo puesto esto:

## Cabecera X-Frame-Options para mejorar la seguridad
Header always append X-Frame-Options SAMEORIGIN

# Tell the browser to attempt the HTTPS version first
Header add Strict-Transport-Security "max-age=157680000"

## Cabecera X-XSS-Protection para evitar ataques XSS en IE y Chrome
Header set X-XSS-Protection "1; mode=block"

## Cabecera X-Content-Type-Options para evitar que se carguen hojas de estilo o scripts maliciosos
Header set X-Content-Type-Options "nosniff"

# Disable server signature
Header set ServerSignature "Off"
Header set ServerTokens "Prod"

# Control Cross-Domain Policies
Header set X-Permitted-Cross-Domain-Policies "master-only"

## Charset UTF-8

Header set Content-Type "text/html; charset=UTF-8"
# BEGIN WordPress

pero WP doctor me dice:
No tiene Cabeceras Content-Security-Policy (Implementar estas cabeceras puede dañar tu web si no se hace correctamente, si tienes dudas consulta con un experto)
Respondido : 16/04/2021 12:41 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Alberto,

Veo que WP Doctor si muestra que tienes activas las cabeceras en tu sitio web

Screenshot

Sin embargo para solucionar el aviso de Cabecera Content-Security-Policy prueba añadir el siguiente código en tu htaccess, ten en cuenta que este código suele ocasionar errores por lo que antes de añadirlo realiza una copia de seguridad del sitio web y tu archivo de esta forma si se genera algún error puedes restaurarla

# Cabecera Content-Security-Policy
Header set X-Content-Security-Policy "allow 'self';"

 

Comprueba esto y nos comentas

Un Saludo

 

Respondido : 16/04/2021 1:21 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alberto
 Alberto
Usuario experto

ok,  funciona, gracias!!

Respondido : 14/10/2021 6:23 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Alberto, 

Enhorabuena ha funcionado, siempre encantados en poder ayudarte

Con esto podemos dar el tema como solucionado

Escríbenos si tienes cualquier otra consulta

Un Saludo 😊 

Respondido : 14/10/2021 6:32 pm

Cursos Gratuitos WordPress