Avisos
Vaciar todo

Editor clásico de wordpress  

 
IDAYRA
 IDAYRA
Nuevo usuario

Hola, tengo un problema en mi wordpress y que no consigo resolver. La interfaz del editor de entradas por bloques ha pasado a ser un editor clásico de wordpress (en todas las entrdaas, publicadas, borradores, nuevas,...). No se ha realizado cambios para que esto ocurra, al menos de forma intencionada. La cuestión es que por algún motivo que aún desconozco el editor de entradas ha cambiado. He probado restaurando a una copia anterior de superbackup, reinstalar wordpress, desactivar uno a uno todos los plugins y no funciona. Una vez hecho todo esto para resolver el problema, para comprobar si podía optar a tener los dos editores, el clásico y el editor por bloques, he probado a intalar y configurar el plugin Editor clásico y sigue sin funcionar el editor por bloques ¿A qué se puede deber esto y cómo lo podría solucionar? Gracias por adelantado.

 

Mi web lleva el tema Divi.

Contenido solo visible a usuarios registrados

Citar
Respondido : 07/12/2020 2:44 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Idayra,

Disculpa si no logro comprender bien la consulta, cuando te refieres editor de bloques quieres decir gutenberg o el constructor de Divi? si es posible envíanos una captura de como ves tu editor ahora y que es lo que necesitas activar

Un Saludo

ResponderCitar
Respondido : 07/12/2020 2:49 pm

Cursos Gratuitos WordPress

IDAYRA
 IDAYRA
Nuevo usuario

Hola @karen

En primer lugar, gracias por tu respuesta. Es un poco lioso, discúlpame tú a mí si no logro explicarme bien. He conseguido revolver la vista del editor (por error en algún momento activamos: Opciones del tema Divi > Constructor > Avanzado > Habilitar editor clásico). Ahora, con esta opción desabilitada, ya tengo la interfaz de gutenberg pero el problema continua porque tengo fallos en mis entradas (en las antinuas creadas o modificadas con el editor clásico y en las nuevas que creo ahora ya con la opción de Divi desabilitada). Te explico con detalle los fallos que he detectado:

1) Las imágenes aparecen con borde al escribir una leyenda. Para eliminar este borde ha añadido este código y se ha solucionado:

.single-post .wp-caption {
border: unset !important;
background-color: unset !important;
}

 

2) Las imágenes de mis entradas aparecen con baja calidad (menos la imagen destacada). Se ve que elige por defecto las miniaturas porque las imágenes las que estoy subiendo están en buena resolusión.

unnamed

Contenido solo visible a usuarios registrados

 

3) Han aparecido bloques de contenido desconocido en gutenberg

Sin título

 

 

ResponderCitar
Respondido : 21/12/2020 11:09 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@petfriendlyclubespanagmail-com

Hola,

Prueba modificando la configuración del tamaño de tus imagenes que te dan este problema, accede al post o pagina donde las tengas publicadas, da doble click sobre la imagen y verás algo así como en la captura:

Captura de Pantalla 2020 12 21 a la(s) 18.39.06

 Quizás estás eligiendo el tamaño miniatura de la imagen y a partir de allí has estado modificando su tamaño, prueba eligiendo el tamaño de la imagen mediana o grande y ajústala a partir de estos tamaños.

El problema que nos describes respecto al mensaje de Gutenberg es, casi estoy seguro, a que has modificado de alguna manera el código generado por el editor, prueba restaurando a una versión anterior la entrada que te muestre ese problema desde las revisiones de la entrada, observa la siguiente captura.

Captura de Pantalla 2020 12 21 a la(s) 18.45.51

Saludos

ResponderCitar
Respondido : 22/12/2020 12:47 am

wpdoctor-revisa-la-salud-de-tu-wordpress