Avisos
Vaciar todo

Error editor clásico  

 
Alberto
 Alberto
Usuario activo

hola buenos días, no me funciona el editor clásico ya que no puedo en las páginas y en las entradas meter elementos, textos... etc... solo me sale en html.

 

mi wordpress me arroja este error:

¡Hola!

 

Desde WordPress 5.2 hay una característica incorporada que detecta cuándo un plugin o un tema causa un error fatal en tu sitio y te avisa mediante este correo electrónico automático.

 

En este caso, WordPress ha detectado un error con tu tema, Enfold.

 

Primero, visita tu web ( https://cedersomontano.com/ ) y comprueba si hay algún problema visible. A continuación, visita la página donde ha sido detectado el error ( https://cedersomontano.com/wp-admin/post.php?post=5633&action=edit&classic-editor ) y comprueba si hay algún problema visible.

 

Por favor, ponte en contacto con tu alojamiento para que te ayude a investigar más a fondo este problema.

 

Si tu sitio parece roto y no puedes acceder a tu escritorio con normalidad, ahora WordPress tiene un «modo de recuperación» especial. Este te permite acceder de forma segura a tu escritorio e investigar más a fondo.

 

https://cedersomontano.com/wp-login.php?action=enter_recovery_mode&rm_token=T9ttmE48IVptTnZ74YeClt&rm_key=McgQ7p7iuJNVvm0tYClBSX

 

Para mantener tu sitio seguro, este enlace caducará en 1 día. Sin embargo, no te preocupes por esto: recibirás por correo electrónico un nuevo enlace si el error ocurre de nuevo después de que caduque.

 

Cuando busques ayuda para este problema, es posible que se te pida la siguiente información:

WordPress versión 5.7.3

Tema actual: Enfold Child (versión 1.0)

Plugin actual:  (versión )

PHP versión 7.4.23

 

 

 

Detalles del error

==================

Se ha producido un error del tipo E_ERROR en la línea 489 del archivo /home2/cedersom/public_html/cedersomontano.org/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/shortcode-template.class.php. Mensaje de error: Uncaught Error: Cannot use string offset as an array in /home2/cedersom/public_html/cedersomontano.org/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/shortcode-template.class.php:489

Stack trace:

#0 /home2/cedersom/public_html/cedersomontano.org/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/shortcode-template.class.php(443): aviaShortcodeTemplate->create_sortable_editor_element(Array)

#1 /home2/cedersom/public_html/cedersomontano.org/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/template-builder.class.php(397): aviaShortcodeTemplate->prepare_editor_element()

#2 /home2/cedersom/public_html/cedersomontano.org/wp-includes/class-wp-hook.php(292): AviaBuilder->js_template_editor_elements('')

#3 /home2/cedersom/public_html/cedersomontano.org/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters('', Array)

#4 /home2/cedersom/public_html/cedersomontano.org/wp-includes/plugin.php(484): WP_Hook->do_action(Array)

#5 /home2/cedersom/p

Contenido solo visible a usuarios registrados

Citar
Respondido : 01/10/2021 8:33 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Alberto.

Por lo que veo en el aviso el problema viene de tu plantilla 

Contenido solo visible a usuarios registrados

 

Lo primero actualiza WordPress a la ultima version que es la 5.8.1

Comprueba si tienes actualizaciones de la plantilla pendiente.

Si tienes plugin pendientes de actualizar los actualizas.

 

Una vez lo tengas todo actualizado accede ajustes -> Enlaces permanentes y sin realizar ninguna modificación pulsa en el boton de Guardar.

 

En esta entrada del soporte de plantilla veo que tratan el tema:

-> https://kriesi.at/support/topic/404-page-not-found-and-uncaught-error-cannot-use-string-offset-as-an-array-in/

 

Comprueba lo que te comento y vamos descartando cosas.

 

Un saludo

ResponderCitar
Respondido : 01/10/2021 9:38 am

Cursos Gratuitos WordPress

Alberto
 Alberto
Usuario activo

@pepesoler

hola todo hecho, he actualizado todos los plugins, el wp a la última versión y el tema me dice que ya tiene la última versión, sigue sin funcionar.

 

Esta publicación ha sido modificada el hace 3 semanas por Pepe
ResponderCitar
Respondido : 01/10/2021 11:41 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Alberto.

Ok el problema lo tienes en tu Plantilla.

Para comprobarlo activa una de las plantillas que trae por defecto WordPress y revisa si después de activar esa plantilla el editor funciona bien.

Si no quieres realizarlo en la web que tienes en producción puedes clonar la web y realizar las pruebas en ese clon:

-> https://guias.webempresa.com/preguntas-frecuentes/wpcenter/#clonar

 

Por lo que veo en las consultas del desarrollador hay una opciones de la plantilla para activar el editor clásico:

 

screenshot themeforest.net 2021.10.01 13 44 32

  

Si ves que no se soluciona después de cambiar de plantilla tendras que consultar con el soporte de la plantilla ya que es de pago y no podemos descargarla para revisarlo.

-> https://themeforest.net/item/enfold-responsive-multipurpose-theme/4519990/comments?utf8=%E2%9C%93&term=classic+editor&from_buyers_and_authors_only=0

 

Un saludo

 

ResponderCitar
Respondido : 01/10/2021 12:46 pm

wpdoctor-revisa-la-salud-de-tu-wordpress