Error en Enlace Permanente  

Página 1 / 2
 
Raul Domingo
 Raul Domingo
Usuario activo

Al transferir mi blog de wordpress a webempresa mis enlaces anteriores dan error, por ejemplo:

http://fisiostar.com/fisioterapia-tratamientos/fisioterapia-deportiva/la-fisioterapia-y-el-deporte/.html

Sé que termina con el slash antes de .html que es algo raro, pero debe de seguir funcionando así, y a pesar que en "enlaces permanentes" de wp-admin lo tengo bien configurado, no funcionan.

¿Cómo podría solucionarlo?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/03/2014 2:25 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a ir en la administración de WordPress a Ajustes->Enlaces permanentes y en este pantalla pulsa el botón Guarda cambios (no hace falta que cambies nada). Esto generará un nuevo archivo .htaccess que debería ser compatible con la web, ya que el que tienes actualmente puede estar mal.

Comprueba si tras este cambio te funcionan correctamente los enlaces.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/03/2014 3:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Raul Domingo
 Raul Domingo
Usuario activo

Lo hice. Pero nada. Sigue el error

ResponderCitar
Respondido : 19/03/2014 3:29 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Realizando pruebas en tu web no veo cómo llegas a los enlaces que comentas. Si entro en el elemento de menú "Fisioterapia" y pulso en el primer artículo la url que me abre es la siguiente:

Contenido solo visible a usuarios registrados

Por supuesto, la página se abre correctamente. Tendrías que indicarnos desde qué página te muestra el enlace que nos has indicado.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/03/2014 5:01 pm

Cursos Gratuitos WordPress

Raul Domingo
 Raul Domingo
Usuario activo

Hola Pablo y gracias por tu tiempo.

Cambié el enlace permanente hasta encontrar la solución. He puesto de nuevo los enlaces permanentes que tenían antes de trasladarlo a webempresa:
http://fisiostar.com/fisioterapia-tratamientos/fisioterapia-deportiva/la-fisioterapia-y-el-deporte/.html

Sé que es raro lo del slash ahí, pero así funcionaba antes y es como están los enlaces interneos, enalces en otros blogs, etc...

Necesitaría que funcionase en ese formato, pero me da error. Ahora podrás verlo.

ResponderCitar
Respondido : 19/03/2014 7:24 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Raúl,

De la url lo único extraño es el slat final antes del punto.

Sé que termina con el slash antes de .html que es algo raro, pero debe de seguir funcionando así, y a pesar que en "enlaces permanentes" de wp-admin lo tengo bien configurado, no funcionan.

¿Puedes mostrarnos en una captura como los tienes configurados los enlaces permanentes?

- Los formatos de capturas admitidos son .jpg y .png
- No las incrustes en archivos .doc de Word o similares, ni en PDFs.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/03/2014 9:37 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Raul Domingo
 Raul Domingo
Usuario activo

Adjunto imagen de como está.

Tiene esto:
/%category%/%postname%/.html

Aquí un ejemplo de una web donde sí funciona que aún no he trasladado a webempresa:
http://recetasreceta.com/recetas-de-cocina/recetas-de-postres/mermelada-de-pina/.html

ResponderCitar
Respondido : 19/03/2014 10:19 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Raúl,

Lo normal es que esté en "Nombre de entrada" ¿lo has probado?.

El problema será como tengas indexados los permalinks.

Adicionalmente ¿tienes configuraciones en el plugin All in One SEO Pack que afecten a enlaces permanentes?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/03/2014 10:34 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Raul Domingo
 Raul Domingo
Usuario activo

All in seo está igual que el de recetas que sí funciona.

Las entradas están igual tb.

te mando imagen

ResponderCitar
Respondido : 19/03/2014 10:41 pm
Raul Domingo
 Raul Domingo
Usuario activo

Diferencias que he visto entre fisiostar y recetas, no sé si puede ser algo de eso

ResponderCitar
Respondido : 19/03/2014 10:45 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Raúl,

La versión de PHP no tiene porque afectarte, pero siempre puedes pasar esa cuenta a PHP 5.3 si no usas en esa misma cuenta instalaciones de Joomla que requieran PHP 5.2.

A fin de cuentas WordPress trabaja bien en PHP 5.2 y 5.3.

¿Has probado a editar en la entrada el enlace permanente y eliminar el slat a ver si no devuelbe un 403?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/03/2014 11:45 pm
Raul Domingo
 Raul Domingo
Usuario activo

Si elimino ese slash en enlaces permanentes funciona bien el enlace, pero no funcionarían todos los enlaces internos que ya están, los que me hayan enlazados de otros blogs, etc... (es decir, la fuerza de los artículos desaparecería)

Por eso lo que quiero es que funcionen tal y como estaban antes de migrar el blog a webempresa, con el slash y .html (/.html)

ResponderCitar
Respondido : 19/03/2014 11:51 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hol Raúl,

Si sin slat te funciona pero no quieres perder los enlaces externos que otros usuarios han realizado a tus contenidos y que Google tampoco te penalice, tendrías que plantearte realizar redirecciones para no perder esos enlaces, o bien desde tu .htaccess manualmente, enlace por enlace o usando algún plugin como Redirection.

- http://wordpress.org/plugins/redirection/

He pasado por eso cuando he cambiado la web de Joomla a WordPress y créeme, el posicionamiento se vino abajo y de repente tenía más de 600 enlaces con errores 404 y Google en las Herramientas para Webemaster me mostraba una gráfica cada día recordándome el problema de los enlaces perdidos de terceros, de urls mías indexadas, etc., hasta que opte por redireccionar para no perder esas visitas y no convertirlas en 404.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/03/2014 12:02 am
Raul Domingo
 Raul Domingo
Usuario activo

El problema es que además quiero que el enlace que se vea correctamente sea el terminado en /.html

Es decir, que ese sea el que se refleje en el navegador, etc... porque hay artículo patrocinados donde el cliente quiere ese enlace final que es el que contrato (basicamente, teliad)

ResponderCitar
Respondido : 20/03/2014 12:09 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

He revisado el problema, parece que es a nivel de servidor. Tienes que enviar un ticket a soporte a través de tu área de clientes haciendo referencia a este hilo de foro.

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/03/2014 3:37 am
Página 1 / 2

Por favor Iniciar Sesión o Registro