Avisos
Vaciar todo

Google Analytics ha dejado de funcionar  

 
Francis
 Francis
Usuario experto

Hola.

 

Hace unos días dejó de funcionarme Google Analytics, si compruebo desde Google Tag Assistant Legacy me sale estos fallos:

 

Captura de pantalla 2021 04 03 a las 14.37.57

 

Estoy haciendo pruebas pero no consigo solucionarlo, ¿Que puede ocurrir?

 

Saludos.

Contenido solo visible a usuarios registrados

Citar
Respondido : 03/04/2021 1:45 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Efectivamente, no detecto el código de Google Analtyics en tu sitio.

Cómo has agregado el código?, envíanos una captura de pantalla.

Si no agregaste el código aún puedes evaluar hacerlo con un plugin, por ejemplo:

https://pe.wordpress.org/plugins/goolytics-simple-google-analytics/
https://es.wordpress.org/plugins/simple-universal-google-analytics/

Saludos.

ResponderCitar
Respondido : 03/04/2021 2:05 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Francis
 Francis
Usuario experto

He probado los 2 plugins que me indicas pero no me funcionan.

El que yo utilizo es GA Google Analytics

Captura de pantalla 2021 04 03 a las 15.37.01

 

Pero si pongo solo el numero de seguimiento GA no me funciona, (ni ahora ni antes) quizás por eso no me funcionan los plugins que me indicas.

Para que funcionase tenia que poner el siguiente código:

 

<!-- Google Analytics -->
<script>
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
ga('create', 'UA-189xxxx1-1', 'auto');
ga('send', 'pageview');
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<!-- End Google Analytics -->

 

A si a estado funcionando unos meses, pero ahora a dejado de funcionar y en el Tag Assistant Legacy me indica el fallo que te mostré antes

 

ResponderCitar
Respondido : 03/04/2021 2:40 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es muy raro que no funcione, prueba desactivando todos los plugins relacionados con Analtyics, luego prueba alguno de los que te envié, es decir no uses varios a la ves, sólo quédate con uno, los que te envié son los más simples como para inserte código de Analytics y si que debería funcionar.

Lo otro es que tengas como parte de tu theme alguna configuración para analytics, revisa si tienes esa opción, ya que en ese caso no sería necesario un plugin adicional y más bien podría causar conflicto.

Como opción final sería agregar el código de Analytics a través de código en el archivo functions.php de tu theme, por ejemplo como se comenta en:
Contenido solo visible a usuarios registrados

Saludos.

ResponderCitar
Respondido : 03/04/2021 3:35 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Francis
 Francis
Usuario experto

He probado pero nada, sigue sin funcionar

 

Lo que si e visto, que aunque yo coloque el código en Head(A través de plugins, a mano... da igual), cuando le doy a inspeccionar código y busco la etiqueta de Analytics esta siempre sale fuera del Head

¿Porque puede ser?

ResponderCitar
Respondido : 03/04/2021 5:01 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Depende como insertes el código, si te sale fuera asumo que lo estas insertando mal.

La manera más segura de insertarlo por código es a través de Hooks, tal como se realiza en el artículo que te envié, prueba hacerlo de esa forma y verifica.

Saludos.

ResponderCitar
Respondido : 03/04/2021 6:03 pm

Cursos Gratuitos WordPress

Francis
 Francis
Usuario experto

Ya he conseguido que el código aparezca en el head, ya no me sale el aviso de que esta fuera de la cabecera, pero no funciona.

Investigando en el código fuente me he dado cuenta de una cosa:

Captura de pantalla 2021 04 04 a las 11.07.43

Da igual que ponga yo el código a mano en el head, que lo ponga a través de algún plugins... me borra el código del script, debería de aparecer:

 <script async src='https://www.google-analytics.com/analytics.js'></script>

en la linea blanca que marco en la imagen, pero no se porque, me borra esa linea de texto siempre

 

ResponderCitar
Respondido : 04/04/2021 10:14 am
Francis
 Francis
Usuario experto

Vale, ya he conseguido hacer que funcione, lo pongo por si le puede servir de ayuda a alguien.

El problema venia por el plugins de los textos legales, tras una actualización del plugin, me activa por defecto una casilla que dice bloquear script conocidos.

 

 

ResponderCitar
Respondido : 04/04/2021 11:45 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Ok, que bueno que encontraste el plugin que te estaba bloqueando el código.

Aunque entiendo que esa es justo la funcionalidad del plugin de textos legales, si acepta las condiciones (algún botón que tiene el plugin), asumo que debería volver a cargar el script.

Saludos.

ResponderCitar
Respondido : 04/04/2021 1:51 pm