Problema en Home WordPress  

 
Gonzalo A.
 Gonzalo A.
Usuario activo

El problema se ha detectado tras llegarme una alerta que tengo configurada en Pingdom para detectar caídas del servidor y nuestra web no estaba funcionando (error 500 http). Me he percatado de que era solamente la portada ya que podía entrar al panel de control de WordPress o directamente a cualquier post, pero no a la portada. Probé a despublicar las últimas noticias y no se ha resuelto. He preguntado a las personas que se encargan de los contenidos y aparentemente no han realizado cambio alguno en plugins ni nada de configuración del WordPress, solamente han escrito algunos Posts. He activado define ('WP_DEBUG', true); y me salen una serie de errores por pantalla:

Notice: wp_register_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home2/aurareec/public_html/wp-includes/functions.php on line 3547

Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method SAR_Generator::query_manipulation() should not be called statically in /home2/aurareec/public_html/wp-includes/plugin.php on line 269

Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method SAR_Generator::query_manipulation() should not be called statically in /home2/aurareec/public_html/wp-includes/plugin.php on line 269

Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method SAR_Generator::query_manipulation() should not be called statically in /home2/aurareec/public_html/wp-includes/plugin.php on line 269

A ver si me podéis dar alguna pista de por donde empezar a mirar ya que es mi primera experiencia con WordPress

Muchas gracias y un saludo

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 07/05/2015 12:19 am
Gonzalo A.
 Gonzalo A.
Usuario activo

Olvidé comentar que el Wordpress es esta versión:

WordPress 4.1.4 running wpherald theme.

¿Debería actualizar a 4.2.1 como sugiere al inicio? ¿Tiene esa actualización algo que ver?

ResponderCitar
Respondido : 07/05/2015 12:27 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rafael
 Rafael
Miembro Moderator

¡Hola Juan Manuel!

¿Has probado a revisar el archivo .htaccess de tu instalación Wordpress?

1º Acceda a tu cpanel (midominio.com/cpanel) > Bloque Archivos > Administrador de archivos

2º Ve al directorio public_html y en el encontrarás un archivo llamado .htaccess > botón derecho y "code edit".
3º Elimina la siguiente línea de código: DirectoryIndex index.php
4º Guardas los cambios y revisa si con ello se soluciona el problema.

Adicionalmente, revisa:
https://www.webempresa.com/blog/administrador-de-archivos-de-cpanel.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/05/2015 12:28 am
Gonzalo A.
 Gonzalo A.
Usuario activo

Acabo de probar a quitar la citada línea, guardar y el problema sigue igual. ¿Alguna otra idea?

ResponderCitar
Respondido : 07/05/2015 12:37 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Rafael
 Rafael
Miembro Moderator

¡Hola Juan Manuel!

Actualmente veo que tu página web ya carga correctamente como puedes ver en la siguiente captura:

Contenido solo visible a usuarios registrados

¿Has probado a limpiar la caché del navegador? ¿has usado otro dispositivo?

En relación a la actualización, sería conveniente que siempre lo tuvieras al día (si el tema lo permite) por motivos de perfomance y seguridad del sitio.

Pero siempre antes de hacer un cambio tan importante en la web, haz copias de seguridad por lo que pudiera pasar. Para ello:

https://www.webempresa.com/blog/copias-de-seguridad-desde-el-panel-de-hosting-cpanel.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/05/2015 12:42 am
Gonzalo A.
 Gonzalo A.
Usuario activo

Hola, muchas gracias, pero como puedes ver en la captura que mandas, la portada se corta y carga solamente la cabecera. Si entras en cualquier otra página que no sea la portada, entonces se ve completa, por ejemplo http://www.auraree.com/aura-research/

Parece que algo deja de funcionar a continuación de la cabecera. Quizás es algún plugin que esté solamente en la portada?

ResponderCitar
Respondido : 07/05/2015 1:14 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Para comprobar si se trata de algún plugin puedes revisar el siguiente articulo de blog: https://www.webempresa.com/blog/item/1662-desactivar-todos-los-plugins-de-wordpress-sin-tocar-la-base-de-datos.html

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/05/2015 1:20 am
Gonzalo A.
 Gonzalo A.
Usuario activo

Pues resulta que sí es un plugin, concretamente el plugin Slideshow, pero no parece que se haya hecho ninguna modificación en el mismo ni publicado ninguna slide nueva...

ResponderCitar
Respondido : 07/05/2015 1:33 am

Cursos Gratuitos WordPress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Al detectar ya el problema te recomendaría, revisar el plugin ya que puede ser un tema de configuración. Como ultima opción quizás tengas que cambiarlo en el caso de que la plantilla lo permita.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/05/2015 1:40 am

Por favor Iniciar Sesión o Registro