Avisos
Vaciar todo

[Resuelto] Plugin todo pago en wordpress  

 
Sergio
 Sergio
Nuevo usuario

Hola qué tal?, instalé el plugin de todo pago en mi wordpress y no logro que funcione. Las especificaciones del plugin indican lo siguiente:

Descomentar: extension=php_soap.dll del php.ini, ya que para la conexión al gateway se utiliza la clase SoapClient del API de PHP. Descomentar: extension=php_openssl.dll del php.ini
En caso de tener conflictos con Jquery por los diferentes temas, descomentar la siguiente linea que se encuentra al final del index.php
// add_action('init', 'my_init');

----------------------

COMPORTAMIENTO ACTUAL:

Cuando ingreso al checkout, elijo el método de pago (TODO PAGO) y hago click en “REALIZAR PEDIDO” aparece el mensaje:
Warning: Invalid argument supplied for foreach() in /home/customer/www/leket.com.ar/public_html/wp-content/plugins/woocommerce-plugin/Core/Transaction/TransactionModel.php on line 135
Error en: Autorización.

Alguna recomendación?
Web: www.leket.com.ar

Contenido solo visible a usuarios registrados

Respondido : 21/02/2021 5:38 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Sergio,

El error que me aparece al intentar hacer una compra con Todo Pago es el siguiente:

Error en: Autorización

Lo que me hace pensar que tienes mal configurado el plugin, revisa la documentación del mismo y la configuración que has aplicado en tus credenciales de Todo Pago, revisa si el problema se presenta tambien si configuras y defines el comportamiento de la pasarela de pago en modo de desarrollo o en modo pruebas. 

He consulta con el equipo de administradores de sistemas de Webempresa y me confirman que la extensión de SOAP está activada en tu cuenta de hsoting, pero observando la documentación del plugin notamos que solamente se hace referencia a extensiones PHP con terminación .dll, ¿Qué signfica esto? Las extensiones .dll son propias de sistemas operativos Windows, nuestros servidores son Linux, por lo que te sugiero que contactes con los desarrolladores para que te aclaren si el plugin funciona únicamente en servidores Windows o si tambien es compatible con servidores Linu, en caso de que solo funcione con Windows no podrás utilizarlo en tu Wordpress, tendrás que buscar otra pasarela de pagos.

Puedes escribir a los desarrolladores del plugin exponiéndoles tu problema, esto puedes hacerlo en el siguiente enlace -> Contenido solo visible a usuarios registrados

Saludos 🙂

Esta publicación ha sido modificada el hace 9 meses por Bulmaro
Respondido : 21/02/2021 6:23 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Sergio
 Sergio
Nuevo usuario

@bulmaro-webempresa Gracias Bulmaro, solucionado!

Respondido : 21/02/2021 7:55 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@bfapyagmail-com

Hola Sergio, 

Excelente, me alegra que pudieras corregirlo y ahora tengas funcionando la pasarela de tu elección. 

Muchas gracias a ti por consultarnos en el foro de soporte en CMS de Webempresa. 

Saludos 🙂

Respondido : 21/02/2021 8:57 pm

Cursos Gratuitos WordPress