Avisos
Vaciar todo

actualización 1.7.3 a 1.7.5  

Página 2 / 3
 
Josep
 Josep
Usuario experto

He hecho un clon de mi prestashop para hacer pruebas y la primera es pasar de 1.7.3 a 1.7.5.1 con el modulo 1-Click Upgrade, empieza todo correcto y no me da ningun error pero se para y no sigue.
He borrado la cache he arreglado todos los permisos con estephan lo he intentado muchas veces y simepre se para y no sigue y no siempre en el mismo sitio.
Estephan me dice que tengo instalado un prestashop 1.6 pero no es correcto tengo el 1.7.3 no se si sera que la base de datos no ha cambiado pero tengo el prestashop funcionando desde hace un año con el 1.7.3
Os adjunto pantallazo de donde se queda parada la actualización
Ya no se que hacer mas
Podeis ayudarme
gracias
la url que os pongo es la de la tienda en funcionamiento el clon es exactamente igula y funciona
Manel

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 20/03/2019 7:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Has pasado revisión con la herramienta Stephan?
https://guias.webempresa.com/preguntas-frecuentes/revision-automatica-asistente-virtual-stephan/

Si sigues con problemas podrías evaluar recuperar una copia antes de la actualización y realizar el proceso nuevamente, sin embargo antes de hacerlo crea igual otro administrador de tu sitio y probar con el administrador alterno en caso no funcione.

Saludos.

ResponderCitar
Respondido : 22/03/2019 5:22 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Josep
 Josep
Usuario experto

Hola, buenos dias,
He pasado Stephan, he restaurado la web y he creado un administrador nuevo, despues he actualizado de nuevo a 1.7.5.1 se ha actualizado todo correcto en verde pero me sigue diciendo acceso denegado con el administrador nuevo y si quiero acceder a cualquier sitio me da error 500
os adjunto imagen de los errores
Ya me diréis que puedo hacer mas para poder actualizar
Gracias
manel

ResponderCitar
Respondido : 25/03/2019 10:47 am
Josep
 Josep
Usuario experto

Hola,
Os copio tambien el mensaje de error 500 que me dice stephan:
[25-Mar-2019 11:11:58 Europe/Madrid] PHP Fatal error: Uncaught TypeError: Argument 2 passed to PrestaShopPrestaShopCoreProductProductListingPresenter::present() must be of the type array, boolean given, called in /home2/audenisc/public_html/instrument.audenis.com/classes/controller/ProductListingFrontController.php on line 67 and defined in /home2/audenisc/public_html/instrument.audenis.com/src/Core/Product/ProductListingPresenter.php:30
[25-Mar-2019 11:14:01 Europe/Madrid] PHP Fatal error: Uncaught Error: Undefined class constant 'HEADER_X_FORWARDED_ALL' in /home2/audenisc/public_html/clon/admAude28/index.php:84

ResponderCitar
Respondido : 25/03/2019 11:38 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Josep.

[25-Mar-2019 11:14:01 Europe/Madrid] PHP Fatal error: Uncaught Error: Undefined class constant 'HEADER_X_FORWARDED_ALL' in /home2/audenisc/public_html/clon/admAude28/index.php:84

Es por problema de una clase que no está definida.

Disculpa tantas consultas, ¿ La instalación que tenías antes de actualizar a 1,7,3 la hiciste desde 1.6 a 1.7 o siempre tuviste prestashop 1.7 ?

lo comento por que ese error puede venir del archivo bootstrap.cache.php y no me cuadra en prestashp 1.7

Un saludo

ResponderCitar
Respondido : 25/03/2019 1:55 pm
Josep
 Josep
Usuario experto

Hola,
hace un año mas o menos pasamos de 1.6 a 1.7.3
y ha funcionanado este tiempo bien, de hecho la web está en funcionamiento en estos momentos
Puedo hacer algo para arreglar este archivo?
Ya me dirás
Josep

ResponderCitar
Respondido : 25/03/2019 5:35 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Algunos de los errores son por archivos del framework Symfony que usa PrestaShop para algunas partes del backend, al parecer la actualización de PrestaShop actualiza también Symfony

Según veo tendría que eliminarse algunos archivos de cache
https://github.com/symfony/symfony/issues/23400

Verifica si tienes ese archivo y prueba eliminarlo, o busca si tienes una carpeta cache y elimina los archivos de cache.

Saludos.

ResponderCitar
Respondido : 25/03/2019 6:49 pm
Josep
 Josep
Usuario experto

Hola me sale este error también:
Que puedo hacer?
[26-Mar-2019 04:39:27 Europe/Madrid] PHP Fatal error: Uncaught TypeError: Argument 2 passed to PrestaShopPrestaShopCoreProductProductListingPresenter::present() must be of the type array, boolean given, called in /home2/audenisc/public_html/instrument.audenis.com/classes/controller/ProductListingFrontController.php on line 67 and defined in /home2/audenisc/public_html/instrument.audenis.com/src/Core/Product/ProductListingPresenter.php:30

ResponderCitar
Respondido : 26/03/2019 10:34 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Josep.

Tienes demasiados problemas con argumentos de variables " must be of the type array, boolean given " .
Todos estos problemas vienen por actualizar de 1.6 a 1.7, por eso lo pregunte antes.

En un principio es posible que no tuvieras problemas, pero prestashop a cambiado mucho desde las primeras versiones de 1,7 y las versiones 1.6 y 1.7 no son compatibles.

Por lo que veo la plantilla noes compatible con prestashop 1.7:
-> https://addons.prestashop.com/es/temas-hogar-jardin/25853-jms-4life.html

Tienes que consultarlo con el soporte de la plantilla ya que detrás de un error tendrás otro hasta que termina por caerse por completo la web.

Realiza la consulta con el desarrollador de la plantilla para ver si te pueden ofrecer una solución:
-> https://addons.prestashop.com/es/contacte-con-nosotros?id_product=25853

Un saludo

ResponderCitar
Respondido : 26/03/2019 11:06 am
Josep
 Josep
Usuario experto

Hola
La plantilla la compramos hace un año y es est: JMS 4Life 1.7 y está adaptada a prestashop 1.7 de hecho teniamos la misma pero en 1.6 y al actualizar a 1.7 tuvimos que comprar la plantilla de nuevo compatible con 1.7 desde entonces está funcionando correctamente, es ahora al actualitzar a 1.7.5 cuando esta creando todos estos errores.
no creo que sea por el tema mas bien creo que el problema ha de estar en el que la base de datos no se actualizo bien en su momento porque segun stephan sigue saliendo como 1.6
Dime si cres que puedo hacer algo para solucionarlo .
Voy ha hacer un restore con el tema de prestashop y volveré a actualizar par asegurarme
Ya me diras si se te ocurre algo
Gracias
Saludos
Josep

ResponderCitar
Respondido : 26/03/2019 11:28 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Josep.

Ok, veo que tienen otra version para 1.7:
-> https://addons.prestashop.com/es/temas-hogar-jardin/25995-jms-4life-17.html

Son problemas de compatibilidades con la plantilla.
Como te indique es una plantilla de pago y tienes que consultarlo con el soporte de la plantilla:
-> https://addons.prestashop.com/es/contacte-con-nosotros?id_product=25995

Si estás haciendo pruebas, en vez de actualizar de 1.6 a 1.7. instala una versión de prestashop 1.7 limpia e instalas la plantilla en esa version, revisa despues de eso si en esa instalación funciona todo bien.

Un saludo

ResponderCitar
Respondido : 26/03/2019 11:46 am
Josep
 Josep
Usuario experto

Hola,
He restaurado con el tema por defecto de prestashop y he actualizado de 1.7.3 a 1.7.5.1 y me sigue dando los mismos errores.
Ya no se que mas hacer
Ya me drás si teneis alguna solución
Saludos
Manel

ResponderCitar
Respondido : 26/03/2019 11:50 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Josep
 Josep
Usuario experto

ok probaré en una instalación limpia con 1.7 y la plantilla para ver como va
Gracias
manel

ResponderCitar
Respondido : 26/03/2019 11:55 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Josep.

No tienes que restaurar.
.- Instala una versión de prestashop 1.7 nueva desde aplicaciones webempresa -> Inicio -> Instalar prestashop

Revisa si esa instalación de prestashop se comporta bien.

.- Descarga la última versión de la plantilla y la instalas:
-> addons.prestashop.com/es/temas-hogar-jardin/25995-jms-4life-17.html

Si ves que con esa instalación todo funciona bien, tendrás que consultarlo con el desarrollador o realizar un traspaso de los productos.

por experiencia ya te digo que las actualizaciones de 1.6 a 1.7 no suelen terminar muy bien aunque la plantilla sea compatible.

Un saludo

ResponderCitar
Respondido : 26/03/2019 12:08 pm

Cursos Gratuitos WordPress

Josep
 Josep
Usuario experto

Hola,
He instalado un prestashop 1.7.5 nuevo y le he puesto el tema jms-4life-1.7 y funciona todo correcto, en el que tengo en funcionamiento tambien funciona correcto pero cuando trato de actualizar de 1.7.3 a 1.7.5 nos da todos los errores.
Os dejo las dos web que funcionan para que veais si se puede hacer algo
funcionando con 1.7.3 : Contenido solo visible a usuarios registrados
1.7.5 limpio con JMS-4live4 1.7: http://audenisc-cp167.webprestashop.com/pruebatienda
Espero tus noticias
Saludos
manel

ResponderCitar
Respondido : 26/03/2019 7:03 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Debe ser algún otro módulo el que te causa problemas o también puede ser que tengas algún problema a nivel de BD.

De manera general podrías probar tu instalación de PrestaShop que si te funciona conectada a la BD en donde tienes problemas y verificar si funciona, tendrías que cambiar los parámetros de BD.

Saludos.

ResponderCitar
Respondido : 26/03/2019 8:39 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Página 2 / 3