Avisos
Vaciar todo

Ayuda actualización de prestashop 1.5.6.2 a prestashop 1.6.7 (con plantilla de pago instalada)  

 
Fernando
 Fernando
Usuario eminente

Ayuda actualización de prestashop 1.5.6.2 a prestashop 1.6.7 (con plantilla de pago instalada)
Buenos días,
Necesito actualizar mi prestashop, ya que son muchos los errores que arrastra la web y pienso que con una actualización zanjaría todos los errores, pero tengo muchas dudas y miedos, ya que a fin de cuentas la página funciona.
Dejé de realizar las actualizaciones porque estas fueron el motivo que algunos módulos dejaran de funcionar y ahora me encuentro que la versión que tengo es muy antigua (1.5.6.2).
La web tiene instalada una plantilla comprada y no sé si al actualizar la versión esta plantilla me seguirá funcionando.
También he realizado muchos cambios en los módulos para ir ajustando la web a lo que necesitaba, cambios que no recuerdo ni la mitad.
Al investigar con la actualización 1 click, veo que por un lado me dice que "La última versión oficial del canal menor" sería 1.5.6.3, pero en La lista de comprobación pre-actualizacion indica que El módulo de actualización 1-click esta actualizado (la versión actual es v1.6.7).
Como recomendáis realizar una actualización? Manual o con el módulo 1 click?
Si realizo una actualización y lo que me encuentro es una catástrofe, puedo volver a lo que tenía? como? He buscado y en todos lados solo hablan que al actualizar es para renovar y que no se debería volver a versiones antiguas, pero no he encontrado nada al respecto de como restaurar la versión que al menos andaba.
No se que hacer, si pueden ayudarme,
Muchas gracias
Saludos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 04/02/2016 12:04 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Una actualización de PrestaShop 1.5 a 1.6 puede generar múltiples problemas si el tema (plantilla) que estás utilizando no es compatible con PrestaShop 1.6, o alguno de los módulos que estás usando tampoco.

A priori, las plantillas compatibles con PrestaShop 1.5 no son compatibles con PrestaShop 1.6, o suele ser necesaria una actualización de la misma. Lo mismo puede ocurrir con los módulos no nativos que hayas instalado.

Para el tema de la plantilla lo recomendable sería que contactaras con los desarrolladores para que te confirmen si la versión que tienes de la misma es compatible con PrestaShop 1.6. En caso contrario será necesario que cambies la plantilla.

Mi recomendación es que no realices esta actualización directamente sobre tu web de producción, ya que es bastante problema que surjan problemas. Lo mejor sería que hicieras un clon completo de tu web (archivos y base de datos) en otro directorio de tu cuenta de hosting o, si lo prefiereres y tienes un servidor web montado en tu equipo, en local. De esta forma podrás hacer las pruebas necesarias sin riesgo a dejar tu web fuera de línea.

A prior, con el 1 Click Upgrade deberías poder actualizar a PrestaShop 1.6.

ResponderCitar
Respondido : 04/02/2016 1:56 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación