Avisos
Vaciar todo

[Resuelto] Error 500 en Prestashop  

 
Manuel
 Manuel
Nuevo usuario

Buenas tardes, he solicitado traslado de un dominio y está en proceso. La web tiene un prestashop ver. 1.6.1, he realizado la copia de archivos y base de datos y estoy probando su funcionamiento en mi dominio/tienda, pero me da error 500 y no carga. He realizado todos los pasos y no veo donde está el problema. Me lo podían revisar. Gracias

Contenido solo visible a usuarios registrados

Respondido : 02/10/2021 7:37 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Manuel,

En el asistente virtual stephan veo que tienes un error en la línea 96 del código:

[02-Oct-2021 14:27:30 Europe/Madrid] PHP Fatal error: Uncaught Error: [] operator not supported for strings in /home2/martiane/public_html/inforcont.es/tienda/classes/db/DbQuery.php:96

Usualmente esto tiene que ver con el codigo que esta dentro del mismo, por ende verifica ingresar a dicho archivo y verificar la linea 96 del código, una vez dentro nos comentas que vez en esta línea para poder verificar si es un error conocido y te podemos compartir el cómo solventarlo.

Un saludo 🖐️ 

Respondido : 02/10/2021 8:20 pm
Manuel me gusta

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Manuel
 Manuel
Nuevo usuario

Buenos días @argenis, esto es lo que veo en esa posición, la línea en negrita es la 96:

public function from($table, $alias = null)
{
if (!empty($table)) {
$this->query['from'][] = '`'._DB_PREFIX_.$table.'`'.($alias ? ' '.$alias : '');
}

return $this;
}

Respondido : 03/10/2021 11:21 am
Manuel
 Manuel
Nuevo usuario

Ese mismo código esta funcionando correctamente en el hosting de origen.

Respondido : 03/10/2021 12:39 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Manuel.

Prueba a modificar la version de PHP de ese instalación e instala la version 5.6 o 5.5

Puedes modificar la version de PHP desde tu cuenta de cPanel:

-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

 

Revisa si después de eso carga la web.

 

Un saludo

 

Respondido : 03/10/2021 12:52 pm
Manuel me gusta
Manuel
 Manuel
Nuevo usuario

Muchas gracias @pepesoler,  ahí estaba el origen del error, en la versión de PHP. La he cambiado a la misma que tenía en el hosting anterior 5.6.

👍

Respondido : 03/10/2021 1:52 pm

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Manuel.

Genial !!! me alegra que lo solucionaras 😀 

Cualquier consulta que tengas no dudes en comunicarlo.

 

Cerramos el tema.

Un saludo

Respondido : 03/10/2021 3:05 pm