Error al actualizar de 1.7.4 a 1.7.5 deshace el theme principal y error sección rendimiento  

 
David
 David
Usuario activo

He hecho un update a 1.7.5 de las dos formas incluso manualmente y resulta que el theme solo se me ve una imagen y luego para el resto d pestañas aparece el theme perfectamente, luego al hacer una restauración del día anterior al darle a la pestaña de rendimiento del Back me sale un error 500 internal...

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 05/02/2019 10:22 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola David.

El error es por que esta pasando una variable que no esta definida.

Necesito un poco más de datos ¿ Actualizaste de prestashop 1.6 a 1.7 ?
Este error suele venir por una actualización de versiones de rama inferiores, es decir de 1.6 a 1.7

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 05/02/2019 11:34 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Usuario activo

No en realidad me pasa con la actualización de la version 1.74 a la version 1.7.5 utilizo un template de Leo Leo Walmart Prestashop Theme

Lo he hecho la actualización de 1 click y lo probé subiendo yo el zip oficial de prestashop y pasa lo mismo

ResponderCitar
Respondido : 05/02/2019 11:55 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola David.

No veo problemas a nivel de hosting o de Prestashop , lo único que veo es la versión de PHP que utilizas 7.0

Prueba a modificar la versión de PHP e instala la 7.2, lo puedes realizar fácilmente desde tu cuenta de cpanel -> Software -> Configurar PHP, solo tienes que seleccionar la versión que quieres instalar.

Tienes información en esta guía:
-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 05/02/2019 1:31 pm

Cursos Gratuitos WordPress

David
 David
Usuario activo

Me quieres decir que puede ser por que la versión de php ese mal? puedo intentar hacer la actualización y enseñarte realmente lo que ocurre no me deja poner el debug ya que esa sección como te comento al entrar peta

Acabo de activar en el defines el debug y me salta esto en la pagina que me da el error adjunto la imagen

Warning: file_exists(): open_basedir restriction in effect. File(/home2/composer.json) is not within the allowed path(s): (/home/lovexes:/home2/lovexes:/usr/lib/php:/usr/local/lib/php:/usr/local/php7:/usr/local/php55:/usr/local/php54:/usr/local/php53:/usr/local/php52:/tmp:/opt/alt/php72)

ResponderCitar
Respondido : 05/02/2019 1:59 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola David.

Ese error es un bug y está documentado en prestashop
-> http://forge.prestashop.com/browse/BOOM-5952

Se soluciono en la version 1.7.4.2
-> https://github.com/PrestaShop/PrestaShop/pull/9345

El problema venía por el módulo 1click beta que circulaba para las actualizaciones de 1.6 a 1.7 y que al final no funcionó

.- Elimina el módulo 1click que tienes instalado e instala el oficial desde esta URL
-> https://addons.prestashop.com/es/migracion-copias-de-seguridad/5496-.html

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 05/02/2019 4:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Usuario activo

Gracias pepe ya he instalado el modulo de la pagina oficial ahora el problema es si hay alguna forma de desabilitar el cache por que al entrar en la sección de rendimiento me salta ese error 500 que me esta dando tantos quebraderos de cabeza...
Gracias

ResponderCitar
Respondido : 05/02/2019 4:37 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Entiendo entonces que sigues con el problema inicial que no puedes entrar a la opción de rendimiento.
En los archivos de tu sitio ubica la carpeta cache y borra manualmente todo el contenido.

Si sigues con problemas prueba restaurar nuevamente otra fecha anterior, verifica si con eso no te sale error 500, y antes de actualizar actualiza el módulo de actualización.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/02/2019 5:21 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David
 David
Usuario activo

He conseguido solucionarlo haciendo una restauración de la db. Ya he hecho la acutalizacion pero esto es lo que me encuentro.

Adjunto

ResponderCitar
Respondido : 05/02/2019 9:06 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Por el momento no visualizo errores. Te adjunto una captura de lo que veo.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/02/2019 4:01 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Usuario activo

Esta bien por que he hecho una restauración a la 1.7.4 de como la tenia funcionando por que no hay forma de actualizar y he descartado el actualizar a la 1.5.7.

Gracias por todo

ResponderCitar
Respondido : 06/02/2019 8:55 am

Por favor Iniciar Sesión o Registro