Inconveniente al Actualizar nueva version Prestashop 1.6.20  

 
oscar alejandro
 oscar alejandro
Estimable Member

Buenos dias!1Como veo que es comun, tengo un percance para actualizar Prestashop a la version 1.6.1.20 ya que al intentar hacerlo como era costumbre, a traves del Modulo ACTUALIZAR CON 1 CLICK, me intenta actualizar a la nueva version 1.7..... Y pues aun no quiero hacerlo pues creo que no estoy preparado para hacerlo.....
Que podria hacer?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 18/08/2018 9:02 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Oscar,

Mi recomendación inicial es que te mantengas en la versión 1.6.1.20 "que es la estable" para la rama 1.6 y seguirá teniendo soporte oficial hasta finales de octubre.

Antes de actualizar desde PS 1.6.1.20 a la estable 1.7.4.2 debes comprobar:

- Si el Tema que usas es 100% compatible en PS 1.7.x
- Si los módulos que usas son 100% compatibles con PS 1.7.x
- Si arrastras módulos desde versiones de PS 1.6 muy antiguas y que al actualizar tengan funciones "deprecated" que luego puedan no funcionar en PS 1.7.x y generen "warnings" o "errores PHP".

Naturalmente antes de hacerlo realiza una copia de seguridad completa de la web y la base de datos.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/08/2018 9:31 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

oscar alejandro
 oscar alejandro
Estimable Member

Hola Luis.
Relamente si quero actualizar al a version 1.6.1.20 pero al intentar hacerlo desde el MODULO DE ACTUALIZACION me obliga a hacerlo a la version 1,7, te adjunto un pantallazo para que lo observaras. Como podria actualizar a la 1.6.1.20?

ResponderCitar
Respondido : 19/08/2018 1:50 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Oscar,

Haz una copia de seguridad y actualiza a la versión estable 1.6.1.20 para lo que tienes que seleccionar el canal secundario en opciones avanzadas, justo debajo de la pantalla de "Actualizar PrestaShop" cuando hagas clic en "1-click upgrade" que es el módulo de actualizaciones de PrestaShop.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/08/2018 2:06 am

Cursos Gratuitos WordPress

oscar alejandro
 oscar alejandro
Estimable Member

Buenos dias.
Intente en dos ocasiones realizar la actualizacion pero me salieron los siguientes errores y no fue posible:

[INTERNAL] /home2/frambues/public_html/prueba1/modules/autoupgrade/classes/UpgradeTools/CoreUpgrader/CoreUpgrader16.php line 67 - Error: Class 'PrestaShopModuleAutoUpgradeUpgradeToolsCoreUpgraderTools' not found #0 /home2/frambues/public_html/prueba1/modules/autoupgrade/classes/UpgradeTools/CoreUpgrader/CoreUpgrader.php(85): PrestaShopModuleAutoUpgradeUpgradeToolsCoreUpgraderCoreUpgrader16->writeNewSettings() #1 /home2/frambues/public_html/prueba1/modules/autoupgrade/classes/TaskRunner/Upgrade/UpgradeDb.php(41): PrestaShopModuleAutoUpgradeUpgradeToolsCoreUpgraderCoreUpgrader->doUpgrade() #2 /home2/frambues/public_html/prueba1/adminwe/autoupgrade/ajax-upgradetab.php(52): PrestaShopModuleAutoUpgradeTaskRunnerUpgradeUpgradeDb->run() #3 {main}

ResponderCitar
Respondido : 19/08/2018 2:48 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola oscar.

Por lo que veo revisando tu cuenta tienes problemas de espacio y es posible que ese error venga por no poder terminar la actualización debido a que no hay espacio suficiente.

prueba primero a solucionar el problema del espacio e intenta realizar de nuevo la actualización.

Si que existe un Bug de PS con ese problema al actualizar de 1.6 a 1.7 pero no entre versiones menores:
-> http://forge.prestashop.com/browse/BOOM-5943?attachmentOrder=desc

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 19/08/2018 3:59 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

oscar alejandro
 oscar alejandro
Estimable Member

Buenos dias!
Te comento que hice lo posible por dar mas espacio e incluso intente hacer la actualizacion sin hacer Backup pero me sigue arrojando exactamente el mismo error, es la primera vez que me ocurre un inconveniente de esta naturaleza.
Probe tambien reinstalando el Modulo pero el problema continua.
Que mas podria ser?

ResponderCitar
Respondido : 20/08/2018 12:28 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hoal Oscar.

El problema esta detectado en el modulo de actualización beta que circulaba para actualizar de 1.6 a 1.7 ¿ sigues utilizando el mismo modulo para las actualizaciones o volviste al modulo por defecto de PS 1.6 ?

Vamos a ir probando cosas a ver si conseguimos solucionarlo:

:- accede a modulos, desactiva el modulo 1click y lo eliminas.
.- Accede addoms de prestashop y descarga la ultima versión del modulo:
-> https://addons.prestashop.com/es/migracion-copias-de-seguridad/5496-.html

.- Activa el modulo y prueba a realizar la actualización.

Es posible que obtengas un error:

[INTERNAL] /home/copiamar/public_html/frambues_1534758882/classes/Cookie.php line 79 - Use of undefined constant _RIJNDAEL_KEY_ - assumed '_RIJNDAEL_KEY_'

Para solucionarlo edita el archivo settings.inc.php que encontraras en la carpeta config y añade estos define:

define('_RIJNDAEL_KEY_', '3Nru1Ha99pSdfAO2XSFnr06ejYfvp7EK');
define('_RIJNDAEL_IV_', 'f40nKRJ9c62OGxbBxteluA==');

Revisa si después de estos pasos puedes actualizar la web, si continuas los problemas veremso como podemos realizar manualmente.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 20/08/2018 2:50 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

oscar alejandro
 oscar alejandro
Estimable Member

PEPE!!
Modifique lo que me comentaste en Settings.inc.php y quedo LISTA LA ACTUALIZACION!!!!
Muchas gracias! te debo una cerveza!!!!!!!!!!!!!!!!! 😀

TODO PERFECTO!!!!!
aun no entiendo que generaria este error pero ya es PRUEBA SUPERADA!

ResponderCitar
Respondido : 21/08/2018 12:43 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Oscar.

Genial me alegro que se solucionaras !!!!!! tomo la palabra para esas cervecitas :woohoo:

aun no entiendo que generaria este error
Nada, es un bug de prestashop, en las versiones 1.7 esos defines no se usan pero en la versión 1.6 son necesarios y los chicos de PS se olvidaron de eso al hacer compatible el modulo para 1.6 y 1.7

Nada una cosa mas solucionada.

Cerramos el tema

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 21/08/2018 2:30 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro