Prestashop 1.7: Error fatal Dispactcher.php cuando intento instalar o desinstalar modulos  

 
José Miguel
Usuario eminente

Hola, hace poco instalé un prestashop para la nueva vesión de nuestra tienda, y estando trabajando en ella, con Prestashop 1.7.5.2, hace unos pocos dias me di cuenta de que cualquier modulo que instalara o desinstalara rompía la web, y siempre da el mismo error 500:

[23-Aug-2019 10:48:05 Europe/Madrid] PHP Fatal error: Uncaught Error: Call to a member function getRequestUri() on null in /home2/solarmat/public_html/classes/Dispatcher.php:533

Alguna idea de cómo resolver este fallo?

Gracias

Saludos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 23/08/2019 6:32 pm
José Miguel
Usuario eminente

Buscando por foros en inglés, he comprobado lo siguiente:

- Me voy a override/classes/Dispatcher.php, y renombro el archivo.
- Solo con esto ya comienza a funcionar la web
- Pero sigo sin poder actualizar, instalar o desinstalar modulos.

Alguna idea?

ResponderCitar
Respondido : 23/08/2019 6:47 pm
Jhon Marreros Guzman
Miembro Moderator

Hola

Si ya renombraste el archivo de la carpeta overrides entonces ahora estas trabajando con el archivo del core de PrestaShop por lo que no deberías tener problemas, veo que actualmente hay una actualización que podrías evaluar hacerla ya que el error que te sale es del core. Prueba actualizar a PrestaShop 1.7.6 y verifica.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/08/2019 7:51 pm
José Miguel
Usuario eminente

Hola John, efectivamente, si que puedo ya trabajar con módulos sin problemas, menudo susto.
Muchas gracias!
Saludos

ResponderCitar
Respondido : 30/08/2019 8:02 pm

Por favor Iniciar Sesión o Registro