Comportamiento anómalo en el frontend al actualizar WP  

 
Rafael
 Rafael
Usuario activo

Hola, os cuento el problema que estoy teniendo, a ver si me podéis echar una mano.
El tema arranca de hace un par de meses a esta parte, desde la movida de Gutemberg. Siguiendo el consejo de los expertos, no actualicé WP hasta no se solucionaran todos los problemas que estaba acarreando la nueva versión.

El problema es que ahora al actualizar wp, genésis o cualquier plugin, me desaparecen en el frontend todas las imágenes de los post, es decir, imagen destacada, miniatura y cualquier imagen que contengan los post. El resto de imágenes que tengo, por ejemplo en la home, siguen apareciendo.
Sin embargo, en el backend el funcionamiento es correcto.

Mi blog está corriendo actualmente con:

  • WordPress 5.0.4
  • Génesis 2.8.1

Adjunto imagen con todos los elementos pendientes de actualización.

Sin ir más lejos, hoy he actualizado sólo los 8 plugins y he vuelto a tener el mismo problema con las imágenes. He tenido que volver a restaurar a la situación anterior.
Agradecería ayuda. Gracias.

Rafa Escudero

URL del sitio: Contenido solo visible a usuarios registrados

Rafa - BricoBlog

Citar
Respondido : 27/03/2019 6:13 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Luego de actualizar verifica a qué ruta hacen referencia las imágenes, comprueba esto en el código HTML, o usando el inspector de código de tu navegador.

Si no te aparecen las imágenes es porque alguna ruta ha cambiado o porque posiblemente tengas algún plugin de optimización o algún sistema de cache o de ministuras de imágenes que necesitar regenerarse. Verifica qué plugins de optimización tienes, puedes enviarnos una captura de pantalla.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/03/2019 6:53 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rafael
 Rafael
Usuario activo

Hola Jhon,
Gracias por tu rápida respuesta. Los plugins que tengo instalados para la gestión de la caché e imágenes son (creo):

  • Autoptimize
  • Lazy Load
  • Smush
  • WE-Varnish-Cache

No sé si me dejo alguno atrás. Por si acaso adjunto pantallazo de los 38 plugins que tengo instalados y activados.

Respecto de comprobar la ruta de las imágenes, he estado viendo el código en el inspector del navegador y, sinceramente, me pierdo, entre tanta línea no veo nada.

Una cosa que quizás sea importante. Desde hace año y medio aproximadamente, estoy usando Google Photos como CDN para las imágenes. Por tanto, tengo parte de las imágenes del blog en el servidor de WebEmpresa, y parte en G.Photos.

¿Te sirve esta información para poder empezar a tirar del hilo?
Gracias.

Rafa - BricoBlog

ResponderCitar
Respondido : 27/03/2019 7:43 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Debe ser alguno de tus plugins de optimización, veo incluso que hay plugins que podrían tener la misma funcionalidad, por ejemplo puedes probar desactivando varnish cache y autoptimize, para desactivar varnish cache revisa :

https://guias.webempresa.com/preguntas-frecuentes/desactivar-magic-cache-varnish-desde-la-administracion-web/

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/03/2019 8:06 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro