Avisos
Vaciar todo

[Resuelto] Error actualizar PHP  

 
Daniel
 Daniel
Usuario eminente

Hola,

He tratado de actualizar mi web a la versión 8 de PHP pero se cae. Me preguntaba si hay alguna forma de saber qué es lo que está fallando, si hay alguna incompatibilidad con algún plugin etc... ¿Dónde se puede ver eso?

Gracias

Contenido solo visible a usuarios registrados

Citar
Respondido : 29/09/2022 11:56 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Daniel

El problema esta en que muchos de los plugin y plantilla aun no son compatibles con la version 8 de PHP.

Veo el siguiente error:

[29-Sep-2022 10:33:51 UTC] PHP Fatal error: Uncaught Error: Call to undefined function create_function() in /home/thezugzw/public_html/wp-content/plugins/arscode-ninja-widget/arscode-ninja-widget.php:140
Stack trace:
#0 /home/thezugzw/public_html/wp-settings.php(428): include_once()
#1 /home/thezugzw/public_html/wp-config.php(85): require_once('/home/thezugzw/...')
#2 /home/thezugzw/public_html/wp-load.php(50): require_once('/home/thezugzw/...')
#3 /home/thezugzw/public_html/wp-blog-header.php(13): require_once('/home/thezugzw/...')
#4 /home/thezugzw/public_html/index.php(17): require('/home/thezugzw/...')
#5 {main}
thrown in /home/thezugzw/public_html/wp-content/plugins/arscode-ninja-widget/arscode-ninja-widget.php on line 140

Este error hace referencia al plugin arscode ninja widget.

Puedes probar a desactivarlo, aunque no te aconsejo que cambies de version de PHP, WordPress no lo recomienda y la verdad me esperaría un poco a que todo sea compatible con esa version.

Tambien veo el siguiente error en tu plantilla:

[29-Sep-2022 10:34:06 UTC] PHP Warning: is_readable(): open_basedir restriction in effect. File(/Newsmag/theme.json) is not within the allowed path(s): (/home/thezugzw:/home2/thezugzw:/usr/local/wepanel/filemanager:/usr/lib/php:/usr/local/lib/php:/tmp:/usr/local/bin/wp:/usr/local/bin/composer:/opt/alt/php74) in /home/thezugzw/public_html/wp-includes/class-wp-theme-json-resolver.php on line 450

 

Por lo que puedo ver estamos en lo mismo, no es compatible con la version 8 de PHP

 

Un Saludo

 

 

ResponderCitar
Respondido : 29/09/2022 12:08 pm

Cursos Gratuitos WordPress

Daniel
 Daniel
Usuario eminente

Excelente respuesta. Muchas gracias.

ResponderCitar
Respondido : 29/09/2022 12:27 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Daniel, 

Gracias a ti, para nosotros es un placer poder ayudarte 

Con esto podemos dar el tema como solucionado, no dudes en escribirnos si tienes cualquier otra consulta

Un Saludo 😊 

 
ResponderCitar
Respondido : 29/09/2022 12:30 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress