No puedo añadir imágenes a los productos al actualizar a Wordpress 5.6  

 
Ana
 Ana
Usuario activo

Buenos días,

He intentado desde diciembre actualizar varias veces mi web a la última versión de Wordpress pero no puedo porque al hacerlo automáticamente me deja de funcionar la opción de Añadir imágenes a la galería del producto. No se si hay más gente que tenga este problema y no se que puedo hacer. No me había pasado nunca, siempre actualizo sin problemas. Al darle a "Añadir imágenes a la galería del producto" no hace nada, es como si volviera a recargar la página y ya está, pero no se abre como siempre la biblioteca de medios.

He consultado a través de un ticket y me habéis dicho que pregunte mejor por aquí ya que además al parecer hay varios errores internos del plugin Woocommerce que pueden estar relacionados, ya que afectan al funcionamiento de la web:

[22-Jan-2021 12:00:02 UTC] PHP Parse error: syntax error, unexpected ':', expecting '{' in /home2/anuskisw/public_html/http://anuskisworld.com/wp-content/plugins/woocommerce/woocommerce.php&source=gmail&ust=1611404104278000&usg=AFQjCNFFVXWcHSb77DKz6PR4V-tpiPF8D A">anuskisworld.com/wp-content/plugins/woocommerce/woocommerce.php on line 57

Contenido solo visible a usuarios registrados

Citar
Respondido : 22/01/2021 12:46 pm
Ana
 Ana
Usuario activo

Acabo de ver que no solo no funciona lo de Añadir imágenes a la galería del producto, si no que tampoco se puede eliminar imágenes de la galería de un producto que ya estuviera.

ResponderCitar
Respondido : 22/01/2021 1:05 pm

Cursos Gratuitos WordPress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana,

Comprueba la versión e PHP que tienes actualmente en tu sitio web y configurarla a 7.3, de igual forma verifica si al instalar el siguiente plugin Enable Jquery Helper y verifica si al hacerlo te permite añadir o eliminar cualquier imagen desde algún producto de woocommerce

Quedamos muy atentos como ha ido todo

Un Saludo

 

ResponderCitar
Respondido : 22/01/2021 1:51 pm
Ana
 Ana
Usuario activo

Ya he comprobado que tengo la versión 7.3 de PHP. Igualmente he instalado el plugin que me comentas y sigo igual sin poder añadir ni eliminar fotos de ningún producto.

ResponderCitar
Respondido : 22/01/2021 5:42 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana,

En este caso comprueba si tienes alguna actualización pendiente en tu tema, si es así actualizalo y verifica si con ello logras eliminar o añadir fotos a las galeria.

PD: Antes de realizar cualquier actualización realiza una copia de seguridad, de esa forma si se genera algún error puedes restaurarla -> https://www.webempresa.com/foro/instalacion-y-actualizacion-prestashop/desactivo-cache-y-sigo-sin-poder-actualizar-prestahop-2/paged/2

Un Saludo

ResponderCitar
Respondido : 22/01/2021 5:46 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Por lo que comentas son errores javascript. Esto que comentas entiendo que te sucede en la administración de WordPress.

Cuando creas una entrada si puedes añadir imágenes destactadas, desde el menú de medios, si puedes agregar y borrar imágenes?

Es decir el problema sólo lo tienes con WooCommerce o a nivel de WordPress?

Saludos

ResponderCitar
Respondido : 22/01/2021 5:47 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ana
 Ana
Usuario activo

@karen TEngo todo actualizado, el tema y todos los plugings

ResponderCitar
Respondido : 22/01/2021 5:56 pm
Ana
 Ana
Usuario activo

@jmarreros A nivel de Wordpress no lo se porque no lo utilizo nunca, al ser una tienda todo lo que tengo son productos de la tienda. He probado a crear una entrada de Worpress pero solo sale la opción de "Establecer la imagen destacada" que si me deja añadirla. Pero en Woocomerce esa imagen también la puedo añadir sin problemas, el problema solo es para Añadir imagenes a la galería del producto.

ResponderCitar
Respondido : 22/01/2021 5:58 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana,

Puedes enviarnos una captura de las opciones de tus temas desde el apartado Apariencia -> temas de esta forma podemos verificar con mayor detalle

Un Saludo

ResponderCitar
Respondido : 22/01/2021 6:02 pm
Ana
 Ana
Usuario activo

Adjunto captura

tema wp

, no se si te refieres a eso

ResponderCitar
Respondido : 22/01/2021 6:55 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Para probar si es algo relacionado con tu theme, prueba cambiar temporalmente de tema, puedes usar alguno de los temas que vienen por defecto con WordPress como Twenty Twenty one, y  verifica si cambiando de theme te sucede lo mismo.

Saludos.

 

ResponderCitar
Respondido : 22/01/2021 7:28 pm
Ana
 Ana
Usuario activo

Al cambiar de tema sí funciona.

ResponderCitar
Respondido : 22/01/2021 10:19 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@anuskisworldgmail-com

Hola Ana,

Si al cambiar de tema funciona entonces eso significa que el problema viene de una incompatibilidad o conflicto causado por tu tema. 

Parece ser que estás usando el tema de WooPress, según veo en la web donde se oferta no recibe actualizaciones desde agosto 2020, te sugiero ponerte en contacto con el desarrollador del mismo para que te de una solución -> Contenido solo visible a usuarios registrados

Saludos

ResponderCitar
Respondido : 22/01/2021 10:39 pm