Avisos
Vaciar todo

Problemas después de migrar web  

Página 2 / 2
 
Bruno
 Bruno
Usuario activo

Hola,

acabo de migrar mi web con webempresa y tengo los siguientes problemas.

No puedo añadir plugins ni actualizar la version de wp. Me dice que no tengo permisos de escritura.
En segundo lugar las imagenes destacadas de los post han cambiado de tamaño y se muestran completas no como antes de migrar.
Lo mismo me ha pasado con las imagenes de los productos de woocommerce. En este caso se muestran más pequeñas que antes.

Me podeis ayudar? Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 29/03/2014 1:40 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Bruno,

Dices que Contenido solo visible a usuarios registrados funcionaba "correctamente" antes del traslado y que ahora no te permite actualizar/instalar plugins.

Entiendo que si accedes a tu cPanel, Administrador de Archivos, la carpeta /wp-content/uploads tiene permisos 755 correctamente ¿cierto?.

Si ejecutas un test con Stephan ¿te da alguna indicación de aviso de seguridad relacionado con permisos o similar?.

Accede a tu Área de Cliente y pulsa en "Crear Ticket", verás una nueva pantalla que te permite usar el nuevo Asistente Virtual Stephan, pulsa en "Pedir una revisión automática a Stephan", escoge la cuenta de hosting que quieres revisar y pulsa en "Revisar Cuenta", al cabo de unos 30 segundos aproximadamente te mostrara el resultado del análisis y si no resuelve tu problema podrás crear un ticket pulsando en la parte inferior en "Quiero crear un nuevo Ticket".

Saludos

ResponderCitar
Respondido : 31/03/2014 6:19 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Bruno
 Bruno
Usuario activo

Hola,

el asistente me detecta los siguientes errores

[28-Mar-2014 23:04:41 Europe/Berlin] PHP Fatal error: Call to undefined function get_header() in /home2/comprare/public_html/wp-content/themes/striking_r/index.php on line 12
[29-Mar-2014 00:16:00 Europe/Berlin] PHP Fatal error: Call to undefined function get_header() in /home2/comprare/public_html/wp-content/themes/striking_r/index.php on line 12
[30-Mar-2014 16:51:54 Europe/Berlin] PHP Fatal error: Call to undefined function get_header() in /home2/comprare/public_html/wp-content/themes/striking_r/index.php on line 12
[30-Mar-2014 23:18:56 Europe/Berlin] PHP Fatal error: Call to undefined function get_header() in /home2/comprare/public_html/wp-content/themes/striking_r/index.php on line 12
[29-Mar-2014 10:58:35 UTC] PHP Fatal error: require_once() [function.require]: Failed opening required 'WP_PLUGIN_DIR/w3-total-cache/inc/functions/compat.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/comprare/public_html/wp-content/plugins/w3-total-cache/inc/define.php on line 1449
[29-Mar-2014 10:58:43 UTC] PHP Fatal error: require_once() [function.require]: Failed opening required 'WP_PLUGIN_DIR/w3-total-cache/inc/functions/compat.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/comprare/public_html/wp-content/plugins/w3-total-cache/inc/define.php on line 1449
[29-Mar-2014 10:59:19 UTC] PHP Fatal error: require_once() [function.require]: Failed opening required 'WP_PLUGIN_DIR/w3-total-cache/inc/functions/compat.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/comprare/public_html/wp-content/plugins/w3-total-cache/inc/define.php on line 1449
[29-Mar-2014 10:59:22 UTC] PHP Fatal error: require_once() [function.require]: Failed opening required 'WP_PLUGIN_DIR/w3-total-cache/inc/functions/compat.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/comprare/public_html/wp-content/plugins/w3-total-cache/inc/define.php on line 1449

He abierto un ticket pero me dicen que el lugar correcto para gestionarlo es aquí.

Que hago?

Saludos

ResponderCitar
Respondido : 31/03/2014 12:53 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Si te fijas estos errores son de días pasados y estás relacionados con el W3 Total Cache, por lo que no deberían de tener nada que ver con el problema de los plugins.

Un técnico ha detectado que en el archivo wp-config.php de la raíz de tu web, archivo encargado de guardar los datos de la configuración de WordPress no estaba bien definida la ruta al directorio de instalación. Se ha modificado y ahora ya te debería dejar de instalar plugins sin problemas.

Sobre los problemas que tienes con las imágenes y sus tamaños tendrías que pasarnos el enlace a alguna página donde esto ocurra para que lo podamos revisar.

ResponderCitar
Respondido : 31/03/2014 5:40 pm

Cursos Gratuitos WordPress

Bruno
 Bruno
Usuario activo

Muchas gracias Pablo. Ya funciona correctamente.

Respecto a lo de las imagenes he descubierto que al quitar el plugin lazy load se corrige el error.

Yo lo instalé porque lo recomendabais en vuestra guía para hacer más rápido el worpress y antes de cambiarme no me daba problemas. No se qué ocurrirá.

De momento lo voy a dejar sin el plugin y si se os ocurre qué puede haber pasado dedidmelo y lo pruebo de nuevo.

Gracias por vuestra ayuda y seguimos en contacto

ResponderCitar
Respondido : 31/03/2014 5:49 pm
Página 2 / 2