Warnings al final de pagina Inicio tras recuperar backup en localhost con XCloner  

 
Dietmar
 Dietmar
Usuario eminente

Hola,
siguiendo los vídeos, XCloner he hecho backup de la instalación el el servidor web y restauración de la copia en localhost (Wapserver 2.5).

Lo he repetido varias veces y durante el proceso de restauración con XCloner.php no ha habido nigún mensaje de error, aparentemente ha restaurado todos los ficheros e importado en la BD nueva creada.

Al ejecutar página inicio sale correcta pero al final aparecen una series de warnings como el fichero que adjunto. Todos estos mensajes de warning se refieren a distintas lineas del fichero menú: C:wampwwwtitania_pruebaswp-contentpluginsgantrycorerulesfacttypesmenu.class.php.
Además de esto, las opciones de menú me llevan a las distintas páginas del servidor web, no de localhost!!, que es donde he restaurado.

Agradezco de antemano cualquier pista que me ayude.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 09/09/2015 9:25 pm
Rafael
 Rafael
Miembro Moderator

Hola Dietmar,

No damos soporte a instalaciones Wordpress realizadas en localhost.

Por tu captura no podemos ver -ya que es demasiado- pequeñas los errores que tienes.

¿Podrías ampliar la imágen para que podamos darte una orientación para que puedas revisar?

No obstante, revisa que estés colocando la URLs de Wordpress en localhost y no que apunten a tu página web.

Saludos

ResponderCitar
Respondido : 09/09/2015 10:40 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Dietmar
 Dietmar
Usuario eminente

Hola Rafael,

muchas gracias por tu respuesta. Adjunto fichero ampliado de uno de los warnings que aparecen debajo de la página de Inicio.
El texto del msj es este que te pongo abajo. Siempre referido al fichero "menu.class.php" en distintas líneas.

Warning: Invalid argument supplied for foreach() in C:wampwwwtitania_pruebaswp-contentpluginsgantrycorerulesfacttypesmenu.class.php on line 43

Como dices, debe ser aque las URLs de Wordpress están apuntando al sitio web ni no al localhost. Pero no sé cómo mirar eso y se supone que XCloner al restaurar esto lo tiene en cuenta o he debido hacer algo mal al hacer backup/restaurar. ¿Dónde puedo revisar eso que me dices o tengo que volver a hacer backup y restaurar?

Muchas gracias.

ResponderCitar
Respondido : 10/09/2015 12:53 pm
Rafael
 Rafael
Miembro Moderator

Hola Dietmar,

Como te indique anteriormente, solo podemos darte orientación general al caso que nos comentas ya que la configuración a nivel local no es la misma que la de tu Hosting Webempresa.

Revisa las URLs de Wordpress y echa un vistazo a este artículo. Con la herramienta que ofrece, podrás cambiar todos los registros en la base de datos que apunten a tu dominio por localhost.

https://www.webempresa.com/blog/cambiar-wordpress-de-un-dominio-a-otro.html

En relación a tu error, revisa -> https://www.webempresa.com/foro/26-Plugins-WordPress/140473-error_log-67-53-43.html?start=15#197361

Saludos

ResponderCitar
Respondido : 10/09/2015 1:11 pm

Cursos Gratuitos WordPress