Campos Extra K2  

 
lmartinez
 lmartinez
Honorable Member

Hola,

En los artículos de K2 tengo un campo extra de Area de texto, me gustaria que en el BackEnd, cuando introducimos los datos saliera un editor WYSIWYG, no se si es posible.

saludos.:)

Citar
Respondido : 19/07/2011 10:41 am
David Noguera
 David Noguera
Miembro Admin

Hola Imartinez,

si que es posible hacer esto en K2 por defecto, por lo menos en la última versión, cuando creas el Campo extra, debes de crearlo de tipo "Área de texto", seleccionar el grupo de campos extra al que pertenece y marcar la opción "Usar editor?". Después cuando crees un nuevo item incluido en este grupo de campos extra, aparecerá el campo con un WYSIWYG.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/07/2011 3:38 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

lmartinez
 lmartinez
Honorable Member

Hola,

La verdad es que cuando entro en un campo Extra que es Area de texto esa opción no se me visualiza ni tampoco la opción de valores po defecto, no se si hay que configurar algo o que puede ocurrir. También me ocurre que no puedo modificar las posiciones de los campos de Extra.
la versión que tengo es la 2.4.1

ResponderCitar
Respondido : 19/07/2011 4:08 pm
David Noguera
 David Noguera
Miembro Admin

Hola, cuando creas un nuevo campo extra, has de seleccionar el tipo de campo "Área de texto" y verás que abajo te sale una opción que pone "Usar editor", has de marcarla, te adjunto captura:

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/07/2011 5:46 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

lmartinez
 lmartinez
Honorable Member

HOla David,

Ya lo he visto, pero el problema es que el cliente ya ha dado de alta articulos y rellenado los campos extras, por tanto lo que necesito es modificar los que hay creados, es posible.

Gracias.:)

ResponderCitar
Respondido : 19/07/2011 6:33 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola lmartinez

Al editar un campo adicional debería aparecerte de manera similar como la imagen que envió David.
Puedes enviar una captura de pantalla de que cosa es lo que te aparece.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/07/2011 10:03 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

lmartinez
 lmartinez
Honorable Member

Hola,

La verdad es que no me aparece nada. Os paso el pantallzo.

Saludos.

ResponderCitar
Respondido : 20/07/2011 9:23 am
David Noguera
 David Noguera
Miembro Admin

Hola lmartinez,

si no te aparece el checkbox, lo que puedes hacer es acceder a tu phpMyAdmin y editar la tabla jos_k2_extra_fields (haz primero una copia de seguridad de esta tabla por si acaso!!), busca el registro que quieres modificar buscando en la columna name, verás que en la columna value aparece una cadena JSON, si no sabes que es JSON, JSON es un formato de representación de información, similar a XML, pero más ligero.

Edita este JSON y añade la propiedad "editor":"1", por ejemplo, en mi caso, mi registro del WYSIWYG queda así:

id name value type group published ordering

5 wysiwyg_we [{"name":null,"value":"","editor":"1","target":null}] textarea 1 1 4

Cambiándolo en el phpMyAdmin debería de servir.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/07/2011 10:44 am

Cursos Gratuitos WordPress

lmartinez
 lmartinez
Honorable Member

hola,

He modificado lo que me dices y entonces cuando entro en un articulo ya dado de alta, no sale el edito, además tampo sale el editor en la descripción. En cambio en un articulo nuevo funciona correctamente.

Gracias.

ResponderCitar
Respondido : 20/07/2011 11:20 am
David Noguera
 David Noguera
Miembro Admin

Hola lmartinez, es extraño lo que te pasa por que yo si que puedo editar el campo extra y sale el botón de "Usar editor", que tipo de usuario estás usando para modificar esto?? Usas un usuario con privilegios de SuperAdministrador??

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/07/2011 9:57 am

wpdoctor-revisa-la-salud-de-tu-wordpress

lmartinez
 lmartinez
Honorable Member

Si, estoy usando provolegios de superadministrador.

ResponderCitar
Respondido : 25/07/2011 11:00 am
David Noguera
 David Noguera
Miembro Admin

Hola lmartinez, al parecer K2 guarda en cada registro en la tabla de K2_items la configuración del campo extra y se en el mismo registro se indica si se usa el campo de area de texto con o sin editor, por lo que habría que hacer una consulta UPDATE sobre la tabla de k2_items y añadir la cadena de texto en formato JSON, lo cual lo veo un poco complejo y muy expuesto a errores..

Te recomiendo que si finalmente decides hacer esto hagas backups de tu base de datos antes..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/07/2011 6:33 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro