Avisos
Vaciar todo

Error al activar las paginas friendly en joomla 1.5 en plantilla camber  

 
kontactalia
 kontactalia
Reputable Member

Hola chicos,

Me sucede algo muy extraño. Cuando activo los parámetros de Pagiunas friendly en la confuguración global de una camber, se me generan las url´s amigables, pero el contenido de estas no es el mismo que tengo en las no amigables. Me aparece el contenido de cómo estaban las páginas anteriormente. Por ejemplo, en esta:

http://suplemen-cp43.webjoomla.es/lavostrallar/index.php?option=com_content&view=article&id=93&Itemid=82&lang=es

Que habla de la residencia Blanes, una vez acitvadas las friendly, cambia su contenido!!! (ver archivo pagina friendly) Ese contenido es como estaba tiempo atras esa pagina mientras hacia la web... Es como si el modulo de paginas friendly, cogiera la pagina anterior en vez de la actual, como si esttuviera guardada en algun sitio.

No se qué hacer? vamos, ni idea...sabeis que esta pasando?

Gracias de antemano

Citar
Respondido : 02/02/2012 9:38 am
David Noguera
 David Noguera
Miembro Admin

Hola Kontactalia, la web de la que hablas está en la raíz de tu alojamiento??

veoq ue tienes una web en el directorio "lavostrallar", podría ser que al usar las URL de tipo amigables, el servidor web te envíe directamente a ese directorio... por favor, pásanos una URL amigable de tu web y una URL no amigable de la misma página de tu web..

Pásanos también una captura donde se vea como tiene los ficheros de la raíz de su web. y de su fichero .htaccess..

Saludos

Saludos

ResponderCitar
Respondido : 02/02/2012 12:05 pm

Cursos Gratuitos WordPress

kontactalia
 kontactalia
Reputable Member

No Enric, está en la ruta /lavostrallar

Url amigable web: http://suplemen-cp43.webjoomla.es/lavostrallar/es/nuestras-residencias/residencia-blanes.html

Url no amigable: http://suplemen-cp43.webjoomla.es/lavostrallar/index.php?option=com_content&view=article&id=93&Itemid=82&lang=es

Ahí tienes todo.

gracias!

ResponderCitar
Respondido : 02/02/2012 12:48 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola kontactalia,

¿Puedes mirar en el Gestor de Artículos con que se corresponde el ítem article&id=93&Itemid=82? aparentemente parecen ser contenidos diferentes los que cargan los 2 enlaces que facilitas ¿se corresponden ambos con el mismo item?.

Saludos

ResponderCitar
Respondido : 03/02/2012 2:49 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

kontactalia
 kontactalia
Reputable Member

Hola Luis, no se si te he entendido muy bien. El item 82? lo cierto es que no sé que es. sé que tiene que ver algo con el menú...el articulo 93 es el de residencia blanes, es decir que el correcto es el de la pagina no friendly.

No obstante, os he de decir algo, al principio mientras hacia la web hice que todas las paginas de las residencias sacaran el mismo articulo (por temas de diseño), que casualmente es el articulo que se muestra en la pagina friendly, el no correcto. Es decir que en algún momento las paginas friendly de las residencias (que son las paginas donde tengo el problema) se crearon tal y como veis ahora la de blanes...es decir, esa pagina frindely ha sido así en un momento anterior, al igual que sus residencias hermanas. Y ahora de alguna manera es como si esa pagina estuviera creada y no cogiera los nuevos valores..

Como miro en el gestor de articulos con que se corresponde ese item? Si, ciertamente cargan contenidos diferentes y lo que es peor, todos los modulos que van en esa pagina no se muestran en la friendly! es como si leyera y creara la pagina anterior y no la que tiene que cargar.

gracias de nuevo

ResponderCitar
Respondido : 03/02/2012 8:04 am
David Noguera
 David Noguera
Miembro Admin

Hola Kontactalia,

muestranos una captura de pantalla de los parámetros de configuración que tienes en el item de menú con id 82, el id del item d emenú aparece a la derecha del todo...

Después muestranos una captura de pantalla del gestor de artículos cuando vas a editar el artículo 93..

Después revisa el fichero .htaccess, haz una copia del fichero y envialo comprimido en zip en este post..

Saludos

ResponderCitar
Respondido : 03/02/2012 11:03 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

kontactalia
 kontactalia
Reputable Member

Ahí va todo Enric,

Gracias.

ResponderCitar
Respondido : 03/02/2012 12:44 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola kontactalia,

El .htaccess está correcto. Entiendo que usas para SEO el que lleva por defecto Joomla!, y no un componente de terceros tipo Artio Joomsef, sh404sef, etc.

Como debes estar usando Joomfish, tambien es posible que este cacheando las url's, procede a limpiar la cache normal y la expirada de Joomla!.

Saludos

ResponderCitar
Respondido : 03/02/2012 4:55 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

kontactalia
 kontactalia
Reputable Member

Hola Jordi,

Acabo de hacer lo que me has dicho...de hecho es algo que ya hice en su momento pero sigue sucediendo lo mismo.. limpio las dos caches (supongo que es limpiar la ache´y purgar la expirada del menu herramientas)...todo sigue igual

Sí estoy usando Joomfish y para seo utilizo el que viene por defecto... ahora he dejado las url´s amigables en la web para que veais como queda... se habria de estudiar de done coge esa info para mostrar la antigua? es como si hubiera otra cache? otros archivos? He probado de hacer un nuevo articulo y hacer que se muestre por ejemplo en la residencia de blanes...y resulta que me sigue sacando la web anterior...o sea que esta url : http://suplemen-cp43.webjoomla.es/lavostrallar/es/nuestras-residencias/residencia-blanes.html siempre es la misma, aunque le cambies el articulo...es como si se hubiera quedado grabada en algun sitio..

ResponderCitar
Respondido : 03/02/2012 7:32 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola kontactalia

Al parecer esta relacionado con Joomfish, veo que sólo tienes un idioma español, es posible que hayas colocado contenido en Joomfish para este artículo.

http://suplemen-cp43.webjoomla.es/lavostrallar/es/nuestras-residencias/residencia-blanes.html

Por otro lado cuando accedes al menú directamente se forma la url :
http://suplemen-cp43.webjoomla.es/lavostrallar/index.php?option=com_content&view=article&id=93&Itemid=82

Revisa lo que tienes en el artículo con id 93, puedes enviarnos algunas capturas, también revisa si tienes traducciones para este artículo en español en Joomfish.

Saludos.

ResponderCitar
Respondido : 05/02/2012 12:54 pm

Cursos Gratuitos WordPress

kontactalia
 kontactalia
Reputable Member

Hola Jhon, he desactivado la traducción de ese articulo y ahora funciona correctamente. Seguiré trasteando a ver que pasa y si todo sigue bien.

Si de nuevo tango fallos, os lo digo!

Muchas gracias!!

ResponderCitar
Respondido : 06/02/2012 7:33 am