Error de registro con Community Builder 1.7.1  

 
Vettusta
 Vettusta
Estimable Member

Buenos días, tengo un problema reciente a la hora de registrarse un usuario nuevo en mi Web que podéis ver en la imagen 1.

De todas formas el mensaje de confirmación le llega igualmente al usuario pero con el siguiente mensaje al acceder a la Web, que podéis ver en la imagen 2.

No se a que puede ser debido, pero supongo que es un problema de esta última versión de Community Builder 1.7.1 ya que antes funcionaba sin problemas.

Gracias de antemano.

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

Citar
Respondido : 30/11/2011 8:52 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Vettusta,

La cuenta de correo electrónico señala que es incorrecta: Contenido solo visible a usuarios registrados falta la extensión en el dominio (.com .es .org .net, etc...)

Desconozco si en el campo de relleno de email durante el registro, realiza una validación del email.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 30/11/2011 10:14 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Vettusta
 Vettusta
Estimable Member

Ya lo he entendido, el problema está en la configuración de Community Builder 1.7.1.
Lo he probado y funciona correctamente.

Ahora me ha llegado otro problema desde algunos usuarios que me han enviado una captura de pantalla, que no termino de interpretar. Os lo mando en una nueva imagen 3

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 30/11/2011 10:35 am
David Noguera
 David Noguera
Miembro Admin

Hola Vettusta,

estás usando URLs amigables?? Haz una prueba, desactiva las URLs amigables y dinos si te sigue sucediendo el error..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/11/2011 10:52 am

Cursos Gratuitos WordPress

Vettusta
 Vettusta
Estimable Member

Hola Vettusta,

estás usando URLs amigables?? Haz una prueba, desactiva las URLs amigables y dinos si te sigue sucediendo el error..

Saludos

He desactivado la opción de URL amigables desde la configuración global, y me sigue pasando lo mismo.
Os dejo la dirección web para que lo comprobéis: www.vettusta.es

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 01/12/2011 10:45 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

He realizado una prueba de registro y ha funcionado correctamente.

Lo más probable es que el problema se deba a que al usuario le ha caducado la sesión antes de enviar los datos del formulario. La mejor opción es que aumentes el tiempo de duración de la sesión.

Para ello, vete a la Configuración global de Joomla y entra en la pestaña Sistema. En el campo Duración de la sesión del apartado Configuración de sesión por un valor mayor, por ejemplo, 30 minutos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/12/2011 12:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Vettusta
 Vettusta
Estimable Member

Hola Pablo,
La verdad que no lo entiendo, ya que yo tenía el tiempo de duración de la sesión en 15 minutos, de todas formas lo puse en 30 minutos, y siguió igual, probé con mis alumnos para que se diesen de alta, y son 15 puestos de trabajo diferentes, con navegadores diferentes, y la respuesta fue que solo lo conseguimos con el navegador Safari, el resto, nada de nada.

Después de buscar y buscar, me metí en el foro de Community Builder y me dijeron de cambiar la configuración del mismo dejándo en NO la opción: Activar la comprobación de suplantación de sesiones, como os adjunto en la siguiente imagen, a mi no me gustaría dejarlo así, pero es la única forma funcionó por un tiempo.

Después de varios intentos volvió a salir de nuevo el error, osea que ya me he quedado totalmente sin ideas, algunas veces nos deja y otras no.

Lo único que puedo aportar como pista, es que pasado un tiempo puedo registrarme con un usuario, pero en el momento que voy a realizar un segundo o tercer registro, me salta el error, aún con diferentes máquinas y navegadores.

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 01/12/2011 4:26 pm
David Noguera
 David Noguera
Miembro Admin

Hola Vettusta,

accedeis siempre mediante la misma URL? podría ser que si cambias entre www.vettusta.es y vettusta.es haya problemas con las cookies..

Por otro lado, leo en el foro de COmmunityBuilder, que el problema podría no estar en la sesion, aunque el mensaje de error diga lo contrario:

http://www.joomlapolis.com/forum/29-usability/26712-registration-session-expired-andor-cookies-are-no?limit=6&start=54

Por favor, ves a Community Builder -> Tools (Herramientas) -> check CB database in backend.

Ejecuta esa comprobación y péganos los resultados..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/12/2011 11:13 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Vettusta
 Vettusta
Estimable Member

Por favor, ves a Community Builder -> Tools (Herramientas) -> check CB database in backend.

Ejecuta esa comprobación y péganos los resultados..

Saludos

Aquí te dejo el resultado obtenido

Herramientas CB: Comprobar Núcleo CB base de datos: Resultados

Comprobando la Base de datos de Community Builder:

  • Todas las filas de la tabla comprofiler_field_values de Community Builder coinciden todos con los campor existentes.
  • Todas las finas de la tabla Community Builder comprofiler_field_values de Community Builder enlazan correctamente a los tipos de campos (fieldtype fields) en la tabla comprofiler_field.
  • Todos los campos Community Builder de comprofiler_fields están presentes como columnas en la tabla comprofiler.
  • Todo Núcleo CB básicos obligatorio La Base de datos está actualizada.

Núcleo CB básicos obligatorio realizadas las comprobaciones de la base de datos. Si todas las líneas anteriores están en verde, el test se ha completado correctamente. En otro caso, toma las medidas correctoras propuestas en rojo.

Todo Núcleo CB La Base de datos está actualizada.
Click aquí para Mostrar detalles

Núcleo CB realizadas las comprobaciones de la base de datos. Si todas las líneas anteriores están en verde, el test se ha completado correctamente. En otro caso, toma las medidas correctoras propuestas en rojo.

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 02/12/2011 5:07 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que el problema se deba a algún conflicto con alguna otra extensión de Joomla que tengas instalada en la web. Indícanos componentes, módulos o plugins que hayas instalado en la web.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/12/2011 5:24 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Vettusta
 Vettusta
Estimable Member

Indícanos componentes, módulos o plugins que hayas instalado en la web.

Adjunto te mando 4 imágenes de lo que me pides (Componentes, módulos, plugins, plantillas)

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 02/12/2011 6:04 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Vettusta,

¿Todos los usuarios que realizan la gestión de registro y tienen problemas de "sesión", lo hacen desde la misma IP?.

¿Has probado esto mismo pero desde diferentes IPs?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/12/2011 8:47 pm

Cursos Gratuitos WordPress

Vettusta
 Vettusta
Estimable Member

Estoy esperando que me confirmen algo sobre los registros a través de IPs diferentes, pero de momento he estado observando algunas cosas y una de ellas que me gustaría preguntar es:

He comprobado que estoy usando la versión PHP 5.2.17 y por lo que me han comentado algunos compañeros estan usando cpanel con versiones más modernas para no tener problemas con community builder o extensiones más modernas compatibles con joomla 1.5 y 1.7 respectivamente.

No se si esto tendría algo que ver, pero por si acaso lo expongo aquí para comentarlo con vosotros.
¿podría tener algo que ver?

Gracias de antemano.

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 05/12/2011 12:06 pm
Lucas
 Lucas
Miembro Admin

Hola,

No creo que sea problema de PHP 5.2.17, en el caso que lo prefieras puedes solicitar mediante ticket que muevan tu cuenta de hosting a un servidor con PHP 5.3.6, por defecto aun usamos 5.2.17 porque hay bastantes extensiones que aun no funcionan bien con PHP 5.3.x, los nuevos servidores a partir del 2012 ya los configuramos por defecto con PHP 5.3.

Yo de ti realizaría pruebas instalandome un joomla en otro directorio con el CB 1.7.1 y otro joomla con la anterior versión de CB que te funcionaba bien para determinar que el problema esté en CB.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/12/2011 1:03 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro