Avisos
Vaciar todo

Formulario de Acceso  

Página 2 / 3
 
Juan
 Juan
Reputable Member

Muy buenas. Estoy teniendo problemas con el formulario de acceso en www.voluntarialcores.org. Al principio activé el módulo de acceso (mod_login) para la web. Dicho módulo muestra las siguientes opciones:"¿Olvidó su contraseña?", "¿Olvido su nombre de usuario?" y "Regístrese aquí". Sin embargo, quiero que el Acceso se muestre en el menú principal. Para ello, creé un ítem de menú de acceso (Usuario > Acceder > Presentación predeterminada de acceso a la cuenta de usuario). El problema es que este menú sólo muestra las opciones "¿Has olvidado tu contraseña?" y "Regístrate", pero no la de "Olvido de usuario". Mi intención es mostrar las tres opciones para que el usuario tenga mayores posibilidades. ¿Qué tendría que hacer? ¿Podría integrar el módulo login dentro de un ítem de menú principal "en blanco"? O podría añadir la opción de "¿Olvidó su nombre de usuario?" al formulario de acceso del menú principal? Espero que me puedan ayudar. Muchas gracias. Saludos.

Citar
Respondido : 13/07/2011 8:30 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Es posible que te refieras al mensaje de clave inválida, es un problema de joomla relacionado con el overrides del template, puedes revisar el siguiente artículo en donde se explica detalladamente.
http://www.monitojoomla.com/articulos/11-articulos/18-articulos-reseteo-contrasena-joomla-error-clave-invalida

Saludos.

ResponderCitar
Respondido : 15/07/2011 4:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan
 Juan
Reputable Member

Cierto, es ese problema. He consultado ese tutorial pero continúo con el problema. Lo he hecho todo al pie de la letra. Envío aquí el reporte del archivo confirm.php por si tuviera algo erróneo. En negrita está lo añadido en el archivo. Gracias y Saludos.

defined('_JEXEC') or die('Restricted access');
?>


<form action="" method="post" class="josForm form-validate">


<label for="token" class="hasTip" title="::">:

<label for="username" class="hasTip" title="::">:

ResponderCitar
Respondido : 15/07/2011 5:26 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Revisa el punto 3 del artículo, es posible que te encuentres usando alguna plantilla que usa framework y debes realizar los cambios en otro lado.

Saludos.

ResponderCitar
Respondido : 15/07/2011 7:57 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan
 Juan
Reputable Member

Pues teóricamente la Plantilla JA Lime utiliza el framework T3, al menos así lo indicaba un logo que se mostraba en el footer de la web. Sin embargo, cuando analizo las carpetas no está la carpeta "jat3" tal como demuestro en la siguiente captura:

¿Qué puedo hacer? Muchas gracias y saludos.

ResponderCitar
Respondido : 15/07/2011 9:03 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Envía la url de tu sitio para comprobar si te aparece la caja de texto agregada en el overrides.

Saludos.

ResponderCitar
Respondido : 15/07/2011 9:23 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

Veo que la plantilla por defecto si muestra la opción de "Olvidaste tu contraseña" y te conduce al formulario para insertar el correo electrónico y que genere un "token" que te permita posteriormente restablecerla.

Saludos

ResponderCitar
Respondido : 15/07/2011 9:43 pm
Juan
 Juan
Reputable Member

Mi web es www.voluntariadoalcores.org. La opción "Olvidaste tu contraseña" aparece también en mi web actual, el problema es que la clave que genera es inválida. Saludos y Gracias.

ResponderCitar
Respondido : 15/07/2011 9:55 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

Ok, centrándonos, el problema no es de la plantilla ni del formulario (mod_login) sino del token, ¿que versión de Joomla tienes?.

Saludos

ResponderCitar
Respondido : 15/07/2011 10:32 pm
Juan
 Juan
Reputable Member

Mi versión es la Joomla 1.5.20. ¿Qué tendría que hacer? Gracias. Saludos.

ResponderCitar
Respondido : 15/07/2011 10:43 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

Precisamente aquí hemos tratado anteriormente ese problema del token que no funciona porque se trata de un bug en las versiones anteriores a la 1.5.23, por tanto mi primera recomendación es actualizarte.

  1. Realiza una copia de seguridad de tu sitio web con Akeeba Backup
  2. Actualiza tu Joomla! a la última versión estable.

En Webempresa siempre le recomendamos que trabajes con la última versión estable de Joomla!. Periódicamente, cuando se producen actualizaciones, informamos a través de nuestro Blog y Boletines a los clientes de estas actualizaciones.

Te facilitamos un enlace donde podrá descargarte la última versión de actualización de su versión actual de Joomla! a la 1.5.23.

-

Ponemos a tu disposición el siguiente vídeo donde se explica el proceso de actualización de tu pack de Joomla! a una versión superior:

http://www.youtube.com/watch?v=A9Y9rRjn-l4

Aprovechamos para dejarte también un enlace a otros vídeo donde puedes ver como actualizar manualmente la versión de Joomla: Vídeos Panel de Control Cpanel/Rvskin: https://www.webempresa.com/web-empresa-joomla-servicios/hosting-joomla/videos-panel-de-control-webempresa.html

No olvides realizar una copia de seguridad de tu sitio web completo y de la base de datos antes de realizar dicha actualización.

Te adjuntamos unos vídeos para poder copiar y restaurar un Joomla! de un Hosting a otro o en el mismo Hosting:

Como copiar su Joomla con Akeeba Backup o JoomlaPack:
https://www.webempresa.com/videos/akeeba_copiadeseguridad/akeeba_copiadeseguridad.html

Como restaurar su Joomla con Akeeba Backup o JoomlaPack:
https://www.webempresa.com/videos/akeeba_restauracion/akeeba_restauracion.html

En el caso que pongas una contraseña al realizar un backup apúntala para luego introducirla en la restauración.

Una vez realizado todo esto verifica nuevamente la recuperación/cambio de contraseña desde el formulario de acceso.

Saludos

ResponderCitar
Respondido : 16/07/2011 12:36 am
Juan
 Juan
Reputable Member

Vale intentaré hacerlo todo y os comento. Pero, ¿tendrá alguna repercusión en la plantilla, la configuración actual de los módulos, los menús o la forma actual de la web? Es que estamos trabajando duro para configurar la página y temo que si actualizo, todo lo que hemos hecho hasta ahora se vaya al traste. Gracias y saludos.

ResponderCitar
Respondido : 16/07/2011 12:58 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

Inicialmente no tiene porque afectarte en lo que comentas la actualización.

No obstante ya sabes, copia de seguridad siempre antes de hacer cambios para poder volver a un punto anterior.

El pack descargalo desde la web de JoomlaSpanish o del enlace que desde su web se facilita para los upgrades de versión, para que no lo mezcles con el pack en ingles.

Saludos

ResponderCitar
Respondido : 16/07/2011 1:25 am
Juan
 Juan
Reputable Member

Buenas, me dispongo a hacer la actualización. He descargado la versiò 1.5.23 del pack del enlace que ofrecéis en Webempresa: http://joomlacode.org/gf/download/frsrelease/14506/63460/Joomla_1.5.23-Stable-Full_Package.zip. Sin embargo, después de ver el videotutorial sobre Actualización del Pack Webempresa, me surge una duda. En el videotutorial, se muestra que en el CPanel > dentro del Pack Webempresa, aparece una opción de "Actualizar" a versiones superiores. Sin embargo, en mi caso, dichas opciones no aparecen como se muestra en la captura.

Y cuando marco el pack que deseo actualizar y pincho en Actualizar, me sale el siguiente error: "Error: Ivalidad Selection". Yo tengo el nuevo pack descargado pero, ¿tendría que cargarlo como si fuera un pack nuevo? ¿Cómo podría hacerlo? Saludos y gracias.

ResponderCitar
Respondido : 16/07/2011 11:16 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan
 Juan
Reputable Member

Se me ha olvidado añadir que en mi caso la cosa se complica porque tengo otros dominios añadidos. Quiero instalar el pack 1.5.23 en todos ellos, previo backup de cada uno. Pero el problema es que no sé cómo cargar el pack de la nueva versión para actualizarlo. Gracias y saludos.

ResponderCitar
Respondido : 16/07/2011 11:25 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

El link http://joomlacode.org/gf/download/frsrelease/14506/63460/Joomla_1.5.23-Stable-Full_Package.zip , es el paquete completo, lo que debes descargarte es el patch. La actualización lo encuentras en el siguiente link:

http://joomlacode.org/gf/project/spanish/frs/?action=FrsReleaseView&release_id=14525

En el tab de Ficheros ubica tu correspondiente parche de 1.5.20 a 1.5.23, por ejemplo :
Joomla_1.5.20_a_1.5.23-Spanish-Parche_Pack.zip

Descomprime este archivo en la raiz de tu sitio web Joomla 1.5.20

Las actualización por el cpanel han sido restringidas ya que algunos usuarios modificaban el core de Joomla y perdían sus cambios.

Saludos.

ResponderCitar
Respondido : 16/07/2011 12:38 pm

Cursos Gratuitos WordPress

Página 2 / 3