Avisos
Vaciar todo

Formulario de Acceso  

Página 3 / 3
 
Juan
 Juan
Reputable Member

Muy buenas. Estoy teniendo problemas con el formulario de acceso en www.voluntarialcores.org. Al principio activé el módulo de acceso (mod_login) para la web. Dicho módulo muestra las siguientes opciones:"¿Olvidó su contraseña?", "¿Olvido su nombre de usuario?" y "Regístrese aquí". Sin embargo, quiero que el Acceso se muestre en el menú principal. Para ello, creé un ítem de menú de acceso (Usuario > Acceder > Presentación predeterminada de acceso a la cuenta de usuario). El problema es que este menú sólo muestra las opciones "¿Has olvidado tu contraseña?" y "Regístrate", pero no la de "Olvido de usuario". Mi intención es mostrar las tres opciones para que el usuario tenga mayores posibilidades. ¿Qué tendría que hacer? ¿Podría integrar el módulo login dentro de un ítem de menú principal "en blanco"? O podría añadir la opción de "¿Olvidó su nombre de usuario?" al formulario de acceso del menú principal? Espero que me puedan ayudar. Muchas gracias. Saludos.

Citar
Respondido : 13/07/2011 8:30 pm
Juan
 Juan
Reputable Member

Gracias. He hecho la actualización creo que correctamente ya que en el panel de Administración de Joomla me indican que mi versión es la 1.5.23. He realizado el intento para recuperar la contraseña y ¡ya funciona!. Pero queda un detalle que me gustaría corregir. Para recuperar la contraseña aparece esta pantalla:

Como veis, el título de clave y la tabla aparece tan descuadrada que no se sabe muy bien dónde hay que introducir el nombre de usuario y dónde la clave. Sé que quizás la solución esté en la ruta del confirm.php (templates/ja_lime/html/com_user/reset/) pero no sabría qué códigos modificar. ¿Qué podría hacer? Muchas gracias y saludos.

ResponderCitar
Respondido : 16/07/2011 3:01 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Creo que has colocado mal el código, ya que al visualizar tu página de confirmación
http://www.voluntariadoalcores.org/?option=com_user&view=reset&layout=confirm

se observa que por ejemplo el label se encuentra por arriba, justo después del form. Asegúrate de haber ingresado el código correctamente


 
 <label for="username" class="hasTip" title="::">:
 
 
 
 
 

Referencia :
http://www.monitojoomla.com/articulos/11-articulos/18-articulos-reseteo-contrasena-joomla-error-clave-invalida

Saludos.

ResponderCitar
Respondido : 16/07/2011 5:35 pm
Juan
 Juan
Reputable Member

Bueno, al menos he conseguido que se muestren al mismo nivel. He probado de la misma forma que indica el tutorial y se me descuadra y de diversos modos y no he conseguido que estén en líneas diferentes con la caja pegada al texto. Ahora, se muestran de esta forma:

Muchas gracias por todo y saludos.

ResponderCitar
Respondido : 16/07/2011 7:49 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

Dices que lo has corregido pero lo sigo viendo igual ¿en que archivo has realizado las correcciones?

Saludos

ResponderCitar
Respondido : 16/07/2011 8:28 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Veo que no esta copiado de acuerdo al código de tablas y más bien todo las etiquetas están en línea.
Tu editaste esto?, te sugiero agrupar el label y el input en un contenedor, por ejemplo


<label for="username" class="hasTip" title="::">:

Saludos.

ResponderCitar
Respondido : 17/07/2011 12:30 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan
 Juan
Reputable Member

Lo he estado editando en el "confirm.php" situado en la siguiente ruta: /templates/ja_lime/html/com_user/reset/confirm.php. Lo edité tal y como indica el tutorial de monitojoomla pero me salió muy desagrupado. Este código de arriba, ¿dónde he de introducirlo?. He restaurado el archivo a como lo tenía antes, pero me sale así:

Mi intención es poner el nombre de usuario arriba, la clave abajo y, en otra línea el botón de enviar. Pero cualquier modificación que hago me sale de forma incorrecta. Os envío una muestra de cómo está este archivo actualmente:

defined('_JEXEC') or die('Restricted access');
?>


<form action="" method="post" class="josForm form-validate">

<label for="token" class="hasTip" title="::">:

<label for="username" class="hasTip" title="::">:

Saludos y gracias.

ResponderCitar
Respondido : 17/07/2011 5:41 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Tu html esta mal formado, prueba cambiar la parte del form por el siguiente código

<form action="" method="post" class="josForm form-validate">

<label for="token" class="hasTip" title="::">:
<label for="username" class="hasTip" title="::">:

Saludos.

ResponderCitar
Respondido : 18/07/2011 5:46 pm

Cursos Gratuitos WordPress

Juan
 Juan
Reputable Member

Perfecto. Ahora sí está todo en su lugar. Muchas gracias.

ResponderCitar
Respondido : 19/07/2011 6:46 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Que bueno que finalmente se solucionó.
Te recomiendo revisar algo de estructura html de tablas, de esta manera no tendrás el mismo problema en el futuro

Revisa este tutorial : http://www.desarrolloweb.com/articulos/629.php

Procedo a cerrar este hilo de discusión.

Saludos.

ResponderCitar
Respondido : 19/07/2011 7:22 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Página 3 / 3