Avisos
Vaciar todo

Problemas con idioma y conjunto de caracteres.  

 
Antonio Pintor
 Antonio Pintor
Nuevo usuario

Hola chicos,

Antes de nada, presentarme, me llamo Antonio, y estoy empezando con joomla, espero tengáis algo de paciencia conmigo.

Bueno, estoy preparando la web de nuestro ampa, que la tenemos alojada en webempresa y que es www.ampalosibones.org.

La tengo con una plantilla llamada via granitti descargada desde http://www.globbersthemes.com/templates-demo/Page-3.html, y también tengo descargado el componente joomfish.

Llevo intención de que al ser el colegio bilingüe en fránces podamos tener la web en castellano, fránces e inglés. Para esto entendí que debía instalarme el joomfish.

Bien, uno de los problemas básicos que tengo es que los títulos de los módulos, o los títulos sin más no me reconoce los caractgeres castellanos como los acentos o ñs. Podéis verlo en la parte de abajo de la web donde pone Quien esta en lnea ? sin la i y gracias porque el está lo he puesto también sin acento.

Rogaría primero saber como puedo cambiar esto que me temo que el problema está en la plantilla, y luego me gustaría saber si los contenidos de los artículos que pongamos son traducidos automáticamente por joomfish y sion saber si hay algún traductor automático.

Gracias por su ayuda.
Antonio

Citar
Respondido : 17/01/2012 6:45 pm
Antonio Pintor
 Antonio Pintor
Nuevo usuario

Creo que el tema puede ser porque la plantilla usa cufón... he visto una explicación por aquí ...
http://tengoun.com.ar/cufon-y-los-acentos/utilidades/11/2010/
Lo que no sé es si eso es correcto y como puedo conocer la fuente de mi plantilla.

ResponderCitar
Respondido : 17/01/2012 7:42 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Antonio

Efectivamente el problema que no aparezcan algunos caracteres en el título es debido a la plantilla, específicamente a que usa un tipo de letra que no es estándar en la web y debe recurrir al uso de cufon, pero no esta incluyendo o este tipo de letra no incluye caracteres con tilde o la ñ. Revisa la configuración de la plantilla para ver si es posible cambiar el tipo de letra de los titulos de módulos.

Por otro lado los contenidos de los artículos no son traducidos automáticamente con Joomfish y deberás hacerlo manualmente. Tienes una alternativa automática a través de google pero no es 100% confiable, revisa el siguiente artículo : https://www.webempresa.com/blog/traduccion-sitio-web-usando-el-servicio-de-traduccion-de-google.html

Saludos.

ResponderCitar
Respondido : 17/01/2012 7:44 pm
Jose
 Jose
Usuario eminente

Saludos.

A mí me pasa en un theme adquirido en el extranjero.

Aunque se ven las tildes y eñes por todo el portal, únicamente cuando uso en parámetros avanzados la opción en los artículos la opción de mostrar el título automáticamente, es entonces cuando el título aparece sin eñes ni tildes.

Sí que es verdad que me traigo una pelea con el editor de texto de creación de artículos. Pues no funciona el editor de texto como espero y no soy capaz de controlar el tamaño de las fuentes.

El problema es cuando le aplicas las etiquetas

o

Aparte de lo anterior, por favor ¿alguien me indicaría un videotutorial de estos tan bien hechos de webemprea para solucionar estos problemas?

Muchas gracias.
Un saludo.

ResponderCitar

Respondido : 15/11/2012 6:56 pm

Cursos Gratuitos WordPress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Jose,

Puedes adjuntarnos la url mediante una etiqueta [hide] y capturas para poder evaluar correctamente el problema.

Saludos.

ResponderCitar
Respondido : 15/11/2012 11:42 pm
Jose
 Jose
Usuario eminente

Hola Johnny Heredia Montiel,

Aunque te adjunte la url y las capturas de pantalla no vas a poder evaluar mejor el problema que leyendo mi texto en el que lo explico.

Para decirte que le doy a una tecla (ñ o carácter con tilde) y no sale publicado en el artículo ¿qué captura quieres si no sale? ¿Cómo sabríass qué tecla he pulsado?

Y esto tiene que ver con algo de cufon.

Saludos.

ResponderCitar
Respondido : 16/11/2012 6:35 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jose,

Hay casos en que la fuente seleccionada "cufon" de algunas plantillas compradas en clubs ingleses o americanos, no permiten caracteres como la ñ o acentos.

Contactas con el club en el que hayas comprado la plantilla para que te indiquen alternativas, o seleccionas una fuente que tenga admita caracteres como ñ y acentos.

Saludos

ResponderCitar
Respondido : 16/11/2012 8:23 am
Jose
 Jose
Usuario eminente

Hola Jordi, no puedo contactar ya con ellos, está descartada esa posibilidad.

La alternativa por tanto es "seleccionas una fuente que tenga admita caracteres como ñ y acentos" y esa es la razón de postear, querido compañero. Este es el motivo de postear en el foro, no sé cómo hacerlo.

Si por favor alguien me ayuda con algún sitio para enterarme se lo agradecería, es difícil que este caso no se haya dado antes pero llevo ya con este 3 días dando vueltas sin encontrar nada.

Saludos.

ResponderCitar
Respondido : 16/11/2012 4:04 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Jose

Debes enviarnos la url de tu sitio web de todas maneras, envíanos la url de un artículo que tengas "ñ" , luego veremos si es problema de CSS.

Envíanos también una captura de pantalla de la configuración de tu plantilla, algunas plantillas permite desactivar la funcionalidad de fuentes y dejar las fuentes estandard.

Saludos.

ResponderCitar
Respondido : 16/11/2012 8:28 pm
Jose
 Jose
Usuario eminente

ñ

ResponderCitar
Respondido : 16/11/2012 10:16 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Jose,

Que tipografía en concreto estas utilizando, puedes adjuntarnos el nombre para poder evaluarla.

Saludos.

ResponderCitar
Respondido : 16/11/2012 11:08 pm
Jose
 Jose
Usuario eminente

arial creo

ResponderCitar
Respondido : 16/11/2012 11:49 pm

Cursos Gratuitos WordPress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Jose,

Para una tipografía tipo Arial no necesitas utilizar cufon, simplemente ingresando código CSS en la tipografía se solucionaría. En el siguiente artículo del Blog de Webempresa se explica el uso de Firebug, herramienta destinada a localizar cadenas de código, estilos, etc., desde tu navegador:

- https://www.webempresa.com/blog/usando-firebug-para-modificar-la-apariencia-de-una-plantilla-joomla.html

Firebug Lite for Google Chrome:
- https://chrome.google.com/extensions/detail/bmagokdooijbeehmkpknfglimnifench

Fifebug Firefox:
- https://addons.mozilla.org/es-es/firefox/addon/firebug/

Saludos.

ResponderCitar
Respondido : 16/11/2012 11:53 pm