Problemas en K2 con Feed RSS  

 
chemaro
 chemaro
Usuario activo

Hola a todos,

el tema es que no me funciona la suscripción a los contenidos que publico en mi blog con el componente K2. Tengo creada una página dentro de mi web, destinada exclusivamente al blog y dentro de esta página he publicado el componente K2, también tengo el modulo "mod_k2_content" publicado en la página de inicio para que me recoja las tres últimas noticias que se publica en el blog, en ambos sitios tengo activado el RSS, pero al pulsarlo no hace nada, es como si volviese a recargar la página y nada más. En las preferencias de K2, tengo la siguiente configuración dentro del apartado "RSS Feed Settings":

Límite Feed : 20
Imagen del artículo: Mostrar
Image size for items: small
Item Introtext: mostrar
Item Introtext word limit: 140
Item Fulltext: mostrar

También he probado a capturar las noticias con diversos gestores de noticias RSS, pero no detectan nada.

Por favor, a ver si me podéis ayudar y muchas gracia de antemano.

Entorno:

Joomla! 1.5.14 Stable
K2 v2.0.0
Pack Joomla Fácil

Citar
Respondido : 13/05/2010 10:57 am
David Noguera
 David Noguera
Miembro Admin

Hola Chemaro,

puedes dejarnos la URL del feed RSS que no te está funcionando para que le echemos un vistazo??

El tema de los RSS es delicado a nivel de programación, ya que cualquier carácter que se imprima por pantalla antes de la generación RSS, en concreto antes de llamar a la función header, hace que no se lea el mime-type adecuadamente y por tanto, el lector RSS sea incapaz de parsear el XML.
No se si se me ha entendido entre tanto tecnicismo 🙂

Por lo que veo estás usando una versión de k2 antigua, la 2.0.0, te recomiendo que actualices a la nueva versión la 2.2, donde probablemente hayan corregido este error.

http://getk2.org/

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/05/2010 1:04 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

chemaro
 chemaro
Usuario activo

Gracias David por responder,

la url que me pides es www.mromeroconsultores.es/blog.html

En cualquier caso actualizaré la versión del K2 a ver si como dices se corrige el error.

Muchas gracias.

ResponderCitar
Respondido : 20/05/2010 11:44 am
David Noguera
 David Noguera
Miembro Admin

Hola Chemaro, te comento que he accedido a tu web y veo que el feed está funcionando correctamente. Mira la siguiente URL:

http://www.mromeroconsultores.es/blog.html?format=feed&type=rss

Ahí aparece el feed RSS de tu blog. Sin embargo, veo que cuando pulsas el botón de la sindicación no aparece el feed. Parece que está habiendo problemas con las URLs amigables.

Prueba a actualizar k2 y me cuentas.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/05/2010 11:53 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

chemaro
 chemaro
Usuario activo

Hola David,

Ya he actualizado la versión de K2 a la 2.2, pero el tema sigue igual.

Alguna otra idea por donde seguir buscando?

Muchas gracias.

ResponderCitar
Respondido : 21/05/2010 9:45 am
Lucas
 Lucas
Miembro Admin

Hola,

Prueba a desactivar el SEO de tu web y ver si sigue fallando con el SEO desactivado.

También podría ser un problema de .htaccess pero probaría antes desactivando el SEO de Joomla.

Que extensión usas para mostrar las rss o como has puesto el rss arriba en tu blog?

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/05/2010 2:25 pm

Cursos Gratuitos WordPress

chemaro
 chemaro
Usuario activo

Hola Lucas,

efectivamente desactivando el SEO funciona correctamente, pero claro me imagino que no será una solución viable, ya que de esta forma pierdo efectividad con los buscadores, no es así?

El rss de la parte superior, se coloca activando la "RSS feed link" de la opción "Blog" del menú principal. Esta opción llama al componente "K2 » Itemlist / Categoría"

saludos.

ResponderCitar
Respondido : 24/05/2010 5:02 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola Chemaro,

En la configuración general de Joomla, dentro del apartado de urls amigables, prueba a activar el SEO pero desactiva el parámetro Agregar un sufijo a las URLs y mira si así te funciona.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/05/2010 5:42 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

chemaro
 chemaro
Usuario activo

Hola Pablo,

si que funciona de la forma que me indicas, pero en que me puede afectar este cambio?, es normal esto con el las RSS de K2?

gracias y saludos.

ResponderCitar
Respondido : 25/05/2010 10:42 am
Lucas
 Lucas
Miembro Admin

Hola,

No te afecta el cambio, en realidad se comenta en el mundillo SEO que ahora es mejor que no se muestren las extensiones, pero bueno, como todo en el mundo SEO cada uno dice una cosa y hasta que no pase un tiempo no se puede saber si se consolida el tema.

Aquí podrás encontrar información al respecto:

http://www.google.es/search?hl=es&q=html+extension+and+seo&aq=f&aqi=&aql=&oq=&gs_rfai=

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/05/2010 6:10 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro