Publicación de enlaces en Facebook  

Página 1 / 2
 
J.Javier Bernárdez
 J.Javier Bernárdez
Usuario eminente

Hola a tod@s,

a ver si alguien puede ayudarme con el siguiente problema. Al hacer publicidad de un enlace de mi web en facebook, me aparecen mal todas las palabras con acentos o ñ... por ejemplo: Convención y declaración en lugar de convención y declaración, esto me ocurre con todos los artículos, ¿alguien sabe a qué se debe?

Gracias.

Citar
Respondido : 11/04/2011 7:22 am
David Noguera
 David Noguera
Miembro Admin

Hola J. Javier,

que método estás empleando para hacer las publicaciones?? usas FeedBurner, usas algun plugin de Joomla?? Las pones a mano??

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/04/2011 8:31 am

Cursos Gratuitos WordPress

J.Javier Bernárdez
 J.Javier Bernárdez
Usuario eminente

Hola,

pues las pongo a mano y también haciendo click en el botón 'Me gusta' de facebook que tengo al final de los artículos. Esta es mi web, por si quieres echar un vistazo: http://comunidad-internacional.com

(Ya he probado poniendo URLs amigables en los parámetros de configuración de SEO y también me da el mismo problema)

Gracias por responder.

Javier

ResponderCitar
Respondido : 11/04/2011 8:39 am
David Noguera
 David Noguera
Miembro Admin

Hola J.Javier,

veo que tiene sun problema con la codificación de tu web. Busca el fichero index.php de tu template, en tu caso, supongo que sería:

/templates/plantilla_3/index.php

Al ver el nombre de la plantilla presupongo que la has hecho tu o le has hecho modificaciones. Revisa la codificación del fichero index.php. Para ello puedes emplear el Notepadd++. La codificación apropiada debería de ser UTF-8.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/04/2011 9:02 am

wpdoctor-revisa-la-salud-de-tu-wordpress

J.Javier Bernárdez
 J.Javier Bernárdez
Usuario eminente

Hola,

he editado el archivo index.php y ya le he puesto la codificación utf-8, pero sigo con el mismo problema, adjunto una imagen para que se vea como aparece en facebook

Muchas gracias.

Javier

ResponderCitar
Respondido : 11/04/2011 9:40 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola J.Javier Bernárdez,

Veo que el módulo de Facebook de tu página ya muestra correctamente la codificación.

¿Cual era el problema?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/05/2011 7:43 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

J.Javier Bernárdez
 J.Javier Bernárdez
Usuario eminente

Hola,

el problema es cuando quiero poner un enlace de mi web en facebook, aparecen caracteres raros, como los que muestro en el texto del primer mensaje por ejemplo: Convención y declaración en lugar de convención y declaración, esto me ocurre con todos los artículos y con todas las palabras, ya sean del contenido o del título, que llevan tilde o ñ...

Por el momento no he sido capaz de solucionar el problema, algo he leído por ahí que eso se debe a la codificación, pero que yo sepa no he cambiado la codificación de UTF-8 en ningún momento.

Gracias por responder,

Javier

ResponderCitar
Respondido : 07/05/2011 7:02 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola J.Javier Bernárdez,

Preguntas importantes para poder estudiar el escenario de tu instalación:

- ¿Que versión de Joomla! estas utilizando?
- ¿Que script o extensión utilizas para Facebook?
- ¿Como introduces los enlaces "copiar/pegar" o mediante alguna extensión que envía los contenidos a Facebook?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/05/2011 7:09 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

J.Javier Bernárdez
 J.Javier Bernárdez
Usuario eminente

Hola,

estoy utilizando la última versión de joomla 1.5, el problema no surge con una extensión determinada, simplemente copio el enlace de una de mis páginas, abro mi facebook y pego el enlace, ahí es cuando me aparecen esos caracteres.

Gracias, un saludo.

Javier

ResponderCitar
Respondido : 07/05/2011 8:59 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola J.Javier Bernárdez,

Puedes indicar si eres tan amable un ejemplo de una de tus páginas donde copias el enlace y tu pagina de Facebook donde lo pegas para ver el comportamiento y poder evaluar el problema.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/05/2011 9:13 pm

Cursos Gratuitos WordPress

J.Javier Bernárdez
 J.Javier Bernárdez
Usuario eminente

Hola,

cualquier página, por ejemplo la de inicio: http://comunidad-internacional.com o esta otra en la que se ve el problema mejor (aunque sucede en todas): http://comunidad-internacional.com/index.php?option=com_content&view=article&id=137%3Alas-doce-hipotesis-de-una-estrategia-altermundista1&catid=35%3Apolitica-internacional-y-rrii&Itemid=76&lang=es

Adelanto que el problema no se debe a no haber puesto las urls como amigables para los buscadores.

Al pegar el enlace en facebook aparece lo que muestro en la imagen adjunta.

Un saludo y gracias por responder,

Javier

ResponderCitar
Respondido : 08/05/2011 4:01 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Javier

Tal como te comentó David anteriormente, el problema al parecer es por la codificación de los archivos, si has editado algún otro archivo a parte del index.php de tu template, sería bueno que revises nuevamente que tenga la codificación correcta.

Puedes verificar al ver el código fuente que por ejemplo en los keywords aparecer " Del, M�xico" , es decir sin tilde y en su lugar un caracter asciii

Si no puedes localizar los archivos, prueba cambiando de template, con eso te asegurarás de que el problema es en los archivos del template y tendrás el problema más enfocado.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/05/2011 1:27 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

J.Javier Bernárdez
 J.Javier Bernárdez
Usuario eminente

Hola,

sí, ya he probado cambiando de template y el problema continúa. He usado una de las templates que trae joomla por defecto y pasa exactamente lo mismo...

¿Habrá un problema en la codificación de la base de datos? Lo extraño es que no he cambiado en ningún momento la codificación, a no ser que se produjese el problema cuando restauré la página a partir de la copia hecha con akeeba backup... aunque esto me parece que no debería producirse.

Gracias por las respuestas.

Javier

ResponderCitar
Respondido : 09/05/2011 7:21 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola,

http://comunidad-internacional.com/index.php?option=com_content&view=article&id=137%3Alas-doce-hipotesis-de-una-estrategia-altermundista1&catid=35%3Apolitica-internacional-y-rrii&Itemid=76&lang=es no visualizó ningún enlace hacia Facebook.

Creo que si no es plantilla, y me parece que Joomla! no parece, ya que visualizando el sitio web no se visualizan caracteres extraños, el problema es de la aplicación que utilizas para enlazar con Facebook (Puede que este definida para trabajar con idioma inglés en el cual no existen acentos ni ñ).

Prueba a instalar otra extensión con funcionalidades similares para comprobar si sucede lo mismo. No nos has indicado que extensión es la que estás usando para enlazar con Facebook.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 09/05/2011 7:39 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

J.Javier Bernárdez
 J.Javier Bernárdez
Usuario eminente

Hola,

no utilizo ninguna aplicación para enlazar con facebook. El problema que comento es que cuando copio un enlace de mi página y lo pego manualmente en mi facebook como un enlace que recomiendo a mis amistades, aparecen esos caracteres... es decir, no es un problema de una extensión determinada. Cuando se recomienda manualmente un enlace, facebook normalmente busca una imagen de la página recomendada y un pequeño texto descriptivo, ese texto es el que a mi me sale con los caracteres que comento.

Gracias, un saludo.

Javier

PD: la única extensión de facebook que estoy usando es Face FanBox or LikeBox, pero lo que comento es otra cosa. Copio un hipervínculo y lo recomiendo en mi facebook manualmente.

ResponderCitar
Respondido : 09/05/2011 8:15 am
Página 1 / 2

Por favor Iniciar Sesión o Registro